summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-08 11:42:18 +0100
committerRemi Collet <remi@remirepo.net>2018-01-08 11:42:18 +0100
commite58449f98b7f28583b0a8d6efa91051261a53dd6 (patch)
treef10d8d9084254d0a0e461c7860495bce60850508
parent1daf80042a208bcfb91048aa589f6c895574da99 (diff)
v8.1.15
-rw-r--r--composer.json20
-rw-r--r--drush-issue2065.patch8
-rw-r--r--drush.spec9
3 files changed, 24 insertions, 13 deletions
diff --git a/composer.json b/composer.json
index 61f5ccb..2423d5d 100644
--- a/composer.json
+++ b/composer.json
@@ -38,16 +38,21 @@
"psy/psysh": "~0.6",
"consolidation/annotated-command": "~2",
"consolidation/output-formatters": "~3",
- "symfony/yaml": "~2.3",
- "symfony/var-dumper": "~2.7",
- "symfony/console": "~2.7",
- "symfony/event-dispatcher": "~2.7",
- "symfony/finder": "~2.7",
+ "symfony/yaml": "~2.3|^3",
+ "symfony/var-dumper": "~2.7|^3",
+ "symfony/console": "~2.7|^3",
+ "symfony/event-dispatcher": "~2.7|^3",
+ "symfony/finder": "~2.7|^3",
"pear/console_table": "~1.3.0",
"phpdocumentor/reflection-docblock": "^2.0",
"webmozart/path-util": "~2"
},
"require-dev": {
+ "symfony/var-dumper": "~2.7",
+ "symfony/console": "~2.7",
+ "symfony/event-dispatcher": "~2.7",
+ "symfony/finder": "~2.7",
+ "symfony/yaml": "~2.3",
"phpunit/phpunit": "4.*",
"symfony/process": "2.7.*"
},
@@ -66,6 +71,11 @@
"Unish": "tests/"
}
},
+ "scripts": {
+ "lint": [
+ "find includes -name '*.inc' -print0 | xargs -0 -n1 php -l"
+ ]
+ },
"extra": {
"branch-alias": {
"dev-master": "8.0.x-dev"
diff --git a/drush-issue2065.patch b/drush-issue2065.patch
index de8cebf..90b256d 100644
--- a/drush-issue2065.patch
+++ b/drush-issue2065.patch
@@ -2,13 +2,11 @@ diff --git a/includes/startup.inc b/includes/startup.inc
index 693fede..fedccbf 100644
--- a/includes/startup.inc
+++ b/includes/startup.inc
-@@ -326,8 +326,8 @@ function drush_startup($argv) {
- }
+@@ -383,7 +383,7 @@ function drush_startup($argv) {
}
-- // Always use pcntl_exec if it exists.
-- $use_pcntl_exec = function_exists("pcntl_exec");
-+ // https://github.com/drush-ops/drush/issues/2065
+ // Always use pcntl_exec if it exists.
+- $use_pcntl_exec = function_exists("pcntl_exec") && (strpos(ini_get('disable_functions'), 'pcntl_exec') === FALSE);
+ $use_pcntl_exec = FALSE;
// If we have posix_getppid, then pass in the shell pid so
diff --git a/drush.spec b/drush.spec
index 058b206..13f9981 100644
--- a/drush.spec
+++ b/drush.spec
@@ -12,8 +12,8 @@
%global github_owner drush-ops
%global github_name drush
-%global github_version 8.1.10
-%global github_commit 2192496b80aa9cdb0581a2d308623f950f747e94
+%global github_version 8.1.15
+%global github_commit f78b619806a9bc7c3d167fa425e8757eb046bb87
%global composer_vendor drush
%global composer_project drush
@@ -66,7 +66,7 @@
Name: %{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Command line shell and scripting interface for Drupal
Group: Development/Libraries
@@ -321,6 +321,9 @@ UNISH_DRUSH=%{buildroot}%{drush_dir}/drush \
%changelog
+* Mon Jan 8 2018 Remi Collet <remi@remirepo.net> - 8.1.15-1
+- Update to 8.1.15
+
* Mon Jan 8 2018 Remi Collet <remi@remirepo.net> - 8.1.10-3
- backport for remirepo
- use symfony package names