summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-01-08 11:19:33 +0100
committerRemi Collet <remi@remirepo.net>2018-01-08 11:19:33 +0100
commit1daf80042a208bcfb91048aa589f6c895574da99 (patch)
tree3f74931619f5f537b55a634ee0422930fa57d8ca
parentf7ae5ee83d54b1c5366329158ca3dd6780f43bd8 (diff)
backport for remirepo
use symfony package names
-rw-r--r--.gitignore8
-rw-r--r--Makefile3
-rw-r--r--composer.json74
-rw-r--r--drush.spec38
4 files changed, 101 insertions, 22 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..cd3c95f
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,3 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../common/Makefile
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..61f5ccb
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,74 @@
+{
+ "name": "drush/drush",
+ "description": "Drush is a command line shell and scripting interface for Drupal, a veritable Swiss Army knife designed to make life easier for those of us who spend some of our working hours hacking away at the command prompt.",
+ "homepage": "http://www.drush.org",
+ "license": "GPL-2.0+",
+ "minimum-stability": "stable",
+ "prefer-stable": true,
+ "authors": [
+ { "name": "Moshe Weitzman", "email": "weitzman@tejasa.com" },
+ { "name": "Owen Barton", "email": "drupal@owenbarton.com" },
+ { "name": "Mark Sonnabaum", "email": "marksonnabaum@gmail.com" },
+ { "name": "Antoine Beaupré", "email": "anarcat@koumbit.org" },
+ { "name": "Greg Anderson", "email": "greg.1.anderson@greenknowe.org" },
+ { "name": "Jonathan Araña Cruz", "email": "jonhattan@faita.net" },
+ { "name": "Jonathan Hedstrom", "email": "jhedstrom@gmail.com" },
+ { "name": "Christopher Gervais", "email": "chris@ergonlogic.com" },
+ { "name": "Dave Reid", "email": "dave@davereid.net" },
+ { "name": "Damian Lee", "email": "damiankloip@googlemail.com" }
+ ],
+ "support": {
+ "forum": "http://drupal.stackexchange.com/questions/tagged/drush",
+ "irc": "irc://irc.freenode.org/drush"
+ },
+ "bin": [
+ "drush",
+ "drush.launcher",
+ "drush.php",
+ "drush.complete.sh"
+ ],
+ "config": {
+ "platform": {
+ "php": "5.4.5"
+ }
+ },
+ "require": {
+ "php": ">=5.4.5",
+ "psr/log": "~1.0",
+ "psy/psysh": "~0.6",
+ "consolidation/annotated-command": "~2",
+ "consolidation/output-formatters": "~3",
+ "symfony/yaml": "~2.3",
+ "symfony/var-dumper": "~2.7",
+ "symfony/console": "~2.7",
+ "symfony/event-dispatcher": "~2.7",
+ "symfony/finder": "~2.7",
+ "pear/console_table": "~1.3.0",
+ "phpdocumentor/reflection-docblock": "^2.0",
+ "webmozart/path-util": "~2"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "4.*",
+ "symfony/process": "2.7.*"
+ },
+ "suggest": {
+ "ext-pcntl": "*",
+ "drush/config-extra": "Provides configuration workflow commands, such as config-merge."
+ },
+ "autoload": {
+ "psr-0": {
+ "Drush": "lib/",
+ "Consolidation": "lib/"
+ }
+ },
+ "autoload-dev": {
+ "psr-0": {
+ "Unish": "tests/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "8.0.x-dev"
+ }
+ }
+}
diff --git a/drush.spec b/drush.spec
index af9ae0a..058b206 100644
--- a/drush.spec
+++ b/drush.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for drush, from
#
# Fedora spec file for drush
#
@@ -99,18 +100,12 @@ BuildRequires: php-composer(psr/log) < %{psr_log_max_
BuildRequires: php-composer(psr/log) >= %{psr_log_min_ver}
BuildRequires: php-composer(psy/psysh) < %{psysh_min_ver}
BuildRequires: php-composer(psy/psysh) >= %{psysh_min_ver}
-BuildRequires: php-composer(symfony/console) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/console) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/event-dispatcher) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/event-dispatcher) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/finder) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/finder) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/process) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/process) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
-BuildRequires: php-composer(symfony/yaml) < %{symfony_max_ver}
-BuildRequires: php-composer(symfony/yaml) >= %{symfony_min_ver}
+BuildRequires: php-symfony-console
+BuildRequires: php-symfony-event-dispatcher
+BuildRequires: php-symfony-finder
+BuildRequires: php-symfony-process
+BuildRequires: php-symfony-var-dumper
+BuildRequires: php-symfonyyaml
BuildRequires: php-composer(webmozart/path-util) < %{webmozart_path_util_max_ver}
BuildRequires: php-composer(webmozart/path-util) >= %{webmozart_path_util_min_ver}
# phpcompatinfo (computed from version 8.1.10)
@@ -148,16 +143,11 @@ Requires: php-composer(psr/log) < %{psr_log_max_
Requires: php-composer(psr/log) >= %{psr_log_min_ver}
Requires: php-composer(psy/psysh) < %{psysh_max_ver}
Requires: php-composer(psy/psysh) >= %{psysh_min_ver}
-Requires: php-composer(symfony/console) < %{symfony_max_ver}
-Requires: php-composer(symfony/console) >= %{symfony_min_ver}
-Requires: php-composer(symfony/event-dispatcher) < %{symfony_max_ver}
-Requires: php-composer(symfony/event-dispatcher) >= %{symfony_min_ver}
-Requires: php-composer(symfony/finder) < %{symfony_max_ver}
-Requires: php-composer(symfony/finder) >= %{symfony_min_ver}
-Requires: php-composer(symfony/var-dumper) < %{symfony_max_ver}
-Requires: php-composer(symfony/var-dumper) >= %{symfony_min_ver}
-Requires: php-composer(symfony/yaml) < %{symfony_max_ver}
-Requires: php-composer(symfony/yaml) >= %{symfony_min_ver}
+Requires: php-symfony-console
+Requires: php-symfony-event-dispatcher
+Requires: php-symfony-finder
+Requires: php-symfony-var-dumper
+Requires: php-symfony-yaml
Requires: php-composer(webmozart/path-util) < %{webmozart_path_util_max_ver}
Requires: php-composer(webmozart/path-util) >= %{webmozart_path_util_min_ver}
# phpcompatinfo (computed from version 8.1.10)
@@ -331,6 +321,10 @@ UNISH_DRUSH=%{buildroot}%{drush_dir}/drush \
%changelog
+* Mon Jan 8 2018 Remi Collet <remi@remirepo.net> - 8.1.10-3
+- backport for remirepo
+- use symfony package names
+
* Wed Jul 26 2017 Fedora Release Engineering <releng@fedoraproject.org> - 8.1.10-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild