summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec23
-rw-r--r--installed.json73
3 files changed, 54 insertions, 44 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 8e97096..c94bcf5 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.3")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.6")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index d0c7095..c249fa9 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit e49be96f3bccd183c9ff1313686c06cf898ba4be
+%global gh_commit fabd995783b633829fd4280e272284b39b6ae702
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.3
+%global upstream_version 2.7.6
#global upstream_prever RC1
#global upstream_lower rc1
@@ -94,10 +94,10 @@ Provides: bundled(php-react-promise) = v3.1.0
Provides: bundled(php-seld-jsonlint) = 1.10.2
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.36
+Provides: bundled(php-symfony-console) = v5.4.39
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.3
-Provides: bundled(php-symfony-filesystem) = v5.4.38
-Provides: bundled(php-symfony-finder) = v5.4.35
+Provides: bundled(php-symfony-filesystem) = v5.4.39
+Provides: bundled(php-symfony-finder) = v5.4.39
Provides: bundled(php-symfony-polyfill-ctype) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.29.0
Provides: bundled(php-symfony-polyfill-intl-normalizer) = v1.29.0
@@ -105,9 +105,9 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
Provides: bundled(php-symfony-polyfill-php73) = v1.29.0
Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
-Provides: bundled(php-symfony-process) = v5.4.36
+Provides: bundled(php-symfony-process) = v5.4.39
Provides: bundled(php-symfony-service-contracts) = v2.5.3
-Provides: bundled(php-symfony-string) = v5.4.36
+Provides: bundled(php-symfony-string) = v5.4.39
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,15 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Sun May 5 2024 Remi Collet <remi@remirepo.net> - 2.7.6-1
+- update to 2.7.6
+
+* Sat May 4 2024 Remi Collet <remi@remirepo.net> - 2.7.5-1
+- update to 2.7.5
+
+* Tue Apr 23 2024 Remi Collet <remi@remirepo.net> - 2.7.4-1
+- update to 2.7.4
+
* Sat Apr 20 2024 Remi Collet <remi@remirepo.net> - 2.7.3-1
- update to 2.7.3
diff --git a/installed.json b/installed.json
index 903fb91..6d25688 100644
--- a/installed.json
+++ b/installed.json
@@ -974,17 +974,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.36",
- "version_normalized": "5.4.36.0",
+ "version": "v5.4.39",
+ "version_normalized": "5.4.39.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e"
+ "reference": "f3e591c48688a0cfa1a3296205926c05e84b22b1"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e",
- "reference": "39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e",
+ "url": "https://api.github.com/repos/symfony/console/zipball/f3e591c48688a0cfa1a3296205926c05e84b22b1",
+ "reference": "f3e591c48688a0cfa1a3296205926c05e84b22b1",
"shasum": ""
},
"require": {
@@ -1022,7 +1022,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-02-20T16:33:57+00:00",
+ "time": "2024-04-18T08:26:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1056,7 +1056,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.36"
+ "source": "https://github.com/symfony/console/tree/v5.4.39"
},
"funding": [
{
@@ -1146,26 +1146,27 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.38",
- "version_normalized": "5.4.38.0",
+ "version": "v5.4.39",
+ "version_normalized": "5.4.39.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "899330a01056077271e2f614c7b28b0379a671eb"
+ "reference": "e6edd875d5d39b03de51f3c3951148cfa79a4d12"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/899330a01056077271e2f614c7b28b0379a671eb",
- "reference": "899330a01056077271e2f614c7b28b0379a671eb",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/e6edd875d5d39b03de51f3c3951148cfa79a4d12",
+ "reference": "e6edd875d5d39b03de51f3c3951148cfa79a4d12",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-ctype": "~1.8",
"symfony/polyfill-mbstring": "~1.8",
- "symfony/polyfill-php80": "^1.16"
+ "symfony/polyfill-php80": "^1.16",
+ "symfony/process": "^5.4|^6.4"
},
- "time": "2024-03-21T08:05:07+00:00",
+ "time": "2024-04-18T08:26:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1193,7 +1194,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.38"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.39"
},
"funding": [
{
@@ -1213,17 +1214,17 @@
},
{
"name": "symfony/finder",
- "version": "v5.4.35",
- "version_normalized": "5.4.35.0",
+ "version": "v5.4.39",
+ "version_normalized": "5.4.39.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/finder.git",
- "reference": "abe6d6f77d9465fed3cd2d029b29d03b56b56435"
+ "reference": "f6a96e4fcd468a25fede16ee665f50ced856bd0a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/finder/zipball/abe6d6f77d9465fed3cd2d029b29d03b56b56435",
- "reference": "abe6d6f77d9465fed3cd2d029b29d03b56b56435",
+ "url": "https://api.github.com/repos/symfony/finder/zipball/f6a96e4fcd468a25fede16ee665f50ced856bd0a",
+ "reference": "f6a96e4fcd468a25fede16ee665f50ced856bd0a",
"shasum": ""
},
"require": {
@@ -1231,7 +1232,7 @@
"symfony/deprecation-contracts": "^2.1|^3",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-01-23T13:51:25+00:00",
+ "time": "2024-04-18T08:26:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1259,7 +1260,7 @@
"description": "Finds files and directories via an intuitive fluent interface",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/finder/tree/v5.4.35"
+ "source": "https://github.com/symfony/finder/tree/v5.4.39"
},
"funding": [
{
@@ -1850,24 +1851,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.36",
- "version_normalized": "5.4.36.0",
+ "version": "v5.4.39",
+ "version_normalized": "5.4.39.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "4fdf34004f149cc20b2f51d7d119aa500caad975"
+ "reference": "85a554acd7c28522241faf2e97b9541247a0d3d5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/4fdf34004f149cc20b2f51d7d119aa500caad975",
- "reference": "4fdf34004f149cc20b2f51d7d119aa500caad975",
+ "url": "https://api.github.com/repos/symfony/process/zipball/85a554acd7c28522241faf2e97b9541247a0d3d5",
+ "reference": "85a554acd7c28522241faf2e97b9541247a0d3d5",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-02-12T15:49:53+00:00",
+ "time": "2024-04-18T08:26:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1895,7 +1896,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.36"
+ "source": "https://github.com/symfony/process/tree/v5.4.39"
},
"funding": [
{
@@ -2001,17 +2002,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.36",
- "version_normalized": "5.4.36.0",
+ "version": "v5.4.39",
+ "version_normalized": "5.4.39.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "4e232c83622bd8cd32b794216aa29d0d266d353b"
+ "reference": "495e71bae5862308051b9e63cc3e34078eed83ef"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/4e232c83622bd8cd32b794216aa29d0d266d353b",
- "reference": "4e232c83622bd8cd32b794216aa29d0d266d353b",
+ "url": "https://api.github.com/repos/symfony/string/zipball/495e71bae5862308051b9e63cc3e34078eed83ef",
+ "reference": "495e71bae5862308051b9e63cc3e34078eed83ef",
"shasum": ""
},
"require": {
@@ -2031,7 +2032,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-02-01T08:49:30+00:00",
+ "time": "2024-04-18T08:26:06+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2070,7 +2071,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.36"
+ "source": "https://github.com/symfony/string/tree/v5.4.39"
},
"funding": [
{