summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-03-12 07:18:23 +0100
committerRemi Collet <remi@php.net>2024-03-12 07:18:23 +0100
commitaed1b1b8b9b6694c59ea2de2278b62592841f384 (patch)
tree0aabcff5cccdb7ee786ba6ebd931edb7bdcca043
parente8358fdff3395bfd71ca89b41510ca254c80f8d6 (diff)
update to 2.7.2HEADmaster
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec19
-rw-r--r--installed.json70
3 files changed, 47 insertions, 44 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index d9af6f6..7b1d166 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.1")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.7.2")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index b3437ae..3d04281 100644
--- a/composer.spec
+++ b/composer.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for composer
#
-# Copyright (c) 2015-2023 Remi Collet
+# Copyright (c) 2015-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit aaf6ed5ccd27c23f79a545e351b4d7842a99d0bc
+%global gh_commit b826edb791571ab1eaf281eb1bd6e181a1192adc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.7.1
+%global upstream_version 2.7.2
#global upstream_prever RC1
#global upstream_lower rc1
@@ -80,10 +80,10 @@ Requires: php-cli
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.4.0
+Provides: bundled(php-composer-ca-bundle) = 1.4.1
Provides: bundled(php-composer-class-map-generator) = 1.1.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.1.1
+Provides: bundled(php-composer-pcre) = 2.1.2
Provides: bundled(php-composer-semver) = 3.4.0
Provides: bundled(php-composer-spdx-licenses) = 1.5.8
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
@@ -94,7 +94,7 @@ Provides: bundled(php-react-promise) = v3.1.0
Provides: bundled(php-seld-jsonlint) = 1.10.2
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.35
+Provides: bundled(php-symfony-console) = v5.4.36
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.35
Provides: bundled(php-symfony-finder) = v5.4.35
@@ -105,9 +105,9 @@ Provides: bundled(php-symfony-polyfill-mbstring) = v1.29.0
Provides: bundled(php-symfony-polyfill-php73) = v1.29.0
Provides: bundled(php-symfony-polyfill-php80) = v1.29.0
Provides: bundled(php-symfony-polyfill-php81) = v1.29.0
-Provides: bundled(php-symfony-process) = v5.4.35
+Provides: bundled(php-symfony-process) = v5.4.36
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.35
+Provides: bundled(php-symfony-string) = v5.4.36
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Tue Mar 12 2024 Remi Collet <remi@remirepo.net> - 2.7.2-1
+- update to 2.7.2
+
* Sat Feb 10 2024 Remi Collet <remi@remirepo.net> - 2.7.1-1
- update to 2.7.1
diff --git a/installed.json b/installed.json
index 30d6fcc..2cce862 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.4.0",
- "version_normalized": "1.4.0.0",
+ "version": "1.4.1",
+ "version_normalized": "1.4.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "b66d11b7479109ab547f9405b97205640b17d385"
+ "reference": "3ce240142f6d59b808dd65c1f52f7a1c252e6cfd"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/b66d11b7479109ab547f9405b97205640b17d385",
- "reference": "b66d11b7479109ab547f9405b97205640b17d385",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/3ce240142f6d59b808dd65c1f52f7a1c252e6cfd",
+ "reference": "3ce240142f6d59b808dd65c1f52f7a1c252e6cfd",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0 || ^7.0"
},
- "time": "2023-12-18T12:05:55+00:00",
+ "time": "2024-02-23T10:16:52+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.4.0"
+ "source": "https://github.com/composer/ca-bundle/tree/1.4.1"
},
"funding": [
{
@@ -229,17 +229,17 @@
},
{
"name": "composer/pcre",
- "version": "2.1.1",
- "version_normalized": "2.1.1.0",
+ "version": "2.1.2",
+ "version_normalized": "2.1.2.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "b439557066cd445732fa57cbc8d905394b4db8a0"
+ "reference": "02b8774a434b1b71edd8824440ceac1e3e49ee2b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/b439557066cd445732fa57cbc8d905394b4db8a0",
- "reference": "b439557066cd445732fa57cbc8d905394b4db8a0",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/02b8774a434b1b71edd8824440ceac1e3e49ee2b",
+ "reference": "02b8774a434b1b71edd8824440ceac1e3e49ee2b",
"shasum": ""
},
"require": {
@@ -250,7 +250,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^5"
},
- "time": "2023-10-11T07:10:55+00:00",
+ "time": "2024-03-07T14:52:56+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -283,7 +283,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.1.1"
+ "source": "https://github.com/composer/pcre/tree/2.1.2"
},
"funding": [
{
@@ -974,17 +974,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.35",
- "version_normalized": "5.4.35.0",
+ "version": "v5.4.36",
+ "version_normalized": "5.4.36.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "dbdf6adcb88d5f83790e1efb57ef4074309d3931"
+ "reference": "39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/dbdf6adcb88d5f83790e1efb57ef4074309d3931",
- "reference": "dbdf6adcb88d5f83790e1efb57ef4074309d3931",
+ "url": "https://api.github.com/repos/symfony/console/zipball/39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e",
+ "reference": "39f75d9d73d0c11952fdcecf4877b4d0f62a8f6e",
"shasum": ""
},
"require": {
@@ -1022,7 +1022,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2024-01-23T14:28:09+00:00",
+ "time": "2024-02-20T16:33:57+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1056,7 +1056,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.35"
+ "source": "https://github.com/symfony/console/tree/v5.4.36"
},
"funding": [
{
@@ -1850,24 +1850,24 @@
},
{
"name": "symfony/process",
- "version": "v5.4.35",
- "version_normalized": "5.4.35.0",
+ "version": "v5.4.36",
+ "version_normalized": "5.4.36.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/process.git",
- "reference": "cbc28e34015ad50166fc2f9c8962d28d0fe861eb"
+ "reference": "4fdf34004f149cc20b2f51d7d119aa500caad975"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/process/zipball/cbc28e34015ad50166fc2f9c8962d28d0fe861eb",
- "reference": "cbc28e34015ad50166fc2f9c8962d28d0fe861eb",
+ "url": "https://api.github.com/repos/symfony/process/zipball/4fdf34004f149cc20b2f51d7d119aa500caad975",
+ "reference": "4fdf34004f149cc20b2f51d7d119aa500caad975",
"shasum": ""
},
"require": {
"php": ">=7.2.5",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2024-01-23T13:51:25+00:00",
+ "time": "2024-02-12T15:49:53+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1895,7 +1895,7 @@
"description": "Executes commands in sub-processes",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/process/tree/v5.4.35"
+ "source": "https://github.com/symfony/process/tree/v5.4.36"
},
"funding": [
{
@@ -2001,17 +2001,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.35",
- "version_normalized": "5.4.35.0",
+ "version": "v5.4.36",
+ "version_normalized": "5.4.36.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "c209c4d0559acce1c9a2067612cfb5d35756edc2"
+ "reference": "4e232c83622bd8cd32b794216aa29d0d266d353b"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/c209c4d0559acce1c9a2067612cfb5d35756edc2",
- "reference": "c209c4d0559acce1c9a2067612cfb5d35756edc2",
+ "url": "https://api.github.com/repos/symfony/string/zipball/4e232c83622bd8cd32b794216aa29d0d266d353b",
+ "reference": "4e232c83622bd8cd32b794216aa29d0d266d353b",
"shasum": ""
},
"require": {
@@ -2031,7 +2031,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2024-01-23T13:51:25+00:00",
+ "time": "2024-02-01T08:49:30+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2070,7 +2070,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.35"
+ "source": "https://github.com/symfony/string/tree/v5.4.36"
},
"funding": [
{