summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-10-15 08:15:59 +0200
committerRemi Collet <remi@php.net>2022-10-15 08:15:59 +0200
commit237fe66bb10f0a8841b607dd8429376821201a83 (patch)
treee9fca7745c9024f880aa220eda952c6023627a6a
parent8753f7bb49196d7958821071656d7e883f61d4ee (diff)
update to 2.4.3
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.spec195
-rw-r--r--installed.json56
3 files changed, 39 insertions, 214 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index d103438..1b05e29 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -24,7 +24,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.4.2")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.4.3")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.spec b/composer.spec
index 9b461eb..13994da 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,15 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%if 0
-%bcond_without tests
-%bcond_without syslib
-%else
-%bcond_with tests
-%bcond_with syslib
-%endif
-
-%global gh_commit 7d887621e69a0311eb50aed4a16f7044b2b385b9
+%global gh_commit b34c0e9a93f2cd688c62ce4dfcc69e13b6ce7aa4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,14 +18,10 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.4.2
+%global upstream_version 2.4.3
#global upstream_prever RC1
#global upstream_lower rc1
-%global symfony_prefix php-symfony5
-%global symfony_path %{_datadir}/php/Symfony5
-%global symfony_min 5.4.1
-
%global _phpunit %{_bindir}/phpunit9
%global bashcompdir %(pkg-config --variable=completionsdir bash-completion 2>/dev/null)
%global bashcomproot %(dirname %{bashcompdir} 2>/dev/null)
@@ -66,46 +54,6 @@ BuildRequires: php(language) >= 7.2.5
BuildRequires: php-cli
BuildRequires: php-json
BuildRequires: pkgconfig(bash-completion)
-%if %{with tests}
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)
-BuildRequires: (php-composer(composer/metadata-minifier) >= 1.0 with php-composer(composer/metadata-minifier) < 2)
-BuildRequires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
-BuildRequires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
-BuildRequires: (php-composer(composer/xdebug-handler) >= 2.0.2 with php-composer(composer/xdebug-handler) < 4)
-BuildRequires: (php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2)
-BuildRequires: (php-composer(seld/phar-utils) >= 1.2 with php-composer(seld/phar-utils) < 2)
-BuildRequires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 4)
-BuildRequires: (php-composer(justinrainbow/json-schema) >= 5.2.11 with php-composer(justinrainbow/json-schema) < 6)
-BuildRequires: (php-composer(react/promise) >= 2.7 with php-composer(react/promise) < 3)
-BuildRequires: (php-composer(composer/pcre) >= 2 with php-composer(composer/pcre) < 4)
-# remirepo:13
-%else
-BuildRequires: php-composer-ca-bundle
-BuildRequires: php-composer-metadata-minifier
-BuildRequires: php-composer-semver3
-BuildRequires: php-composer-spdx-licenses >= 1.2
-BuildRequires: php-composer-xdebug-handler2 >= 2.0.2
-BuildRequires: php-jsonlint >= 1.4
-BuildRequires: php-seld-phar-utils >= 1.2
-BuildRequires: php-PsrLog >= 1.1
-BuildRequires: php-justinrainbow-json-schema5 >= 5.2.11
-BuildRequires: php-react-promise >= 2.7
-BuildRequires: php-composer-pcre3
-%endif
-BuildRequires: %{symfony_prefix}-console >= %{symfony_min}
-BuildRequires: %{symfony_prefix}-finder >= %{symfony_min}
-BuildRequires: %{symfony_prefix}-filesystem >= %{symfony_min}
-BuildRequires: %{symfony_prefix}-process >= %{symfony_min}
-BuildRequires: php-zip
-# From composer.json, "require-dev": {
-# "symfony/phpunit-bridge": "^4.2 || ^5.0 || ^6.0",
-# "phpspec/prophecy": "^1.10"
-BuildRequires: %{_phpunit}
-# For autoloader
-BuildRequires: php-fedora-autoloader-devel
-%endif
# From composer.json, "require": {
# "php": "^7.2.5 || ^8.0",
@@ -128,46 +76,11 @@ BuildRequires: php-fedora-autoloader-devel
# "symfony/polyfill-php80": "^1.24"
Requires: php(language) >= 7.2.5
Requires: php-cli
-%if %{with syslib}
-# remirepo:1
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-Requires: (php-composer(composer/ca-bundle) >= 1.0 with php-composer(composer/ca-bundle) < 2)
-Requires: (php-composer(composer/metadata-minifier) >= 1.0 with php-composer(composer/metadata-minifier) < 2)
-Requires: (php-composer(composer/semver) >= 3.0 with php-composer(composer/semver) < 4)
-Requires: (php-composer(composer/spdx-licenses) >= 1.2 with php-composer(composer/spdx-licenses) < 2)
-Requires: (php-composer(composer/xdebug-handler) >= 2.0.2 with php-composer(composer/xdebug-handler) < 4)
-Requires: (php-composer(seld/jsonlint) >= 1.4 with php-composer(seld/jsonlint) < 2)
-Requires: (php-composer(seld/phar-utils) >= 1.2 with php-composer(seld/phar-utils) < 2)
-Requires: (php-composer(psr/log) >= 1.1 with php-composer(psr/log) < 4)
-Requires: (php-composer(justinrainbow/json-schema) >= 5.2.11 with php-composer(justinrainbow/json-schema) < 6)
-Requires: (php-composer(react/promise) >= 2.7 with php-composer(react/promise) < 3)
-Requires: (php-composer(composer/pcre) >= 2 with php-composer(composer/pcre) < 4)
-# remirepo:13
-%else
-Requires: php-composer-ca-bundle
-Requires: php-composer-metadata-minifier
-Requires: php-composer-semver3
-Requires: php-composer-spdx-licenses >= 1.2
-Requires: php-composer-xdebug-handler2 >= 2.0.2
-Requires: php-jsonlint >= 1.4
-Requires: php-seld-phar-utils >= 1.2
-Requires: php-PsrLog >= 1.1
-Requires: php-justinrainbow-json-schema5 >= 5.2.11
-Requires: php-react-promise >= 2.7
-Requires: php-composer-pcre3
-%endif
-Requires: %{symfony_prefix}-console >= %{symfony_min}
-Requires: %{symfony_prefix}-finder >= %{symfony_min}
-Requires: %{symfony_prefix}-process >= %{symfony_min}
-Requires: %{symfony_prefix}-filesystem >= %{symfony_min}
-# For our autoloader
-Requires: php-composer(fedora/autoloader)
-%else
# System certificates
Requires: ca-certificates
# Bundled libraries
# License MIT
-Provides: bundled(php-composer-ca-bundle) = 1.3.3
+Provides: bundled(php-composer-ca-bundle) = 1.3.4
Provides: bundled(php-composer-class-map-generator) = 1.0.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
Provides: bundled(php-composer-pcre) = 2.0.0
@@ -181,9 +94,9 @@ Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
-Provides: bundled(php-symfony-console) = v5.4.12
+Provides: bundled(php-symfony-console) = v5.4.14
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
-Provides: bundled(php-symfony-filesystem) = v5.4.12
+Provides: bundled(php-symfony-filesystem) = v5.4.13
Provides: bundled(php-symfony-finder) = v5.4.11
Provides: bundled(php-symfony-polyfill-ctype) = v1.26.0
Provides: bundled(php-symfony-polyfill-intl-grapheme) = v1.26.0
@@ -193,8 +106,8 @@ Provides: bundled(php-symfony-polyfill-php73) = v1.26.0
Provides: bundled(php-symfony-polyfill-php80) = v1.26.0
Provides: bundled(php-symfony-process) = v5.4.11
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.12
-%endif
+Provides: bundled(php-symfony-string) = v5.4.14
+
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
# "ext-zip": "Enabling the zip extension allows you to unzip archives",
@@ -253,47 +166,6 @@ fi
rm src/bootstrap.php
rm src/Composer/vendor/composer/ca-bundle/res/cacert.pem
-%if %{with syslib}
-rm -rf src/Composer/vendor
-
-phpab --template fedora --output src/Composer/autoload.php src/Composer
-cat << 'EOF' | tee -a src/Composer/autoload.php
-
-\Fedora\Autoloader\Dependencies::required([
- [ /* before symfony which load composer */
- '%{_datadir}/php/Composer/XdebugHandler3/autoload.php',
- '%{_datadir}/php/Composer/XdebugHandler2/autoload.php',
- ],
- '%{symfony_path}/Component/Console/autoload.php',
- '%{symfony_path}/Component/Finder/autoload.php',
- '%{symfony_path}/Component/Process/autoload.php',
- '%{symfony_path}/Component/Filesystem/autoload.php',
- '%{_datadir}/php/Seld/JsonLint/autoload.php',
- '%{_datadir}/php/Seld/PharUtils/autoload.php',
- '%{_datadir}/php/Composer/CaBundle/autoload.php',
- '%{_datadir}/php/Composer/Spdx/autoload.php',
- '%{_datadir}/php/Composer/MetadataMinifier/autoload.php',
- '%{_datadir}/php/Composer/Semver3/autoload.php',
- [
- '%{_datadir}/php/Composer/Pcre3/autoload.php',
- '%{_datadir}/php/Composer/Pcre2/autoload.php',
- ], [
- '%{_datadir}/php/Psr/Log3/autoload.php',
- '%{_datadir}/php/Psr/Log2/autoload.php',
- '%{_datadir}/php/Psr/Log/autoload.php',
- ],
- '%{_datadir}/php/JsonSchema5/autoload.php',
- '%{_datadir}/php/React/Promise/autoload.php',
-]);
-EOF
-
-cat << 'EOF' | tee tests/bootstrap.php
-<?php
-require 'Composer/autoload.php';
-\Fedora\Autoloader\Autoload::addPsr0('Composer\\Test\\', __DIR__ . '/');
-EOF
-
-%else
: symlink autoloader for library
ln -s vendor/autoload.php src/Composer/autoload.php
@@ -319,20 +191,10 @@ php -r '
printf("# License %s\n%s\n", $lic, implode("\n", $lib));
}
'
-%endif
: fix reported version
-%if 0%{?gh_date}
-DATE=%{gh_date}
-DATE=${DATE:0:4}-${DATE:4:2}-${DATE:6:2}
-sed -e '/VERSION/s/@package_version@/%{gh_commit}/' \
- -e '/BRANCH_ALIAS_VERSION/s/@package_branch_alias_version@/%{gh_branch}/' \
- -e "/RELEASE_DATE/s/@release_date@/$DATE/" \
- -i src/Composer/Composer.php
-%else
sed -e '/BRANCH_ALIAS_VERSION/s/@package_branch_alias_version@//' \
-i src/Composer/Composer.php
-%endif
: check Plugin API version
php -r '
@@ -373,46 +235,6 @@ ln -sf %{_datadir}/%{name}/LICENSE LICENSE
install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
-%check
-%if %{with tests} && %{with syslib}
-: Online tests
-rm tests/Composer/Test/Util/RemoteFilesystemTest.php
-
-: Ensure not used
-rm -rf res
-
-: Run test suite
-export BUILDROOT=%{buildroot}
-
-# testSearchWithSpecialChars is online
-# testCreateMap fails on 8.1
-# testOutputIgnoresFormatting use InstalledVersions
-FILTER="--filter '^((?!(testIntegration|testSearchWithSpecialChars|testCreateMap|testOutputIgnoresFormatting)).)*$'"
-
-# Adapt for phunit9
-find tests \
- -name \*.php \
- -exec sed -e '/function setUpBeforeClass(/s/$/:void/' \
- -e '/function tearDownAfterClass(/s/$/:void/' \
- -e '/function setUp(/s/$/:void/' \
- -e '/function tearDown(/s/$/:void/' \
- -i {} \;
-
-# testIntegration may hang on local build
-ret=0
-for cmd in php php74 php80 php81; do
- if which $cmd; then
- $cmd -d memory_limit=1G %{_phpunit} \
- $FILTER \
- --include-path %{buildroot}%{_datadir}/php || ret=1
- fi
-done
-exit $ret
-%else
-: Test suite disabled
-%endif
-
-
%files
%{!?_licensedir:%global license %%doc}
%license LICENSE
@@ -426,6 +248,9 @@ exit $ret
%changelog
+* Sat Oct 15 2022 Remi Collet <remi@remirepo.net> - 2.4.3-1
+- update to 2.4.3
+
* Thu Sep 15 2022 Remi Collet <remi@remirepo.net> - 2.4.2-1
- update to 2.4.2
diff --git a/installed.json b/installed.json
index 5fa078f..459b3d4 100644
--- a/installed.json
+++ b/installed.json
@@ -2,17 +2,17 @@
"packages": [
{
"name": "composer/ca-bundle",
- "version": "1.3.3",
- "version_normalized": "1.3.3.0",
+ "version": "1.3.4",
+ "version_normalized": "1.3.4.0",
"source": {
"type": "git",
"url": "https://github.com/composer/ca-bundle.git",
- "reference": "30897edbfb15e784fe55587b4f73ceefd3c4d98c"
+ "reference": "69098eca243998b53eed7a48d82dedd28b447cd5"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/ca-bundle/zipball/30897edbfb15e784fe55587b4f73ceefd3c4d98c",
- "reference": "30897edbfb15e784fe55587b4f73ceefd3c4d98c",
+ "url": "https://api.github.com/repos/composer/ca-bundle/zipball/69098eca243998b53eed7a48d82dedd28b447cd5",
+ "reference": "69098eca243998b53eed7a48d82dedd28b447cd5",
"shasum": ""
},
"require": {
@@ -26,7 +26,7 @@
"symfony/phpunit-bridge": "^4.2 || ^5",
"symfony/process": "^2.5 || ^3.0 || ^4.0 || ^5.0 || ^6.0"
},
- "time": "2022-07-20T07:14:26+00:00",
+ "time": "2022-10-12T12:08:29+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -61,7 +61,7 @@
"support": {
"irc": "irc://irc.freenode.org/composer",
"issues": "https://github.com/composer/ca-bundle/issues",
- "source": "https://github.com/composer/ca-bundle/tree/1.3.3"
+ "source": "https://github.com/composer/ca-bundle/tree/1.3.4"
},
"funding": [
{
@@ -977,17 +977,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.14",
+ "version_normalized": "5.4.14.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "c072aa8f724c3af64e2c7a96b796a4863d24dba1"
+ "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/c072aa8f724c3af64e2c7a96b796a4863d24dba1",
- "reference": "c072aa8f724c3af64e2c7a96b796a4863d24dba1",
+ "url": "https://api.github.com/repos/symfony/console/zipball/984ea2c0f45f42dfed01d2f3987b187467c4b16d",
+ "reference": "984ea2c0f45f42dfed01d2f3987b187467c4b16d",
"shasum": ""
},
"require": {
@@ -1025,7 +1025,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2022-08-17T13:18:05+00:00",
+ "time": "2022-10-07T08:01:20+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1059,7 +1059,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.12"
+ "source": "https://github.com/symfony/console/tree/v5.4.14"
},
"funding": [
{
@@ -1149,17 +1149,17 @@
},
{
"name": "symfony/filesystem",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.13",
+ "version_normalized": "5.4.13.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/filesystem.git",
- "reference": "2d67c1f9a1937406a9be3171b4b22250c0a11447"
+ "reference": "ac09569844a9109a5966b9438fc29113ce77cf51"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/filesystem/zipball/2d67c1f9a1937406a9be3171b4b22250c0a11447",
- "reference": "2d67c1f9a1937406a9be3171b4b22250c0a11447",
+ "url": "https://api.github.com/repos/symfony/filesystem/zipball/ac09569844a9109a5966b9438fc29113ce77cf51",
+ "reference": "ac09569844a9109a5966b9438fc29113ce77cf51",
"shasum": ""
},
"require": {
@@ -1168,7 +1168,7 @@
"symfony/polyfill-mbstring": "~1.8",
"symfony/polyfill-php80": "^1.16"
},
- "time": "2022-08-02T13:48:16+00:00",
+ "time": "2022-09-21T19:53:16+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1196,7 +1196,7 @@
"description": "Provides basic utilities for the filesystem",
"homepage": "https://symfony.com",
"support": {
- "source": "https://github.com/symfony/filesystem/tree/v5.4.12"
+ "source": "https://github.com/symfony/filesystem/tree/v5.4.13"
},
"funding": [
{
@@ -1943,17 +1943,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.12",
- "version_normalized": "5.4.12.0",
+ "version": "v5.4.14",
+ "version_normalized": "5.4.14.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "2fc515e512d721bf31ea76bd02fe23ada4640058"
+ "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/2fc515e512d721bf31ea76bd02fe23ada4640058",
- "reference": "2fc515e512d721bf31ea76bd02fe23ada4640058",
+ "url": "https://api.github.com/repos/symfony/string/zipball/089e7237497fae7a9c404d0c3aeb8db3254733e4",
+ "reference": "089e7237497fae7a9c404d0c3aeb8db3254733e4",
"shasum": ""
},
"require": {
@@ -1973,7 +1973,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2022-08-12T17:03:11+00:00",
+ "time": "2022-10-05T15:16:54+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2012,7 +2012,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.12"
+ "source": "https://github.com/symfony/string/tree/v5.4.14"
},
"funding": [
{