summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-09-15 07:57:32 +0200
committerRemi Collet <remi@php.net>2022-09-15 07:57:32 +0200
commit8753f7bb49196d7958821071656d7e883f61d4ee (patch)
tree093111adca6ae10a646b53b330364ca0bb6c60ae
parenta60f6e31ff5dc501e2e96590aab2f09d13a2653c (diff)
update to 2.4.2
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.json2
-rw-r--r--composer.spec9
-rw-r--r--installed.json14
4 files changed, 15 insertions, 12 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 4aed20f..d103438 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -24,7 +24,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.4.1")
+ local completecmd=("$sf_cmd" "_complete" "-sbash" "-c$cword" "-S2.4.2")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.json b/composer.json
index 85fbff5..780f051 100644
--- a/composer.json
+++ b/composer.json
@@ -49,7 +49,7 @@
"phpstan/phpstan-phpunit": "^1.0",
"phpstan/phpstan-deprecation-rules": "^1",
"phpstan/phpstan-strict-rules": "^1",
- "phpstan/phpstan-symfony": "^1.1"
+ "phpstan/phpstan-symfony": "^1.2.10"
},
"suggest": {
"ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
diff --git a/composer.spec b/composer.spec
index 6067b97..9b461eb 100644
--- a/composer.spec
+++ b/composer.spec
@@ -18,7 +18,7 @@
%bcond_with syslib
%endif
-%global gh_commit 777d542e3af65f8e7a66a4d98ce7a697da339414
+%global gh_commit 7d887621e69a0311eb50aed4a16f7044b2b385b9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -26,7 +26,7 @@
%global api_version 2.3.0
%global run_version 2.2.2
-%global upstream_version 2.4.1
+%global upstream_version 2.4.2
#global upstream_prever RC1
#global upstream_lower rc1
@@ -179,7 +179,7 @@ Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
Provides: bundled(php-react-promise) = v2.9.0
Provides: bundled(php-seld-jsonlint) = 1.9.0
-Provides: bundled(php-seld-phar-utils) = 1.2.0
+Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.1
Provides: bundled(php-symfony-console) = v5.4.12
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
@@ -426,6 +426,9 @@ exit $ret
%changelog
+* Thu Sep 15 2022 Remi Collet <remi@remirepo.net> - 2.4.2-1
+- update to 2.4.2
+
* Mon Aug 29 2022 Remi Collet <remi@remirepo.net> - 2.4.1-1
- update to 2.4.1
diff --git a/installed.json b/installed.json
index c299172..5fa078f 100644
--- a/installed.json
+++ b/installed.json
@@ -862,23 +862,23 @@
},
{
"name": "seld/phar-utils",
- "version": "1.2.0",
- "version_normalized": "1.2.0.0",
+ "version": "1.2.1",
+ "version_normalized": "1.2.1.0",
"source": {
"type": "git",
"url": "https://github.com/Seldaek/phar-utils.git",
- "reference": "9f3452c93ff423469c0d56450431562ca423dcee"
+ "reference": "ea2f4014f163c1be4c601b9b7bd6af81ba8d701c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/Seldaek/phar-utils/zipball/9f3452c93ff423469c0d56450431562ca423dcee",
- "reference": "9f3452c93ff423469c0d56450431562ca423dcee",
+ "url": "https://api.github.com/repos/Seldaek/phar-utils/zipball/ea2f4014f163c1be4c601b9b7bd6af81ba8d701c",
+ "reference": "ea2f4014f163c1be4c601b9b7bd6af81ba8d701c",
"shasum": ""
},
"require": {
"php": ">=5.3"
},
- "time": "2021-12-10T11:20:11+00:00",
+ "time": "2022-08-31T10:31:18+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -907,7 +907,7 @@
],
"support": {
"issues": "https://github.com/Seldaek/phar-utils/issues",
- "source": "https://github.com/Seldaek/phar-utils/tree/1.2.0"
+ "source": "https://github.com/Seldaek/phar-utils/tree/1.2.1"
},
"install-path": "../seld/phar-utils"
},