summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-12-09 08:08:01 +0100
committerRemi Collet <remi@php.net>2023-12-09 08:08:01 +0100
commit13d1e6b844b7f74b0630f32f1fe19550d436dc62 (patch)
tree379471963fe4104f79a95c4417acfaa7341a2c32
parentdaa58a5705de11bb7778b6f9951753a137d2cf9a (diff)
update to 2.6.6
-rw-r--r--composer-bash-completion2
-rw-r--r--composer.json2
-rw-r--r--composer.spec17
-rw-r--r--installed.json76
4 files changed, 50 insertions, 47 deletions
diff --git a/composer-bash-completion b/composer-bash-completion
index 0f414c4..d0d01b7 100644
--- a/composer-bash-completion
+++ b/composer-bash-completion
@@ -25,7 +25,7 @@ _sf_composer() {
local cur prev words cword
_get_comp_words_by_ref -n := cur prev words cword
- local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.6.5")
+ local completecmd=("$sf_cmd" "_complete" "--no-interaction" "-sbash" "-c$cword" "-S2.6.6")
for w in ${words[@]}; do
w=$(printf -- '%b' "$w")
# remove quotes from typed values
diff --git a/composer.json b/composer.json
index 70f4885..78dae74 100644
--- a/composer.json
+++ b/composer.json
@@ -33,7 +33,7 @@
"psr/log": "^1.0 || ^2.0 || ^3.0",
"seld/jsonlint": "^1.4",
"seld/phar-utils": "^1.2",
- "symfony/console": "^5.4.11 || ^6.0.11 || ^7",
+ "symfony/console": "^5.4.11 || ^6.0.11",
"symfony/filesystem": "^5.4 || ^6.0 || ^7",
"symfony/finder": "^5.4 || ^6.0 || ^7",
"symfony/process": "^5.4 || ^6.0 || ^7",
diff --git a/composer.spec b/composer.spec
index 0173010..5427de8 100644
--- a/composer.spec
+++ b/composer.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4b0fe89db9e65b1e64df633a992e70a7a215ab33
+%global gh_commit 683557bd2466072777309d039534bb1332d0dda5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_branch 2.0-dev
%global gh_owner composer
@@ -18,7 +18,7 @@
%global api_version 2.6.0
%global run_version 2.2.2
-%global upstream_version 2.6.5
+%global upstream_version 2.6.6
#global upstream_prever RC1
#global upstream_lower rc1
@@ -83,18 +83,18 @@ Requires: ca-certificates
Provides: bundled(php-composer-ca-bundle) = 1.3.7
Provides: bundled(php-composer-class-map-generator) = 1.1.0
Provides: bundled(php-composer-metadata-minifier) = 1.0.0
-Provides: bundled(php-composer-pcre) = 2.1.0
+Provides: bundled(php-composer-pcre) = 2.1.1
Provides: bundled(php-composer-semver) = 3.4.0
-Provides: bundled(php-composer-spdx-licenses) = 1.5.7
+Provides: bundled(php-composer-spdx-licenses) = 1.5.8
Provides: bundled(php-composer-xdebug-handler) = 3.0.3
Provides: bundled(php-justinrainbow-json-schema) = v5.2.13
Provides: bundled(php-psr-container) = 1.1.1
Provides: bundled(php-psr-log) = 1.1.4
-Provides: bundled(php-react-promise) = v3.0.0
+Provides: bundled(php-react-promise) = v3.1.0
Provides: bundled(php-seld-jsonlint) = 1.10.0
Provides: bundled(php-seld-phar-utils) = 1.2.1
Provides: bundled(php-seld-signal-handler) = 2.0.2
-Provides: bundled(php-symfony-console) = v5.4.28
+Provides: bundled(php-symfony-console) = v5.4.32
Provides: bundled(php-symfony-deprecation-contracts) = v2.5.2
Provides: bundled(php-symfony-filesystem) = v5.4.25
Provides: bundled(php-symfony-finder) = v5.4.27
@@ -107,7 +107,7 @@ Provides: bundled(php-symfony-polyfill-php80) = v1.28.0
Provides: bundled(php-symfony-polyfill-php81) = v1.28.0
Provides: bundled(php-symfony-process) = v5.4.28
Provides: bundled(php-symfony-service-contracts) = v2.5.2
-Provides: bundled(php-symfony-string) = v5.4.29
+Provides: bundled(php-symfony-string) = v5.4.32
# From composer.json, suggest
# "ext-openssl": "Enabling the openssl extension allows you to access https URLs for repositories and packages",
@@ -249,6 +249,9 @@ install -Dpm 755 bin/%{name} %{buildroot}%{_bindir}/%{name}
%changelog
+* Sat Dec 9 2023 Remi Collet <remi@remirepo.net> - 2.6.6-1
+- update to 2.6.6
+
* Fri Oct 6 2023 Remi Collet <remi@remirepo.net> - 2.6.5-1
- update to 2.6.5
diff --git a/installed.json b/installed.json
index a415636..271fa91 100644
--- a/installed.json
+++ b/installed.json
@@ -229,17 +229,17 @@
},
{
"name": "composer/pcre",
- "version": "2.1.0",
- "version_normalized": "2.1.0.0",
+ "version": "2.1.1",
+ "version_normalized": "2.1.1.0",
"source": {
"type": "git",
"url": "https://github.com/composer/pcre.git",
- "reference": "3fdb2807b31a78a40ad89570e30ec77466c98717"
+ "reference": "b439557066cd445732fa57cbc8d905394b4db8a0"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/pcre/zipball/3fdb2807b31a78a40ad89570e30ec77466c98717",
- "reference": "3fdb2807b31a78a40ad89570e30ec77466c98717",
+ "url": "https://api.github.com/repos/composer/pcre/zipball/b439557066cd445732fa57cbc8d905394b4db8a0",
+ "reference": "b439557066cd445732fa57cbc8d905394b4db8a0",
"shasum": ""
},
"require": {
@@ -250,7 +250,7 @@
"phpstan/phpstan-strict-rules": "^1.1",
"symfony/phpunit-bridge": "^5"
},
- "time": "2022-11-16T18:32:04+00:00",
+ "time": "2023-10-11T07:10:55+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -283,7 +283,7 @@
],
"support": {
"issues": "https://github.com/composer/pcre/issues",
- "source": "https://github.com/composer/pcre/tree/2.1.0"
+ "source": "https://github.com/composer/pcre/tree/2.1.1"
},
"funding": [
{
@@ -387,17 +387,17 @@
},
{
"name": "composer/spdx-licenses",
- "version": "1.5.7",
- "version_normalized": "1.5.7.0",
+ "version": "1.5.8",
+ "version_normalized": "1.5.8.0",
"source": {
"type": "git",
"url": "https://github.com/composer/spdx-licenses.git",
- "reference": "c848241796da2abf65837d51dce1fae55a960149"
+ "reference": "560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/composer/spdx-licenses/zipball/c848241796da2abf65837d51dce1fae55a960149",
- "reference": "c848241796da2abf65837d51dce1fae55a960149",
+ "url": "https://api.github.com/repos/composer/spdx-licenses/zipball/560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a",
+ "reference": "560bdcf8deb88ae5d611c80a2de8ea9d0358cc0a",
"shasum": ""
},
"require": {
@@ -407,7 +407,7 @@
"phpstan/phpstan": "^0.12.55",
"symfony/phpunit-bridge": "^4.2 || ^5"
},
- "time": "2022-05-23T07:37:50+00:00",
+ "time": "2023-11-20T07:44:33+00:00",
"type": "library",
"extra": {
"branch-alias": {
@@ -448,9 +448,9 @@
"validator"
],
"support": {
- "irc": "irc://irc.freenode.org/composer",
+ "irc": "ircs://irc.libera.chat:6697/composer",
"issues": "https://github.com/composer/spdx-licenses/issues",
- "source": "https://github.com/composer/spdx-licenses/tree/1.5.7"
+ "source": "https://github.com/composer/spdx-licenses/tree/1.5.8"
},
"funding": [
{
@@ -716,27 +716,27 @@
},
{
"name": "react/promise",
- "version": "v3.0.0",
- "version_normalized": "3.0.0.0",
+ "version": "v3.1.0",
+ "version_normalized": "3.1.0.0",
"source": {
"type": "git",
"url": "https://github.com/reactphp/promise.git",
- "reference": "c86753c76fd3be465d93b308f18d189f01a22be4"
+ "reference": "e563d55d1641de1dea9f5e84f3cccc66d2bfe02c"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/reactphp/promise/zipball/c86753c76fd3be465d93b308f18d189f01a22be4",
- "reference": "c86753c76fd3be465d93b308f18d189f01a22be4",
+ "url": "https://api.github.com/repos/reactphp/promise/zipball/e563d55d1641de1dea9f5e84f3cccc66d2bfe02c",
+ "reference": "e563d55d1641de1dea9f5e84f3cccc66d2bfe02c",
"shasum": ""
},
"require": {
"php": ">=7.1.0"
},
"require-dev": {
- "phpstan/phpstan": "1.10.20 || 1.4.10",
- "phpunit/phpunit": "^9.5 || ^7.5"
+ "phpstan/phpstan": "1.10.39 || 1.4.10",
+ "phpunit/phpunit": "^9.6 || ^7.5"
},
- "time": "2023-07-11T16:12:49+00:00",
+ "time": "2023-11-16T16:21:57+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -780,7 +780,7 @@
],
"support": {
"issues": "https://github.com/reactphp/promise/issues",
- "source": "https://github.com/reactphp/promise/tree/v3.0.0"
+ "source": "https://github.com/reactphp/promise/tree/v3.1.0"
},
"funding": [
{
@@ -974,17 +974,17 @@
},
{
"name": "symfony/console",
- "version": "v5.4.28",
- "version_normalized": "5.4.28.0",
+ "version": "v5.4.32",
+ "version_normalized": "5.4.32.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/console.git",
- "reference": "f4f71842f24c2023b91237c72a365306f3c58827"
+ "reference": "c70df1ffaf23a8d340bded3cfab1b86752ad6ed7"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/console/zipball/f4f71842f24c2023b91237c72a365306f3c58827",
- "reference": "f4f71842f24c2023b91237c72a365306f3c58827",
+ "url": "https://api.github.com/repos/symfony/console/zipball/c70df1ffaf23a8d340bded3cfab1b86752ad6ed7",
+ "reference": "c70df1ffaf23a8d340bded3cfab1b86752ad6ed7",
"shasum": ""
},
"require": {
@@ -1022,7 +1022,7 @@
"symfony/lock": "",
"symfony/process": ""
},
- "time": "2023-08-07T06:12:30+00:00",
+ "time": "2023-11-18T18:23:04+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -1056,7 +1056,7 @@
"terminal"
],
"support": {
- "source": "https://github.com/symfony/console/tree/v5.4.28"
+ "source": "https://github.com/symfony/console/tree/v5.4.32"
},
"funding": [
{
@@ -2022,17 +2022,17 @@
},
{
"name": "symfony/string",
- "version": "v5.4.29",
- "version_normalized": "5.4.29.0",
+ "version": "v5.4.32",
+ "version_normalized": "5.4.32.0",
"source": {
"type": "git",
"url": "https://github.com/symfony/string.git",
- "reference": "e41bdc93def20eaf3bfc1537c4e0a2b0680a152d"
+ "reference": "91bf4453d65d8231688a04376c3a40efe0770f04"
},
"dist": {
"type": "zip",
- "url": "https://api.github.com/repos/symfony/string/zipball/e41bdc93def20eaf3bfc1537c4e0a2b0680a152d",
- "reference": "e41bdc93def20eaf3bfc1537c4e0a2b0680a152d",
+ "url": "https://api.github.com/repos/symfony/string/zipball/91bf4453d65d8231688a04376c3a40efe0770f04",
+ "reference": "91bf4453d65d8231688a04376c3a40efe0770f04",
"shasum": ""
},
"require": {
@@ -2052,7 +2052,7 @@
"symfony/translation-contracts": "^1.1|^2",
"symfony/var-exporter": "^4.4|^5.0|^6.0"
},
- "time": "2023-09-13T11:47:41+00:00",
+ "time": "2023-11-26T13:43:46+00:00",
"type": "library",
"installation-source": "dist",
"autoload": {
@@ -2091,7 +2091,7 @@
"utf8"
],
"support": {
- "source": "https://github.com/symfony/string/tree/v5.4.29"
+ "source": "https://github.com/symfony/string/tree/v5.4.32"
},
"funding": [
{