summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-13 16:20:15 +0200
committerRemi Collet <remi@remirepo.net>2019-05-13 16:20:15 +0200
commitea60bace65e5c2d949f626e35dc2a4712b12e078 (patch)
tree4eb4cc64a917f0d249aae04f29db465c9d4bad1a
parent76477c2eadb70bd3ed77cbf60624976bad35bf10 (diff)
- update to version 6.9.10 patch level 45HEADmaster
- add HEIC support using libheif from RPMFusion in optional heic subpackage
-rw-r--r--ImageMagick6.spec56
1 files changed, 47 insertions, 9 deletions
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index fd2bc9d..89e6b20 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 6.9.10
-%global Patchlevel 44
+%global Patchlevel 45
%global incsuffixe -6
%global libsuffixe -6.Q16
%global with_tests 0%{!?_without_tests:1}
@@ -50,6 +50,9 @@
%global with_gvc 1
+# from mock config, when rpmfusion enabled
+%global with_libheif 0%{?_with_rpmfusion:1}
+
%global libname ImageMagick
%if 0%{?fedora} >= 30 || 0%{?rhel} >= 8
@@ -73,7 +76,7 @@ Name: %{libname}
Name: %{libname}6
%endif
Version: %{VER}.%{Patchlevel}
-Release: 2%{?dist}
+Release: 1%{?dist}
Summary: An X application for displaying and manipulating images
License: ImageMagick
Url: http://www.imagemagick.org/
@@ -101,13 +104,6 @@ BuildRequires: pkgconfig(libzstd)
BuildRequires: perl-devel
BuildRequires: perl-generators
BuildRequires: ghostscript-devel
-%if %{with_djvu}
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: pkgconfig(ddjvuapi)
-%else
-BuildRequires: djvulibre-devel
-%endif
-%endif
BuildRequires: libwmf-devel
BuildRequires: pkgconfig(jasper)
BuildRequires: libtool-ltdl-devel
@@ -260,6 +256,11 @@ for applications requiring this libraries.
%if %{with_djvu}
%package djvu
Summary: DjVu plugin for ImageMagick
+%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+BuildRequires: pkgconfig(ddjvuapi)
+%else
+BuildRequires: djvulibre-devel
+%endif
Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
Obsoletes: ImageMagick-last-djvu < %{epoch}:%{version}
%if "%{name}" == "%{libname}"
@@ -276,6 +277,25 @@ for applications requiring this libraries.
%endif
+%if %{with_libheif}
+%package heic
+Summary: HEIC plugin for ImageMagick
+BuildRequires: pkgconfig(libheif)
+Requires: %{name}-libs%{?_isa} = %{epoch}:%{version}-%{release}
+%if "%{name}" == "%{libname}"
+Obsoletes: %{libname}6-heic <= %{epoch}:%{version}-%{release}
+%endif
+
+%description heic
+This packages contains a plugin for ImageMagick which makes it possible to
+save and load HEIC files from ImageMagick and libMagickCore using applications.
+%if "%{name}" != "%{libname}"
+This package could be installed beside official RPM of ImageMagick-heic
+for applications requiring this libraries.
+%endif
+%endif
+
+
%package doc
Summary: ImageMagick html documentation
Obsoletes: ImageMagick-last-doc < %{epoch}:%{version}
@@ -418,6 +438,11 @@ cp -p Magick++/demo/*.cpp Magick++/demo/*.miff Magick++/examples
%if %{with_gvc}
--with-gvc \
%endif
+%if %{with_libheif}
+ --with-heif \
+%else
+ --without-heif \
+%endif
--with-perl-options="INSTALLDIRS=vendor %{?perl_prefix} CC='%__cc -L$PWD/magick/.libs' LDDLFLAGS='-shared -L$PWD/magick/.libs'" \
--without-dps \
%if %{move}
@@ -541,6 +566,9 @@ fi
%if %{with_djvu}
%exclude %{_libdir}/%{libname}-%{VER}/modules-Q16/coders/djvu.*
%endif
+%if %{with_libheif}
+%exclude %{_libdir}/%{libname}-%{VER}/modules-Q16/coders/heic.*
+%endif
%files devel
%{_bindir}/MagickCore-config
@@ -570,6 +598,11 @@ fi
%{_libdir}/%{libname}-%{VER}/modules-Q16/coders/djvu.*
%endif
+%if %{with_libheif}
+%files heic
+%{_libdir}/%{libname}-%{VER}/modules-Q16/coders/heic.*
+%endif
+
%files doc
%if %{move}
%doc %{_datadir}/%{name}/doc/%{libname}%{?incsuffixe}
@@ -600,6 +633,11 @@ fi
%changelog
+* Mon May 13 2019 Remi Collet <remi@remirepo.net> - 6.9.10.45-1
+- update to version 6.9.10 patch level 45
+- add HEIC support using libheif from RPMFusion
+ in optional heic subpackage
+
* Tue May 7 2019 Remi Collet <remi@remirepo.net> - 6.9.10.44-2
- fix missing epoch in obsoletes