summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-25 18:34:08 +0200
committerRemi Collet <remi@remirepo.net>2021-06-25 18:34:08 +0200
commitdd295d6df0cd66283e1f17fcab63d9c77ff15e1a (patch)
tree28223de173aeb8ac57c86513b45bfd2b8ec2eb62
parent7c09da3f382103e82badc95581268d183de48322 (diff)
update to version 6.9.12 patch level 17
drop patch merged upstream
-rw-r--r--160.patch31
-rw-r--r--ImageMagick6.spec9
2 files changed, 5 insertions, 35 deletions
diff --git a/160.patch b/160.patch
deleted file mode 100644
index 90d1736..0000000
--- a/160.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 83fc01755a8cfd082000085e89a2cced085b1326 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Wed, 23 Jun 2021 16:42:15 +0200
-Subject: [PATCH] fix memory corruption in ConcatenateStringInfo
-
----
- magick/string.c | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/magick/string.c b/magick/string.c
-index 23f9361d0..5535b9a51 100644
---- a/magick/string.c
-+++ b/magick/string.c
-@@ -564,7 +564,6 @@ MagickExport void ConcatenateStringInfo(StringInfo *string_info,
- length+=source->length;
- if (~length < MagickPathExtent)
- ThrowFatalException(ResourceLimitFatalError,"MemoryAllocationFailed");
-- string_info->length=length;
- if (string_info->datum == (unsigned char *) NULL)
- string_info->datum=(unsigned char *) AcquireQuantumMemory(length+
- MagickPathExtent,sizeof(*string_info->datum));
-@@ -574,7 +573,8 @@ MagickExport void ConcatenateStringInfo(StringInfo *string_info,
- sizeof(*string_info->datum));
- if (string_info->datum == (unsigned char *) NULL)
- ThrowFatalException(ResourceLimitFatalError,"MemoryAllocationFailed");
-- (void) memcpy(string_info->datum+length,source->datum,source->length);
-+ (void) memcpy(string_info->datum+string_info->length,source->datum,source->length);
-+ string_info->length=length;
- }
-
- /*
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index 45a9e5e..db89122 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 6.9.12
-%global Patchlevel 16
+%global Patchlevel 17
%global incsuffixe -6
%global libsuffixe -6.Q16
%bcond_without tests
@@ -57,8 +57,6 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: 160.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -353,7 +351,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%patch0 -p1
# for %%doc
mkdir Magick++/examples
@@ -612,6 +609,10 @@ fi
%changelog
+* Fri Jun 25 2021 Remi Collet <remi@remirepo.net> - 6.9.12.17-1
+- update to version 6.9.12 patch level 17
+- drop patch merged upstream
+
* Wed Jun 23 2021 Remi Collet <remi@remirepo.net> - 6.9.12.16-2
- fix memory corruption using fix from
https://github.com/ImageMagick/ImageMagick6/pull/160