summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-06-22 08:53:43 +0200
committerRemi Collet <remi@remirepo.net>2020-06-22 08:53:43 +0200
commit56a7e649e0a7416fb4ba5c0b1d05972c609900dd (patch)
tree555bc8a229951e59482e32358abb10bfa0fa299b
parent6699ecc85f75628ff889abfc366f251921fcdc0a (diff)
update to version 6.9.11 patch level 20
revert upstream commit on EL-6 to fix broken build with old libtiff https://github.com/ImageMagick/ImageMagick6/issues/84 report behavior change with DrawSetTextInterlineSpacing https://github.com/ImageMagick/ImageMagick6/issues/85
-rw-r--r--218d6abc4e36596c90a07463bfb2ab9e8312efbb.patch32
-rw-r--r--ImageMagick6.spec14
2 files changed, 45 insertions, 1 deletions
diff --git a/218d6abc4e36596c90a07463bfb2ab9e8312efbb.patch b/218d6abc4e36596c90a07463bfb2ab9e8312efbb.patch
new file mode 100644
index 0000000..cedecca
--- /dev/null
+++ b/218d6abc4e36596c90a07463bfb2ab9e8312efbb.patch
@@ -0,0 +1,32 @@
+From 218d6abc4e36596c90a07463bfb2ab9e8312efbb Mon Sep 17 00:00:00 2001
+From: Dirk Lemstra <dirk@lemstra.org>
+Date: Sat, 13 Jun 2020 18:00:50 +0200
+Subject: [PATCH] Check the type of the field before performing the
+ multiplication.
+
+---
+ coders/tiff.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/coders/tiff.c b/coders/tiff.c
+index 61858c3cc..25a939811 100644
+--- a/coders/tiff.c
++++ b/coders/tiff.c
+@@ -638,9 +638,16 @@ static MagickBooleanType TIFFGetProfiles(TIFF *tiff,Image *image)
+ if ((TIFFGetField(tiff,TIFFTAG_RICHTIFFIPTC,&length,&profile) == 1) &&
+ (profile != (unsigned char *) NULL))
+ {
++ const TIFFField
++ *field;
++
+ if (TIFFIsByteSwapped(tiff) != 0)
+ TIFFSwabArrayOfLong((uint32 *) profile,(size_t) length);
+- status=ReadProfile(image,"iptc",profile,4L*length);
++ field=TIFFFieldWithTag(tiff,TIFFTAG_RICHTIFFIPTC);
++ if (TIFFFieldDataType(field) == TIFF_LONG)
++ status=ReadProfile(image,"iptc",profile,4L*length);
++ else
++ status=ReadProfile(image,"iptc",profile,length);
+ }
+ #endif
+ #if defined(TIFFTAG_XMLPACKET)
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index 5179e04..2a43486 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 6.9.11
-%global Patchlevel 19
+%global Patchlevel 20
%global incsuffixe -6
%global libsuffixe -6.Q16
%global with_tests 0%{!?_without_tests:1}
@@ -78,6 +78,8 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
+Patch0: https://github.com/ImageMagick/ImageMagick6/commit/218d6abc4e36596c90a07463bfb2ab9e8312efbb.patch
+
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -379,6 +381,9 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
+%if 0%{?rhel} == 6
+%patch0 -p1 -R
+%endif
# for %%doc
mkdir Magick++/examples
@@ -637,6 +642,13 @@ fi
%changelog
+* Mon Jun 22 2020 Remi Collet <remi@remirepo.net> - 6.9.11.20-1
+- update to version 6.9.11 patch level 20
+- revert upstream commit on EL-6 to fix broken build with old libtiff
+ https://github.com/ImageMagick/ImageMagick6/issues/84
+- report behavior change with DrawSetTextInterlineSpacing
+ https://github.com/ImageMagick/ImageMagick6/issues/85
+
* Mon Jun 15 2020 Remi Collet <remi@remirepo.net> - 6.9.11.19-1
- update to version 6.9.11 patch level 19