summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-01 09:30:03 +0100
committerRemi Collet <remi@php.net>2024-01-01 09:30:03 +0100
commit4d7096749088f17bb32aacbcc857d34425327997 (patch)
treede1379d51ae9d0855fb590e2543f725907b62c2c
parent74603431d05d6ea84207e4ae99cecdec1bf1fc5f (diff)
update to version 6.9.13 patch level 3
add build patch from https://github.com/ImageMagick/ImageMagick6/pull/301
-rw-r--r--0001-fix-error-libraw_data_t-has-no-member-named-rawparam.patch25
-rw-r--r--ImageMagick6.spec10
2 files changed, 34 insertions, 1 deletions
diff --git a/0001-fix-error-libraw_data_t-has-no-member-named-rawparam.patch b/0001-fix-error-libraw_data_t-has-no-member-named-rawparam.patch
new file mode 100644
index 0000000..7768991
--- /dev/null
+++ b/0001-fix-error-libraw_data_t-has-no-member-named-rawparam.patch
@@ -0,0 +1,25 @@
+From 1226c5f394f644ed7e73f3c39fa48553388de48b Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Mon, 1 Jan 2024 09:00:14 +0100
+Subject: [PATCH] fix error: 'libraw_data_t' has no member named 'rawparams'
+
+---
+ coders/dng.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/coders/dng.c b/coders/dng.c
+index 55a1ca9a5..0a1eec8ea 100644
+--- a/coders/dng.c
++++ b/coders/dng.c
+@@ -327,7 +327,7 @@ static void SetLibRawParams(const ImageInfo *image_info,Image *image,
+ const char
+ *option;
+
+-#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,20)
++#if LIBRAW_COMPILE_CHECK_VERSION_NOTLESS(0,21)
+ raw_info->rawparams.max_raw_memory_mb=8192;
+ option=GetImageOption(image_info,"dng:max-raw-memory");
+ if (option != (const char *) NULL)
+--
+2.43.0
+
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index 59689e3..df2b2c6 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 6.9.13
-%global Patchlevel 1
+%global Patchlevel 3
%global incsuffixe -6
%global libsuffixe -6.Q16
%bcond_without tests
@@ -73,6 +73,8 @@ Url: http://www.imagemagick.org/
#Source0: https://www.imagemagick.org/download/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://imagemagick.org/archive/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
+Patch0: 0001-fix-error-libraw_data_t-has-no-member-named-rawparam.patch
+
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -388,6 +390,8 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
+%patch -P0 -p1
+
# for %%doc
mkdir Magick++/examples
cp -p Magick++/demo/*.cpp Magick++/demo/*.miff Magick++/examples
@@ -645,6 +649,10 @@ fi
%changelog
+* Mon Jan 1 2024 Remi Collet <remi@remirepo.net> - 6.9.13.3-1
+- update to version 6.9.13 patch level 3
+- add build patch from https://github.com/ImageMagick/ImageMagick6/pull/301
+
* Mon Dec 11 2023 Remi Collet <remi@remirepo.net> - 6.9.13.1-1
- update to version 6.9.13 patch level 1