summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-03-27 16:58:01 +0200
committerRemi Collet <remi@php.net>2023-03-27 16:58:01 +0200
commit45f5db559ce4adc3a4845569be387b5921303b68 (patch)
treeaae47790bb8b2c70cfda9e9d14c1710cfd1155d2
parent5bb5913e3194f61c168dc125892243b67e032fe2 (diff)
update to version 6.9.12 patch level 83
fix https://github.com/ImageMagick/ImageMagick6/issues/225 using upstream patch
-rw-r--r--65692230ba98b5735b911565682010afc67c769f.patch22
-rw-r--r--ImageMagick6.spec18
2 files changed, 37 insertions, 3 deletions
diff --git a/65692230ba98b5735b911565682010afc67c769f.patch b/65692230ba98b5735b911565682010afc67c769f.patch
new file mode 100644
index 0000000..6b012eb
--- /dev/null
+++ b/65692230ba98b5735b911565682010afc67c769f.patch
@@ -0,0 +1,22 @@
+From 65692230ba98b5735b911565682010afc67c769f Mon Sep 17 00:00:00 2001
+From: Cristy <urban-warrior@imagemagick.org>
+Date: Sun, 26 Mar 2023 08:32:25 -0400
+Subject: [PATCH] fix compiler exception
+
+---
+ coders/jpeg.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/coders/jpeg.c b/coders/jpeg.c
+index 62b01186c..7a50bc926 100644
+--- a/coders/jpeg.c
++++ b/coders/jpeg.c
+@@ -2293,7 +2293,7 @@ static MagickBooleanType WriteJPEGImage_(const ImageInfo *image_info,
+ *exception;
+
+ Image
+- *jps_images = (Image *) NULL,
++ *jps_image = (Image *) NULL,
+ *volatile volatile_image = (Image *) NULL;
+
+ int
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index 4a4a2e8..f171d3c 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,7 +9,7 @@
# Please preserve changelog entries
#
%global VER 6.9.12
-%global Patchlevel 82
+%global Patchlevel 83
%global incsuffixe -6
%global libsuffixe -6.Q16
%bcond_without tests
@@ -32,8 +32,12 @@
%global with_lqr 0
%endif
-# from mock config, when rpmfusion enabled
-%global with_libheif 0%{?_with_rpmfusion:1}
+%if 0%{?fedora} >= 36 || 0%{?rhel} >= 9 || 0%{?_with_rpmfusion:1}
+# from distribution or from rpmfusion, when enabled in mock config
+%global with_libheif 1
+%else
+%global with_libheif 0
+%endif
%global libname ImageMagick
@@ -69,6 +73,8 @@ Url: http://www.imagemagick.org/
#Source0: https://www.imagemagick.org/download/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://imagemagick.org/archive/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
+Patch0: https://github.com/ImageMagick/ImageMagick6/commit/65692230ba98b5735b911565682010afc67c769f.patch
+
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -379,6 +385,7 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
+%patch0 -p1
# for %%doc
mkdir Magick++/examples
@@ -636,6 +643,11 @@ fi
%changelog
+* Mon Mar 27 2023 Remi Collet <remi@remirepo.net> - 6.9.12.83-1
+- update to version 6.9.12 patch level 83
+- fix https://github.com/ImageMagick/ImageMagick6/issues/225
+ using upstream patch
+
* Mon Mar 20 2023 Remi Collet <remi@remirepo.net> - 6.9.12.82-1
- update to version 6.9.12 patch level 82