summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-31 08:31:19 +0100
committerRemi Collet <remi@php.net>2022-01-31 08:31:19 +0100
commit32f8771cd7a943733eba7bd888183063f2fb3e68 (patch)
treeec86029d6435269229e6b4836d2543709298ab42
parentc09a5d3eb272ea98b51cc5225f057cb4a8aa2ab2 (diff)
update to version 6.9.12 patch level 37
-rw-r--r--ImageMagick6.spec13
-rw-r--r--heic-el7.patch43
2 files changed, 7 insertions, 49 deletions
diff --git a/ImageMagick6.spec b/ImageMagick6.spec
index baeb522..fbf31a3 100644
--- a/ImageMagick6.spec
+++ b/ImageMagick6.spec
@@ -9,11 +9,14 @@
# Please preserve changelog entries
#
%global VER 6.9.12
-%global Patchlevel 35
+%global Patchlevel 37
%global incsuffixe -6
%global libsuffixe -6.Q16
%bcond_without tests
+# Disable automatic .la file removal
+%global __brp_remove_la_files %nil
+
%global with_djvu 1
%global with_webp 1
%global with_jp2 1
@@ -57,8 +60,6 @@ Url: http://www.imagemagick.org/
#Source0: ftp://ftp.ImageMagick.org/pub/ImageMagick/ImageMagick-%%{VER}-%%{Patchlevel}.tar.xz
Source0: https://www.imagemagick.org/download/ImageMagick-%{VER}-%{Patchlevel}.tar.xz
-Patch0: heic-el7.patch
-
BuildRequires: gcc
BuildRequires: gcc-c++
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
@@ -363,9 +364,6 @@ however.
%prep
%setup -q -n %{libname}-%{VER}-%{Patchlevel}
-%if 0%{?rhel} == 7
-%patch0 -p1 -R
-%endif
# for %%doc
mkdir Magick++/examples
@@ -624,6 +622,9 @@ fi
%changelog
+* Mon Jan 31 2022 Remi Collet <remi@remirepo.net> - 6.9.12.37-1
+- update to version 6.9.12 patch level 37
+
* Mon Jan 24 2022 Remi Collet <remi@remirepo.net> - 6.9.12.35-1
- update to version 6.9.12 patch level 35
- add weak dependencies on default fonts
diff --git a/heic-el7.patch b/heic-el7.patch
deleted file mode 100644
index 730bf81..0000000
--- a/heic-el7.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 1b89b2b729238758a98c596c256a1d5753fa5670 Mon Sep 17 00:00:00 2001
-From: Cristy <urban-warrior@imagemagick.org>
-Date: Wed, 19 Jan 2022 18:40:35 -0500
-Subject: [PATCH] AVIF is supported by the HEIC coder
-
----
- coders/heic.c | 18 +++++++-----------
- coders/miff.c | 4 ++--
- coders/mpc.c | 7 +++----
- 3 files changed, 12 insertions(+), 17 deletions(-)
-
-diff --git a/coders/heic.c b/coders/heic.c
-index c17ec7848c..29c5fbc0a9 100644
---- a/coders/heic.c
-+++ b/coders/heic.c
-@@ -586,20 +586,16 @@ static Image *ReadHEICImage(const ImageInfo *image_info,
- */
- static MagickBooleanType IsHEIC(const unsigned char *magick,const size_t length)
- {
-+#if defined(MAGICKCORE_HEIC_DELEGATE)
-+ enum heif_filetype_result
-+ heif_filetype;
-+
- if (length < 12)
- return(MagickFalse);
-- if (LocaleNCompare((const char *) magick+4,"ftyp",4) != 0)
-- return(MagickFalse);
-- if (LocaleNCompare((const char *) magick+8,"avif",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"heic",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"heix",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"mif1",4) == 0)
-- return(MagickTrue);
-- if (LocaleNCompare((const char *) magick+8,"msf1",4) == 0)
-+ heif_filetype=heif_check_filetype(magick,(int) length);
-+ if (heif_filetype == heif_filetype_yes_supported)
- return(MagickTrue);
-+#endif
- return(MagickFalse);
- }
-