summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--wizard/index.php51
1 files changed, 35 insertions, 16 deletions
diff --git a/wizard/index.php b/wizard/index.php
index 1f0b26e..0346c4e 100644
--- a/wizard/index.php
+++ b/wizard/index.php
@@ -15,6 +15,7 @@ define('EL_DEV', 8);
define('COUNTER', __DIR__ . "/counter.txt");
$osvers = [
+ 'RHEL 8' => '7.2',
'RHEL 7' => '5.4',
'RHEL 6' => '5.3',
'CentOS 7' => '5.4',
@@ -25,6 +26,7 @@ $osvers = [
'Fedora 26' => '7.1',
];
$osmin = [
+ 'RHEL 8' => '7.2',
'RHEL 7' => '5.4',
'RHEL 6' => '5.4',
'CentOS 7' => '5.4',
@@ -35,6 +37,7 @@ $osmin = [
'Fedora 26' => '5.6',
];
$osmax = [
+ 'RHEL 8' => '7.3',
'RHEL 7' => '7.3',
'RHEL 6' => '7.3',
'CentOS 7' => '7.3',
@@ -45,6 +48,7 @@ $osmax = [
'Fedora 26' => '7.2',
];
$osname = [
+ 'RHEL 8' => 'RHEL-8-Beta (Development version, not ready for production)',
'RHEL 7' => 'RHEL-7',
'RHEL 6' => 'RHEL-6 (maintained until March 2020)',
'CentOS 7' => 'CentOS 7',
@@ -171,23 +175,30 @@ if ($php && $os) {
}
if ($php && $os && $type && !$err) {
if ($dist == 'Fedora') {
+ $mod = ($ver >= 29);
$yum = 'dnf';
printf("<li>Command to install the Remi repository configuration package:");
printf("<pre> $yum install http://rpms.remirepo.net/fedora/remi-release-%d.rpm</pre>", $ver);
printf("</li><br />");
} else {
- $yum = 'yum';
- printf("<li>Command to install the EPEL repository configuration package:");
- printf("<pre> $yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-%d.noarch.rpm</pre>", $ver);
- printf("</li><br /><li>Command to install the Remi repository configuration package:");
+ $mod = ($ver >= 8);
+ if ($ver >= EL_DEV) {
+ $yum = 'dnf';
+ printf("<li>EPEL repository is not yet available.</li><br/>");
+ } else {
+ $yum = 'yum';
+ printf("<li>Command to install the EPEL repository configuration package:");
+ printf("<pre> $yum install https://dl.fedoraproject.org/pub/epel/epel-release-latest-%d.noarch.rpm</pre></li><br />", $ver);
+ }
+ printf("<li>Command to install the Remi repository configuration package:");
printf("<pre> $yum install http://rpms.remirepo.net/enterprise/remi-release-%d.rpm</pre>", $ver);
printf("</li><br />");
printf("<li>Command to install the yum-utils package (for the yum-config-manager command):");
printf("<pre> $yum install yum-utils</pre>");
printf("</li><br />");
- if ($dist == 'RHEL') {
+ if ($dist == 'RHEL' && $ver < EL_DEV) {
printf("<li>On <b>RHEL</b> you (probably) need to enable the <b>optional channel</b> for some dependencies.</li><br />");
printf("</li><li>Command to enable:");
if ($ver == 7) {
@@ -225,19 +236,23 @@ if ($php && $os && $type && !$err) {
printf("<pre> dnf config-manager --set-enabled remi</pre></li><br />");
}
- printf("<li>PHP version <b>%s</b> packages are available for <b>%s</b> in <b>%s</b> repository</li><br />", $php, $os, $repo);
- printf("<li>If the <b>priorities</b> plugin is enabled, ensure %s have higher priority (a lower value) than %s</li><br />", $repo, ($dist == 'Fedora' ? 'fedora' : 'base and updates'));
-
- printf("<li>Command to enable the repository:");
+ if ($dist == 'Fedora' || $yum == 'yum') {
+ printf("<li>PHP version <b>%s</b> packages are available for <b>%s</b> in <b>%s</b> repository</li><br />", $php, $os, $repo);
+ printf("<li>Command to enable the repository:");
+ }
if ($dist == 'Fedora') {
- printf("<pre> dnf config-manager --set-enabled %s</pre>", $repo);
- } else {
- printf("<pre> yum-config-manager --enable %s</pre>", $repo);
+ printf("<pre> dnf config-manager --set-enabled %s</pre></li><br />", $repo);
+ if ($mod) {
+ printf("<li>Alternatively, you may prefer to enable the module:");
+ }
+ } else if ($yum == 'yum') { // EL-6, 7
+ printf("<pre> yum-config-manager --enable %s</pre></li><br />", $repo);
+ printf("<li>If the <b>priorities</b> plugin is enabled, ensure %s have higher priority (a lower value) than %s</li><br />", $repo, ($dist == 'Fedora' ? 'fedora' : 'base and updates'));
+ } else { // EL-8, module only
+ printf("<li>You have to enable the module stream for $php:");
}
- printf("</li><br />");
- if ($dist == 'Fedora' && $ver >= 29) {
- printf("<li>Alternatively, you may prefer to enable the module:");
+ if ($mod) {
printf("<pre> dnf module install remi-php:%s</pre>", $php);
printf("</li><br />");
}
@@ -252,7 +267,11 @@ if ($php && $os && $type && !$err) {
if (version_compare($php, '7.0', '>=')) {
printf("<li>Command to install <b>testing</b> packages:");
- printf("<pre> $yum --enablerepo=%s-test install php-xxx</pre>", $repo);
+ if ($dist != 'Fedora' && $mod) {
+ printf("<pre> $yum --enablerepo=remi-modular-test install php-xxx</pre>", $repo);
+ } else {
+ printf("<pre> $yum --enablerepo=%s-test install php-xxx</pre>", $repo);
+ }
printf("</li><br />");
}