summaryrefslogtreecommitdiffstats
path: root/wizard/index.php
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-20 13:30:21 +0100
committerRemi Collet <remi@remirepo.net>2020-02-20 13:30:21 +0100
commit329de2c52ed2405f28fcb403f3994d2b1c26d620 (patch)
tree4c95f724df82a6dc2ba59d872cb2abe0965ce623 /wizard/index.php
parentbf10893a929a5d2cc83fb6cd605df37eaa5d0895 (diff)
Wizard: fix #140 minimal version not properly displayed on EL-8
Diffstat (limited to 'wizard/index.php')
-rw-r--r--wizard/index.php6
1 files changed, 3 insertions, 3 deletions
diff --git a/wizard/index.php b/wizard/index.php
index d6d74e4..d955277 100644
--- a/wizard/index.php
+++ b/wizard/index.php
@@ -225,11 +225,11 @@ if ($php && $os && $type && !$err) {
} else if (!$phpvers[$php]) {
printf("<li>Sorry, but PHP version <b>%s</b> are not yet available for <b>%s</b> as single version, try multiple versions.</li><br />", $php, $os);
- } else if (version_compare($php, (is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '<')) {
- printf("<li>Sorry, but PHP version older than <b>%s</b> are not available for <b>%s</b>, try multiple versions.</li><br />", $osvers[$os], $os);
+ } else if (version_compare($php, $tmp=(is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '<')) {
+ printf("<li>Sorry, but PHP version older than <b>%s</b> are not available for <b>%s</b>, try multiple versions.</li><br />", $tmp, $os);
} else {
- if ($dist == 'Fedora' && version_compare($php, (is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '=')) {
+ if ($dist == 'Fedora' && version_compare($php, $tmp=(is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '=')) {
$repo = 'remi';
} else {
$repo = $phpvers[$php];