summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-11-07 11:48:57 +0100
committerRemi Collet <remi@remirepo.net>2019-11-07 11:48:57 +0100
commit09b86ade39645406449032ee8189ca6918573467 (patch)
treea730d8422fc6835250c2b6bb33f403b817f6799e
parent7b1f24560495dfae60322e0be251c1614ff48880 (diff)
RHEL 8.1 have 7.2 and 7.3
F31 is GA F29 is close to EOL
-rw-r--r--wizard/index.php20
1 files changed, 11 insertions, 9 deletions
diff --git a/wizard/index.php b/wizard/index.php
index e98c2ee..4fee002 100644
--- a/wizard/index.php
+++ b/wizard/index.php
@@ -8,14 +8,14 @@
<link rel="shortcut icon" href="/favicon.ico" />
</head>
<?php
-define('FC_EOL', 27);
-define('FC_DEV', 31);
+define('FC_EOL', 28);
+define('FC_DEV', 32);
define('EL_EOL', 5);
define('EL_DEV', 9);
define('COUNTER', __DIR__ . "/counter.txt");
$osvers = [
- 'RHEL 8' => '7.2',
+ 'RHEL 8' => ['7.2','7.3'],
'RHEL 7' => '5.4',
'RHEL 6' => '5.3',
'CentOS 8' => '7.2',
@@ -54,9 +54,9 @@ $osname = [
'CentOS 8' => 'CentOS 8',
'CentOS 7' => 'CentOS 7 (maintained until June 2024)',
'CentOS 6' => 'CentOS 6 (maintained until March 2020)',
- 'Fedora 31' => 'Fedora 31 (development version)',
+ 'Fedora 31' => 'Fedora 31',
'Fedora 30' => 'Fedora 30',
- 'Fedora 29' => 'Fedora 29',
+ 'Fedora 29' => 'Fedora 29 (maintained until November 2019)',
];
$grpname = [
'RHEL' => 'Red Hat Enterprise Linux',
@@ -171,8 +171,10 @@ if ($os) {
}
}
if ($php && $os) {
- printf("<li><b>%s</b> provides PHP version <b>%s</b> in its official repository</li><br />", $os, $osvers[$os]);
-
+ printf("<li><b>%s</b> provides PHP version <b>%s</b> in its official repository</li><br />",
+ $os,
+ is_array($osvers[$os]) ? implode(', ', $osvers[$os]) : $osvers[$os]
+ );
if (version_compare($php, '5.6', '<')) {
printf("<li><b>WARNING</b>, PHP version <b>%s</b> have reached its eod of life, despite packages have security fix, you should consider a maintained version.</li><br />", $php);
}
@@ -223,11 +225,11 @@ if ($php && $os && $type && !$err) {
} else if (!$phpvers[$php]) {
printf("<li>Sorry, but PHP version <b>%s</b> are not yet available for <b>%s</b> as single version, try multiple versions.</li><br />", $php, $os);
- } else if (version_compare($php, $osvers[$os], '<')) {
+ } else if (version_compare($php, (is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '<')) {
printf("<li>Sorry, but PHP version older than <b>%s</b> are not available for <b>%s</b>, try multiple versions.</li><br />", $osvers[$os], $os);
} else {
- if ($dist == 'Fedora' && version_compare($php, $osvers[$os], '=')) {
+ if ($dist == 'Fedora' && version_compare($php, (is_array($osvers[$os]) ? $osvers[$os][0] : $osvers[$os]), '=')) {
$repo = 'remi';
} else {
$repo = $phpvers[$php];