summaryrefslogtreecommitdiffstats
path: root/zephir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir.spec')
-rw-r--r--zephir.spec15
1 files changed, 9 insertions, 6 deletions
diff --git a/zephir.spec b/zephir.spec
index 7533358..8b3b328 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for zephir
#
-# Copyright (c) 2016-2017 Remi Collet
+# Copyright (c) 2016-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -11,7 +11,7 @@
%global with_tests 0
%scl_package zephyr-parser
%else
-%if 0%{?fedora}
+%if 0%{?fedora} >= 21 || 0%{?rhel} >= 8
%global with_tests 0%{!?_without_tests:1}
%else
# Disable in EL as 5.4 and 5.5 can't use phpunit
@@ -21,7 +21,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 2917ebe8aec4b4a3a2561f6b74b7c8f96472a335
+%global gh_commit 70e6efe4c5a3fcbd20416e8b295e9b0c67bcb4f0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -30,7 +30,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.10.7
+Version: 0.10.8
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -53,7 +53,7 @@ BuildRequires: %{?scl_prefix}php-ctype
# "ext-gmp": "*",
# "ext-pdo": "*",
# "ext-pdo_sqlite": "*",
-# "squizlabs/php_codesniffer": "^2.8",
+# "squizlabs/php_codesniffer": "^3.2",
# "phpunit/phpunit": "^4.8"
BuildRequires: %{?scl_prefix}php-gmp
BuildRequires: %{?scl_prefix}php-pdo
@@ -64,7 +64,7 @@ BuildRequires: %{?scl_prefix}php-composer(phpunit/phpunit) >= 4.8
Requires: %{?scl_prefix}php-cli
Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# From composer.json, "require"
-# "php": ">=5.4",
+# "php": ">=5.5",
# "ext-json": "*",
# "ext-hash": "*",
# "ext-ctype": "*",
@@ -159,6 +159,9 @@ sh ./bin/%{gh_project}.test version | grep %{version}
%changelog
+* Tue Apr 17 2018 Remi Collet <remi@remirepo.net> - 0.10.8-1
+- update to 0.10.8
+
* Fri Dec 29 2017 Remi Collet <remi@remirepo.net> - 0.10.7-1
- Update to 0.10.7