summaryrefslogtreecommitdiffstats
path: root/zephir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir.spec')
-rw-r--r--zephir.spec14
1 files changed, 9 insertions, 5 deletions
diff --git a/zephir.spec b/zephir.spec
index 0678f8b..d305621 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -16,7 +16,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 1e3bafd736a65ae4888878460599cb3b4c1044ef
+%global gh_commit c893389cc6de6fc6a52199ae401aa91ff7eb1206
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,7 +25,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.11.12
+Version: 0.12.0
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -37,7 +37,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
Patch0: %{gh_project}-rpm.patch
BuildArch: noarch
-BuildRequires: %{?scl_prefix}php-devel > 5.6
+BuildRequires: %{?scl_prefix}php-devel > 7.0
BuildRequires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
%if %{with_tests}
BuildRequires: %{?scl_prefix}php-json
@@ -105,7 +105,7 @@ BuildRequires: php-composer(fedora/autoloader)
Requires: %{?scl_prefix}php-cli
Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# From composer.json, "require"
-# "php": ">=5.6.0 <8.0",
+# "php": ">=7.0.0 <8.0",
# "ext-SPL": "*",
# "ext-ctype": "*",
# "ext-hash": "*",
@@ -127,7 +127,7 @@ Requires: %{?scl_prefix}php-zephir-parser >= %{parser_ver}
# "symfony/monolog-bundle": "3.3.*",
# "symfony/routing": "3.4.*",
# "symfony/yaml": "3.4.*"
-Requires: %{?scl_prefix}php(language) >= 5.6
+Requires: %{?scl_prefix}php(language) >= 7.0
Requires: %{?scl_prefix}php-spl
Requires: %{?scl_prefix}php-ctype
Requires: %{?scl_prefix}php-hash
@@ -320,6 +320,10 @@ esac
%changelog
+* Fri Jun 21 2019 Remi Collet <remi@remirepo.net> - 0.12.0-1
+- update to 0.12.0
+- raise minimal PHP version to 7.0
+
* Mon Mar 25 2019 Remi Collet <remi@remirepo.net> - 0.11.12-1
- update to 0.11.12