summaryrefslogtreecommitdiffstats
path: root/zephir.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir.spec')
-rw-r--r--zephir.spec40
1 files changed, 25 insertions, 15 deletions
diff --git a/zephir.spec b/zephir.spec
index 7a45de4..36b8494 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -16,7 +16,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 98c5a73576e06c73886b7a4eb2bc69dfeafb3840
+%global gh_commit 1c107e0c8966233f0d35156419e2c97729dcc4ce
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -25,7 +25,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.12.6
+Version: 0.12.7
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -97,7 +97,7 @@ BuildRequires: php-PsrLog
BuildRequires: php-symfony3-debug
BuildRequires: php-symfony3-phpunit-bridge
%endif
-BuildRequires: %{_bindir}/phpunit
+BuildRequires: %{_bindir}/phpunit7
%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -200,11 +200,9 @@ Compiler design goals:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+sed -e s'/ZEPHIR_NULL/ZVAL_NULL/' -i kernels/ZendEngine3/string.c
%patch0 -p0 -b .rpm
-sed -e 's:@DATADIR@:%{_datadir}:;s:@BINDIR@:%{_bindir}:' \
- -i %{gh_project}
-
sed -e 's/\$Id\$/%{gh_short}/' \
-i Library/Zephir.php
@@ -271,6 +269,10 @@ install -Dpm 755 %{gh_project}.sh %{buildroot}%{_bindir}/%{gh_project}
%check
%if %{with_tests}
+
+# TODO try when symfony/phpunit-bridge 4.3 available
+rm unit-tests/Extension/Oo/DeprecatedMethodsTest.php
+
sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' \
%{gh_project}.php > %{gh_project}.test
%{_bindir}/php %{gh_project}.test --version
@@ -291,25 +293,27 @@ EOF
: Run test suite
%{_bindir}/php \
-d extension=zephir_parser.so \
- -d extension=ext/modules/test.so \
- %{_bindir}/phpunit \
+ %{_bindir}/phpunit7 \
--bootstrap bs.php \
--no-coverage \
- --verbose unit-tests/Zephir
+ --testsuite Zephir \
+ --verbose
case %{php_version} in
- 7.0.*) VER=Php70;;
- 7.1.*) VER=Php70;;
- *) VER=Php72;;
+ 7.0.*) test_suite="Extension_Php70";;
+ 7.1.*) test_suite="Extension_Php70";;
+ *) test_suite="Extension_Php72";;
esac
%{_bindir}/php \
-d extension=zephir_parser.so \
- -d extension=ext/modules/test.so \
- %{_bindir}/phpunit \
+ -d extension=$PWD/ext/modules/test.so \
+ %{_bindir}/phpunit7 \
--bootstrap bs.php \
--no-coverage \
- --verbose unit-tests/Extension/$VER
+ --testsuite ${test_suite} \
+ --verbose
+
%else
: Test suite disabled
%endif
@@ -325,6 +329,12 @@ esac
%changelog
+* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.7-1
+- update to 0.12.7
+- switch to phpunit7
+- open https://github.com/phalcon/zephir/issues/1946
+ undefined symbol ZEPHIR_NULL
+
* Fri Oct 4 2019 Remi Collet <remi@remirepo.net> - 0.12.6-2
- test build for https://github.com/phalcon/zephir/issues/1940