summaryrefslogtreecommitdiffstats
path: root/zephir-parser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'zephir-parser.spec')
-rw-r--r--zephir-parser.spec12
1 files changed, 8 insertions, 4 deletions
diff --git a/zephir-parser.spec b/zephir-parser.spec
index 9732e11..04d1d16 100644
--- a/zephir-parser.spec
+++ b/zephir-parser.spec
@@ -16,16 +16,16 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit e716dbe641fe731031dba38a63af599d1c384824
+%global gh_commit 22f663212836d6dadd5c5d4239ada4f9d30406c9
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20160728
+%global gh_date 20160929
%global gh_owner phalcon
%global gh_project zephir
%global ext_name zephir_parser
Name: %{?scl_prefix}%{gh_project}-parser
-Version: 0.9.3
-Release: 2%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 0.9.4
+Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Zephir parser extension
Group: Development/Libraries
@@ -155,6 +155,7 @@ make install -C parser INSTALL_ROOT=%{buildroot}
sed -e 's:%ZEPHIRDIR%:%{buildroot}%{_datadir}/%{gh_project}:g' \
-e 's: php:%{_bindir}/php:' \
bin/%{gh_project}.rpm > bin/%{gh_project}.test
+sh ./bin/%{gh_project}.test version
sh ./bin/%{gh_project}.test version | grep %{version}
: Check extension
@@ -190,6 +191,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Oct 10 2016 Remi Collet <remi@fedoraproject.org> - 0.9.4-1.20160929git22f6632
+- new snapshot to fix PHP 7.1 compatibility of generated code
+
* Wed Sep 14 2016 Remi Collet <remi@fedoraproject.org> - 0.9.3-2.20160728gite716dbe
- rebuild for PHP 7.1 new API version