summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json8
-rw-r--r--zephir.spec17
2 files changed, 14 insertions, 11 deletions
diff --git a/composer.json b/composer.json
index 6a15e5e..e00c4a2 100644
--- a/composer.json
+++ b/composer.json
@@ -72,11 +72,11 @@
},
"autoload-dev": {
"psr-4": {
- "Zephir\\Test\\": "unit-tests/Zephir/Test/",
- "Extension\\": "unit-tests/Extension/"
+ "Zephir\\Test\\": "tests/Zephir/",
+ "Extension\\": "tests/Extension/"
},
"classmap": [
- "unit-tests/fixtures/mocks/"
+ "tests/fixtures/mocks/"
]
},
"minimum-stability": "dev",
@@ -86,8 +86,8 @@
],
"support": {
"issues": "https://github.com/phalcon/zephir/issues?state=open",
- "forum": "https://forum.zephir-lang.com",
"source": "https://github.com/phalcon/zephir",
+ "irc": "irc://irc.freenode.net/zephir",
"docs": "https://docs.zephir-lang.com"
}
}
diff --git a/zephir.spec b/zephir.spec
index b7edb54..798a49d 100644
--- a/zephir.spec
+++ b/zephir.spec
@@ -20,7 +20,7 @@
# Get commit from PHP_PHALCON_ZEPVERSION in
# https://github.com/phalcon/cphalcon/blob/master/ext/php_phalcon.h
-%global gh_commit 26d474561733e678b939d802dc9e35db2420d3ce
+%global gh_commit 4345593a198647cfe01879a34faa227e2d7f357c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
#global gh_date 20161126
%global gh_owner phalcon
@@ -29,7 +29,7 @@
%global parser_ver 1.1.1
Name: %{?scl_prefix}%{gh_project}
-Version: 0.12.18
+Version: 0.12.19
Release: 1%{?gh_date:.%{gh_date}.%{gh_short}}%{?dist}
Summary: Zephir language for creation of extensions for PHP.
@@ -299,14 +299,14 @@ install -Dpm 755 %{gh_project}.sh %{buildroot}%{_bindir}/%{gh_project}
%if %{with_tests}
# TODO try when symfony/phpunit-bridge 4.3 available
-rm unit-tests/Extension/Oo/DeprecatedMethodsTest.php
+rm tests/Extension/Oo/DeprecatedMethodsTest.php
sed -e 's:%{_datadir}:%{buildroot}%{_datadir}:' \
%{gh_project}.php > %{gh_project}.test
%{_bindir}/php %{gh_project}.test --version
%{_bindir}/php %{gh_project}.test --version | grep %{version}
-%{_bindir}/php %{_bindir}/phpab -o bs.php unit-tests/fixtures/mocks
+%{_bindir}/php %{_bindir}/phpab -o bs.php tests/fixtures/mocks
cat << 'EOF' | tee -a bs.php
require '%{buildroot}%{_datadir}/%{gh_project}/autoload.php';
\Fedora\Autoloader\Dependencies::required([
@@ -314,8 +314,8 @@ require '%{buildroot}%{_datadir}/%{gh_project}/autoload.php';
'%{_datadir}/php/Symfony3/Component/Debug/autoload.php',
'%{_datadir}/php/Symfony3/Bridge/PhpUnit/autoload.php',
]);
-\Fedora\Autoloader\Autoload::addPsr4('Zephir\\Test\\', __DIR__ . '/unit-tests/Zephir/Test/');
-\Fedora\Autoloader\Autoload::addPsr4('Extension\\', __DIR__ . '/unit-tests/Extension/');
+\Fedora\Autoloader\Autoload::addPsr4('Zephir\\Test\\', __DIR__ . '/tests/Zephir/');
+\Fedora\Autoloader\Autoload::addPsr4('Extension\\', __DIR__ . '/tests/Extension/');
EOF
: Run test suite
@@ -335,7 +335,7 @@ esac
%{_bindir}/php \
-d extension=zephir_parser.so \
- -d extension=$PWD/ext/modules/test.so \
+ -d extension=$PWD/ext/modules/stub.so \
%{_bindir}/phpunit7 \
--bootstrap bs.php \
--no-coverage \
@@ -357,6 +357,9 @@ esac
%changelog
+* Wed May 13 2020 Remi Collet <remi@remirepo.net> - 0.12.19-1
+- update to 0.12.19
+
* Mon Apr 27 2020 Remi Collet <remi@remirepo.net> - 0.12.18-1
- update to 0.12.18