summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-31 16:09:45 +0200
committerRemi Collet <remi@php.net>2024-07-31 16:09:45 +0200
commitff76133997a0e04e69545609fa5921ad65b89768 (patch)
treef2a437da602cb45b74596949e2d5766061ab6d9c
parenta3d5473a1d1c9c7851ae034085c5d9018103ac91 (diff)
update to 5.34.1 ans sync with F40
-rw-r--r--Makefile2
-rw-r--r--yaz.spec97
2 files changed, 52 insertions, 47 deletions
diff --git a/Makefile b/Makefile
index 1e65467..91b0fd5 100644
--- a/Makefile
+++ b/Makefile
@@ -1,4 +1,4 @@
SRCDIR := $(shell pwd)
NAME := $(shell basename $(SRCDIR))
-include ../common/Makefile
+include ../../common/Makefile
diff --git a/yaz.spec b/yaz.spec
index b4f2a17..abbe367 100644
--- a/yaz.spec
+++ b/yaz.spec
@@ -1,6 +1,6 @@
# remirepo spec file for yaz, from:
#
-# Fedora spec file for redis
+# Fedora spec file for yaz
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -9,26 +9,31 @@
#
Name: yaz
-Version: 5.14.11
+Version: 5.34.1
Release: 1%{?dist}
Summary: Z39.50/SRW/SRU toolkit
-License: BSD
+# SPDX confirmed
+License: BSD-3-Clause
URL: http://www.indexdata.com/yaz/
Source0: http://ftp.indexdata.com/pub/yaz/yaz-%{version}.tar.gz
+
+BuildRequires: gcc
BuildRequires: bison
-BuildRequires: chrpath
-BuildRequires: gnutls-devel
-BuildRequires: hiredis-devel
-BuildRequires: libgcrypt-devel
-BuildRequires: libgpg-error-devel
+BuildRequires: make
+
+BuildRequires: pkgconfig(libexslt)
+BuildRequires: pkgconfig(gnutls)
+BuildRequires: pkgconfig(hiredis)
+BuildRequires: pkgconfig(libmemcached)
+BuildRequires: pkgconfig(libxml-2.0)
+BuildRequires: pkgconfig(libxslt)
+
BuildRequires: libicu-devel
-BuildRequires: libmemcached-devel
-BuildRequires: libpcap-devel
-BuildRequires: libxml2-devel
-BuildRequires: libxslt-devel
+BuildRequires: ncurses-devel
BuildRequires: readline-devel
-BuildRequires: tcl
-BuildRequires: tcp_wrappers-devel
+BuildRequires: /usr/bin/tclsh
+
+Requires: lib%{name}%{?_isa} = %{version}-%{release}
%description
YAZ is a programmers toolkit supporting the development of Z39.50/SRW/SRU
@@ -53,11 +58,7 @@ This packages contains shared libraries for %{name}.
%package -n lib%{name}-devel
Summary: Development files for %{name}
-Requires: gnutls-devel%{?_isa}
Requires: lib%{name}%{?_isa} = %{version}-%{release}
-Requires: libmemcached-devel%{?_isa}
-Requires: libxml2-devel%{?_isa}
-Requires: readline-devel%{?_isa}
%description -n lib%{name}-devel
This package contains libraries and header files for
@@ -76,13 +77,17 @@ server and client.
%setup -q
%build
+sed -i.rpath configure \
+ -e 's|hardcode_libdir_flag_spec=|hardcode_libdir_flag_spec_goodby=|' \
+ -e '\@sys_lib_dlsearch_path_spec=@s|/lib /usr/lib|/lib /usr/lib %{_libdir} /%{_lib}|' \
+ %{nil}
+
%configure \
- --enable-tcpd \
--enable-shared \
--with-memcached \
--with-redis \
--disable-static \
- --disable-rpath
+ %{nil}
%make_build
@@ -92,57 +97,51 @@ server and client.
# Remove cruft
find %{buildroot} -name '*.*a' -delete -print
-# Delete rpath
-chrpath --delete %{buildroot}%{_bindir}/yaz-icu
-chrpath --delete %{buildroot}%{_bindir}/yaz-url
-chrpath --delete %{buildroot}%{_bindir}/yaz-json-parse
-chrpath --delete %{buildroot}%{_bindir}/yaz-illclient
-chrpath --delete %{buildroot}%{_bindir}/yaz-client
-chrpath --delete %{buildroot}%{_bindir}/yaz-marcdump
-chrpath --delete %{buildroot}%{_bindir}/zoomsh
-chrpath --delete %{buildroot}%{_bindir}/yaz-iconv
-chrpath --delete %{buildroot}%{_bindir}/yaz-ztest
-
%check
make check
-%post -n lib%{name} -p /sbin/ldconfig
+%ldconfig_scriptlets -n lib%{name}
-%postun -n lib%{name} -p /sbin/ldconfig
+%ldconfig_scriptlets -n lib%{name}
%files
-%doc NEWS README
+%doc NEWS
+%doc README.md
%license LICENSE
%{_bindir}/yaz-client
-%{_bindir}/yaz-ztest
-%{_bindir}/yaz-marcdump
%{_bindir}/yaz-iconv
-%{_bindir}/yaz-illclient
%{_bindir}/yaz-icu
+%{_bindir}/yaz-illclient
%{_bindir}/yaz-json-parse
+%{_bindir}/yaz-marcdump
+%{_bindir}/yaz-record-conv
%{_bindir}/yaz-url
+%{_bindir}/yaz-ztest
%{_bindir}/zoomsh
%{_mandir}/man1/yaz-client.*
-%{_mandir}/man1/yaz-illclient.*
-%{_mandir}/man8/yaz-ztest.*
-%{_mandir}/man1/zoomsh.*
-%{_mandir}/man1/yaz-marcdump.*
%{_mandir}/man1/yaz-iconv.*
%{_mandir}/man1/yaz-icu.*
-%{_mandir}/man7/yaz-log.*
+%{_mandir}/man1/yaz-illclient.*
%{_mandir}/man1/yaz-json-parse.*
+%{_mandir}/man7/yaz-log.*
+%{_mandir}/man1/yaz-marcdump.*
+%{_mandir}/man1/yaz-record-conv.*
%{_mandir}/man1/yaz-url.*
+%{_mandir}/man8/yaz-ztest.*
+%{_mandir}/man1/zoomsh.*
%files -n lib%{name}
%license LICENSE
-%{_libdir}/*.so.*
+%{_libdir}/libyaz.so.5*
+%{_libdir}/libyaz_icu.so.5*
+%{_libdir}/libyaz_server.so.5*
%{_mandir}/man7/yaz.*
%{_mandir}/man7/bib1-attr.*
%files -n lib%{name}-devel
-%doc NEWS README
-%{_bindir}/yaz-config
+%doc NEWS README.md
%{_bindir}/yaz-asncomp
+%{_bindir}/yaz-config
%{_libdir}/pkgconfig/*
%{_libdir}/*.so
%{_includedir}/%{name}/
@@ -152,10 +151,16 @@ make check
%{_mandir}/man1/yaz-config.*
%files -n %{name}-doc
-%{_datadir}/doc/yaz/
+%{_pkgdocdir}
%changelog
+* Wed Jul 31 2024 Remi Collet <remi@remirepo.net> - 5.34.1-1
+- update to 5.34.1 ans sync with F40
+
+* Wed Jun 19 2024 Mamoru TASAKA <mtasaka@fedoraproject.org> - 5.34.1-1
+- 5.34.1
+
* Mon Dec 5 2016 Remi Collet <remi@remirepo.net> - 5.14.11-1
- rebuild for remi repo waiting #1366650