summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-11-22 15:29:25 +0100
committerRemi Collet <remi@php.net>2021-11-22 15:29:25 +0100
commit423f98550f2c5c567bce20f274f6b33ed4f2f1da (patch)
tree2cf6013374d0a851ef378cad3ad3d5cf2f30aded
parentcb327d4a0098b9e8d446451c60ad82ac43676b44 (diff)
add patch proposal for https://github.com/nginx/unit/issues/600
-rw-r--r--unit-upstream.patch16
-rw-r--r--unit.spec8
2 files changed, 23 insertions, 1 deletions
diff --git a/unit-upstream.patch b/unit-upstream.patch
new file mode 100644
index 0000000..8304f65
--- /dev/null
+++ b/unit-upstream.patch
@@ -0,0 +1,16 @@
+diff --git a/src/nxt_main_process.c b/src/nxt_main_process.c
+--- a/src/nxt_main_process.c
++++ b/src/nxt_main_process.c
+@@ -972,9 +972,11 @@ nxt_main_process_sigchld_handler(nxt_tas
+
+ if (rt->nprocesses <= 1) {
+ nxt_runtime_quit(task, 0);
++
++ return;
+ }
+
+- return;
++ continue;
+ }
+
+ nxt_port_remove_notify_others(task, process);
diff --git a/unit.spec b/unit.spec
index ec529e2..39c2743 100644
--- a/unit.spec
+++ b/unit.spec
@@ -17,7 +17,7 @@
Name: unit
Summary: NGINX Unit application server
Version: 1.26.0
-Release: 2%{?dist}
+Release: 3%{?dist}
License: ASL 2.0
URL: https://unit.nginx.org/
@@ -33,6 +33,8 @@ Patch0: %{project}-syspol.patch
# Workaround for OpenSSL 3.0
# https://github.com/nginx/unit/pull/598
Patch1: %{project}-openssl3.patch
+# https://github.com/nginx/unit/issues/600
+Patch2: %{project}-upstream.patch
BuildRequires: make
BuildRequires: gcc
@@ -68,6 +70,7 @@ Library and include files required for NGINX Unit modules development.
%setup -qn %{project}-%{gh_commit}
%patch0 -p1 -b .syspol
%patch1 -p1 -b .openssl3
+%patch2 -p1 -b .stop
cp pkg/rpm/rpmbuild/SOURCES/unit.example.config example.config
@@ -191,6 +194,9 @@ BANNER
%changelog
+* Mon Nov 22 2021 Remi Collet <remi@remirepo.net> - 1.26.0-3
+- add patch proposal for https://github.com/nginx/unit/issues/600
+
* Thu Nov 18 2021 Remi Collet <remi@remirepo.net> - 1.26.0-2
- add better workaround for OpenSSL 3.0 from
https://github.com/nginx/unit/pull/598