summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-09-03 18:11:20 +0200
committerRemi Collet <remi@remirepo.net>2021-09-03 18:11:20 +0200
commita3211358265bfafa5089300210c9be11fc43ff7c (patch)
treed395b24f51e606196e6661ceea3b495b38334a7b
parent12c94da1f0bc6fcbc8def691f92dc3860104b7f8 (diff)
fix build with recent glibc using patch from
https://github.com/nginx/unit/pull/576
-rw-r--r--unit-build.patch25
-rw-r--r--unit-php.spec9
2 files changed, 33 insertions, 1 deletions
diff --git a/unit-build.patch b/unit-build.patch
new file mode 100644
index 0000000..c2b0ef4
--- /dev/null
+++ b/unit-build.patch
@@ -0,0 +1,25 @@
+From 0125873b1dfbe6e671e3c9874ec2653f1b7832fa Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 3 Sep 2021 18:03:38 +0200
+Subject: [PATCH] fix build with recent glibc
+
+---
+ src/nxt_thread.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/nxt_thread.h b/src/nxt_thread.h
+index d7800cc..36e74cd 100644
+--- a/src/nxt_thread.h
++++ b/src/nxt_thread.h
+@@ -142,7 +142,7 @@ nxt_thread_yield() \
+ #endif
+
+
+-#if (PTHREAD_STACK_MIN)
++#if defined(PTHREAD_STACK_MIN)
+ #define NXT_THREAD_STACK_MIN PTHREAD_STACK_MIN
+
+ #else
+--
+2.31.1
+
diff --git a/unit-php.spec b/unit-php.spec
index 01c3baa..5904298 100644
--- a/unit-php.spec
+++ b/unit-php.spec
@@ -35,13 +35,15 @@ Requires: %{scl_prefix}php-embedded
Name: %{?scl_prefix}%{project}-php
Version: 1.25.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP module for NGINX Unit
License: ASL 2.0
URL: https://unit.nginx.org/
Source0: https://github.com/%{gh_owner}/%{project}/archive/%{gh_commit}/%{project}-%{version}-%{gh_short}.tar.gz
+Patch1: unit-build.patch
+
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -62,6 +64,7 @@ and NGINX unit %{version}.
%prep
%setup -qn %{project}-%{gh_commit}
+%patch1 -p1 -b .build
%build
@@ -122,6 +125,10 @@ make %{modname}-install DESTDIR=%{buildroot}
%changelog
+* Fri Sep 3 2021 Remi Collet <remi@remirepo.net> - 1.25.0-3
+- fix build with recent glibc using patch from
+ https://github.com/nginx/unit/pull/576
+
* Wed Sep 01 2021 Remi Collet <remi@remirepo.net> - 1.25.0-2
- rebuild for 8.1.0RC1