summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-15 16:57:33 +0100
committerRemi Collet <remi@php.net>2022-12-15 16:57:33 +0100
commit83819330b4353871a89f945a01c79d9de7ea6ee3 (patch)
tree5fb675bf4d45f3e40fb42b46d7607866ab16c17d
parent1449f7d6d52eaeb26e0f3053180e54149417398f (diff)
update to 1.29.0
drop patch merged upstream
-rw-r--r--unit-php.spec12
-rw-r--r--unit-php82.patch42
2 files changed, 6 insertions, 48 deletions
diff --git a/unit-php.spec b/unit-php.spec
index 7c37f8c..65ceefe 100644
--- a/unit-php.spec
+++ b/unit-php.spec
@@ -9,7 +9,7 @@
%global gh_owner nginx
%global project unit
-%global gh_commit 38bd7e76a134084ab95a4ee3125af1ccd7b35864
+%global gh_commit 87a1a9c0d275c6869e50bc9f3dfca1227ec54868
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%undefine _debugsource_packages
@@ -34,7 +34,7 @@ Requires: %{scl_prefix}php-embedded
%endif
Name: %{?scl_prefix}%{project}-php
-Version: 1.28.0
+Version: 1.29.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: PHP module for NGINX Unit
License: ASL 2.0
@@ -42,9 +42,6 @@ URL: https://unit.nginx.org/
Source0: https://github.com/%{gh_owner}/%{project}/archive/%{gh_commit}/%{project}-%{version}-%{gh_short}.tar.gz
-# https://github.com/nginx/unit/pull/713
-Patch0: %{project}-php82.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
@@ -65,7 +62,6 @@ and NGINX unit %{version}.
%prep
%setup -qn %{project}-%{gh_commit}
-%patch0 -p1
%build
@@ -126,6 +122,10 @@ make %{modname}-install DESTDIR=%{buildroot}
%changelog
+* Thu Dec 15 2022 Remi Collet <remi@remirepo.net> - 1.29.0-1
+- update to 1.29.0
+- drop patch merged upstream
+
* Tue Sep 13 2022 Remi Collet <remi@remirepo.net> - 1.28.0-1
- update to 1.28.0
diff --git a/unit-php82.patch b/unit-php82.patch
deleted file mode 100644
index abcfcf2..0000000
--- a/unit-php82.patch
+++ /dev/null
@@ -1,42 +0,0 @@
-From e90451adbe213803ef5f456e7715a2a79d83dccd Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 2 Jun 2022 16:16:35 +0200
-Subject: [PATCH] fix php_module_startup call for PHP 8.2
-
----
- auto/modules/php | 4 ++++
- src/nxt_php_sapi.c | 4 ++++
- 2 files changed, 8 insertions(+)
-
-diff --git a/auto/modules/php b/auto/modules/php
-index e92a67cd3..328cd8df2 100644
---- a/auto/modules/php
-+++ b/auto/modules/php
-@@ -149,7 +149,11 @@ nxt_feature_test="
- #include <php_main.h>
-
- int main() {
-+ #if PHP_VERSION_ID < 80200
- php_module_startup(NULL, NULL, 0);
-+ #else
-+ php_module_startup(NULL, NULL);
-+ #endif
- return 0;
- }"
-
-diff --git a/src/nxt_php_sapi.c b/src/nxt_php_sapi.c
-index 68ef07eb1..dda3c1f21 100644
---- a/src/nxt_php_sapi.c
-+++ b/src/nxt_php_sapi.c
-@@ -1150,7 +1150,11 @@ nxt_php_vcwd_chdir(nxt_unit_request_info_t *req, u_char *dir)
- static int
- nxt_php_startup(sapi_module_struct *sapi_module)
- {
-+#if PHP_VERSION_ID < 80200
- return php_module_startup(sapi_module, &nxt_php_unit_module, 1);
-+#else
-+ return php_module_startup(sapi_module, &nxt_php_unit_module);
-+#endif
- }
-
-