summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-08 16:42:03 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-08 16:42:03 +0200
commite8f4f6c57e164e9de16b846a5f95290e21089bcb (patch)
tree356d5b73567284142a1ae99b4ac2fa4a43d31078
parent597f34a3255e9f5233047cbd669d522cecf5947a (diff)
php-pecl-http: add upstream patch for php 7.1
-rw-r--r--Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 5d52b6e..fb7e252 100644
--- a/Makefile
+++ b/Makefile
@@ -106,6 +106,15 @@ php7build:
time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb $(NAME).spec ; \
fi
+php71build:
+ @if test -f $(NAME)-php7.spec ; then \
+ time rpmbuild $(RPMDEFINES) --define "scl php71" --without zts -bb $(NAME)-php7.spec ; \
+ elif test -f $(NAME)-dev.spec ; then \
+ time rpmbuild $(RPMDEFINES) --define "scl php71" --without zts -bb $(NAME)-dev.spec ; \
+ else \
+ time rpmbuild $(RPMDEFINES) --define "scl php71" --without zts -bb $(NAME).spec ; \
+ fi
+
php7test:
@if test -f $(NAME)-php7.spec ; then \
time rpmbuild $(RPMDEFINES) --define "scl php70" --without zts -bb --with tests $(NAME)-php7.spec ; \