summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2011-12-29 09:54:25 +0100
committerRemi Collet <fedora@famillecollet.com>2011-12-29 09:54:25 +0100
commitfec17e0bcfa5e1f3faf6d2d4a711655cac7f44bb (patch)
tree2058f11680cb1385367027edfab1d9280a001c0e
parentb7dd3f6aea2a29f963b9ce297700af02c6331998 (diff)
syck with php 5.4
-rw-r--r--syck-php54.patch12
-rw-r--r--syck.spec25
2 files changed, 36 insertions, 1 deletions
diff --git a/syck-php54.patch b/syck-php54.patch
new file mode 100644
index 0000000..b54b7db
--- /dev/null
+++ b/syck-php54.patch
@@ -0,0 +1,12 @@
+diff -up syck-0.61+svn231+patches/ext/php/phpext.c.php54 syck-0.61+svn231+patches/ext/php/phpext.c
+--- syck-0.61+svn231+patches/ext/php/phpext.c.php54 2011-12-29 09:37:51.361894355 +0100
++++ syck-0.61+svn231+patches/ext/php/phpext.c 2011-12-29 09:48:41.682923536 +0100
+@@ -27,7 +27,7 @@ static double mynan() { return zero() /
+ *
+ * Every user visible function must have an entry in syck_functions[].
+ */
+-function_entry syck_functions[] = {
++zend_function_entry syck_functions[] = {
+ PHP_FE(syck_load, NULL)
+ {NULL, NULL, NULL} /* Must be the last line in syck_functions[] */
+ };
diff --git a/syck.spec b/syck.spec
index e3a0467..eba1cae 100644
--- a/syck.spec
+++ b/syck.spec
@@ -2,6 +2,14 @@
%{!?php_version:%define php_version %(php-config --version || echo bad)}
%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
+# Private libraries are not be exposed globally by RPM
+# RPM 4.8
+%{?filter_provides_in: %filter_provides_in %{php_extdir}/.*\.so$}
+%{?filter_setup}
+# RPM 4.9
+%global __provides_exclude_from %{?__provides_exclude_from:%__provides_exclude_from|}%{php_extdir}/.*\\.so$
+
+
Name: syck
Summary: YAML for C, Python, and PHP
@@ -17,6 +25,7 @@ Source1: syck.ini
Patch0: syck-0.55-libtool.patch
Patch1: syck-nan.patch
+Patch2: syck-php54.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: gawk bison flex libtool
@@ -42,7 +51,7 @@ filtering.
%package php
Summary: YAML module for php
Group: Development/Languages
-%if %{?php_zend_api}0
+%if %{?php_zend_api:1}0
Requires: php(zend-abi) = %{php_zend_api}
Requires: php(api) = %{php_core_api}
%else
@@ -111,6 +120,7 @@ Syck.
%setup -q -n syck-0.61+svn231+patches
%patch0 -p1 -b .libtool
%patch1 -p0 -b .nan
+%patch2 -p1 -b .php54
%build
# Rebuild all
@@ -169,6 +179,14 @@ popd # End python extension
# Get out of extension
popd
+%check
+# minimal load test for the PHP extension
+LD_LIBRARY_PATH=%{buildroot}%{_libdir} php -n \
+ -d extension_dir=%{buildroot}%{php_extdir} \
+ -d extension=syck.so -m \
+ | grep syck
+
+
%clean
rm -rf $RPM_BUILD_ROOT
@@ -197,6 +215,11 @@ rm -rf $RPM_BUILD_ROOT
%config(noreplace) %{_sysconfdir}/php.d/syck.ini
%changelog
+* Thu Dec 29 2011 Remi Collet <remi@fedoraproject.org> - 7.0.3-1
+- build with php 5.4, with patch
+- add minimal load test for PHP extension
+- add provides filters
+
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.61-13
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild