summaryrefslogtreecommitdiffstats
path: root/0001-Honor-CFLAGS-passed-to-cmake.patch
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-18 14:22:43 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-18 14:22:43 +0200
commitd9a493b0b171b645d280d5d481d416be41673d8f (patch)
tree70a9be813d313065a5421bc92fd7f012abf414c8 /0001-Honor-CFLAGS-passed-to-cmake.patch
parent5cc0f6388ee49b67f5c7f2ce94243b42fe423ecf (diff)
scl-utils: f23 (re)build
Diffstat (limited to '0001-Honor-CFLAGS-passed-to-cmake.patch')
-rw-r--r--0001-Honor-CFLAGS-passed-to-cmake.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/0001-Honor-CFLAGS-passed-to-cmake.patch b/0001-Honor-CFLAGS-passed-to-cmake.patch
new file mode 100644
index 0000000..dc6a1e3
--- /dev/null
+++ b/0001-Honor-CFLAGS-passed-to-cmake.patch
@@ -0,0 +1,25 @@
+From 0100e1a89bc7ba3f7e94960437f69294638322a6 Mon Sep 17 00:00:00 2001
+From: Lubos Kardos <lkardos@redhat.com>
+Date: Tue, 7 Jul 2015 10:25:40 +0200
+Subject: [PATCH] Honor CFLAGS passed to cmake resovles: #1239997
+
+---
+ src/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
+index 4cfeef3..d0f96fe 100644
+--- a/src/CMakeLists.txt
++++ b/src/CMakeLists.txt
+@@ -4,7 +4,7 @@ SET(MODULE_CMD "/usr/bin/modulecmd" )
+ SET(CONF_DIR "/etc/scl/conf/" )
+ CONFIGURE_FILE( config.h.cmake config.h )
+
+-SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g" )
++SET( CMAKE_C_FLAGS "-Wall -pedantic --std=gnu99 -D_GNU_SOURCE -g ${CMAKE_C_FLAGS}" )
+ INCLUDE_DIRECTORIES ("${PROJECT_BINARY_DIR}/src")
+ list(APPEND SOURCES scl.c debug.c scllib.c lib_common.c args.c sclmalloc.c fallback.c)
+ ADD_EXECUTABLE (scl ${SOURCES})
+--
+1.9.3
+