summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-07-04 08:30:44 +0200
committerRemi Collet <remi@php.net>2024-07-04 08:30:44 +0200
commit49db863d63ed603fa34d90c0330b9f74397636d8 (patch)
tree03f999403077a2bdba1753df06bb5fefdd9893ba
parent0710a637220022e39dec30ecc856ac71c7882dd0 (diff)
cleanup
-rw-r--r--Makefile2
-rw-r--r--failed.txt2
-rw-r--r--macros.php2
-rw-r--r--php-fpm.sysconfig14
-rw-r--r--php.conf14
-rw-r--r--php.conf214
-rw-r--r--php.spec4
7 files changed, 17 insertions, 35 deletions
diff --git a/Makefile b/Makefile
index 29b6a5b..96fad12 100644
--- a/Makefile
+++ b/Makefile
@@ -3,4 +3,4 @@ NAME := $(shell basename $(SRCDIR))
include ../../common/Makefile
srpm:
- rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php83' -bs $(NAME).spec
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php84' -bs $(NAME).spec
diff --git a/failed.txt b/failed.txt
index edbd717..aa7f430 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.3.9 (2024-07-04)
+===== 8.4.0alpha1 (2024-07-04)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/macros.php b/macros.php
index 54aea04..c5b0d76 100644
--- a/macros.php
+++ b/macros.php
@@ -18,5 +18,5 @@
%@SCL@__phpconfig @BINDIR@/php-config
-%@SCL@_pecl_xmldir @STATEDIR@/lib/php/peclxml
+%@SCL@pecl_xmldir @STATEDIR@/lib/php/peclxml
diff --git a/php-fpm.sysconfig b/php-fpm.sysconfig
deleted file mode 100644
index 4099ed6..0000000
--- a/php-fpm.sysconfig
+++ /dev/null
@@ -1,14 +0,0 @@
-# Additional environment file for php-fpm
-
-# This file is deprecated when systemd is used and
-# will be removed in the future
-
-# With systemd >= 204 you can simply drop a file with the
-# suffix .conf in /etc/systemd/system/php-fpm.service.d, with
-# [Service]
-# Environment=FOO=bar
-
-# See systemd documentation.
-# man systemd.unit
-# man systemd.exec
-
diff --git a/php.conf b/php.conf
index 0639c0a..424cb8f 100644
--- a/php.conf
+++ b/php.conf
@@ -50,3 +50,17 @@ DirectoryIndex index.php
#php_value opcache.file_cache "/var/lib/php/opcache"
</IfModule>
+
+# Redirect to local php-fpm if mod_php (5, 7 or 8) is not available
+<IfModule !mod_php5.c>
+ <IfModule !mod_php7.c>
+ <IfModule !mod_php.c>
+ # Enable http authorization headers
+ SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
+
+ <FilesMatch \.(php|phar)$>
+ SetHandler "proxy:fcgi://127.0.0.1:9000"
+ </FilesMatch>
+ </IfModule>
+ </IfModule>
+</IfModule>
diff --git a/php.conf2 b/php.conf2
deleted file mode 100644
index cdd7640..0000000
--- a/php.conf2
+++ /dev/null
@@ -1,14 +0,0 @@
-
-# Redirect to local php-fpm if mod_php (5, 7 or 8) is not available
-<IfModule !mod_php5.c>
- <IfModule !mod_php7.c>
- <IfModule !mod_php.c>
- # Enable http authorization headers
- SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
-
- <FilesMatch \.(php|phar)$>
- SetHandler "proxy:fcgi://127.0.0.1:9000"
- </FilesMatch>
- </IfModule>
- </IfModule>
-</IfModule>
diff --git a/php.spec b/php.spec
index c9adba4..17b51a9 100644
--- a/php.spec
+++ b/php.spec
@@ -114,9 +114,7 @@ Source4: php-fpm.conf
Source5: php-fpm-www.conf
Source6: php-fpm.service
Source7: php-fpm.logrotate
-Source8: php-fpm.sysconfig
Source9: php.modconf
-Source10: php.conf2
Source12: php-fpm.wants
# Configuration files for some extensions
Source50: 10-opcache.ini
@@ -1271,7 +1269,6 @@ cp %{SOURCE9} modconf
# Dual config file with httpd >= 2.4 (RHEL >= 7)
install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_modconfdir}/20-%{name}.conf
install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
sed -e 's:/var/lib:%{_localstatedir}/lib:' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
@@ -1315,7 +1312,6 @@ install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/ht
install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/*.service.d/%{?scl_prefix}php-fpm.conf
sed -e 's:/run:%{_localstatedir}/run:' \
- -e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
-e 's:php-fpm.service:%{?scl_prefix}php-fpm.service:' \
-e 's:/usr/sbin:%{_sbindir}:' \
-i $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service