summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-08-13 17:17:22 +0200
committerRemi Collet <remi@php.net>2024-08-13 17:17:22 +0200
commit2e5230819fb65319a5744dcf372aee3deb2a31b0 (patch)
treebc53fd8d3723a395fca52e085144855b792f9840
parent536922a7c7dc222b0ddf01e3d8ddedd9b676bf1a (diff)
Update to 8.4.0beta1
-rw-r--r--failed.txt22
-rw-r--r--php-8.4.0-ldap_r.patch12
-rw-r--r--php-8.4.0-phpinfo.patch (renamed from php-8.1.0-phpinfo.patch)16
-rw-r--r--php.ini34
-rw-r--r--php.spec9
5 files changed, 32 insertions, 61 deletions
diff --git a/failed.txt b/failed.txt
index 31d343d..4dbd7fd 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,18 +1,20 @@
-===== 8.4.0alpha4 (2024-08-01)
+===== 8.4.0beta1 (2024-08-15)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/scl83el8a/build.log:Tests failed : 0
-/var/lib/mock/scl83el8x/build.log:Tests failed : 0
-/var/lib/mock/scl83el9a/build.log:Tests failed : 0
-/var/lib/mock/scl83el9x/build.log:Tests failed : 0
-/var/lib/mock/scl83fc38x/build.log:Tests failed : 0
-/var/lib/mock/scl83fc39a/build.log:Tests failed : 0
-/var/lib/mock/scl83fc39x/build.log:Tests failed : 0
-/var/lib/mock/scl83fc40a/build.log:Tests failed : 0
-/var/lib/mock/scl83fc40x/build.log:Tests failed : 0
+/var/lib/mock/scl83el8a/build.log:Tests failed : 1
+/var/lib/mock/scl83el8x/build.log:Tests failed : 1
+/var/lib/mock/scl83el9a/build.log:Tests failed : 1
+/var/lib/mock/scl83el9x/build.log:Tests failed : 1
+/var/lib/mock/scl83fc38x/build.log:Tests failed : 1
+/var/lib/mock/scl83fc39a/build.log:Tests failed : 1
+/var/lib/mock/scl83fc39x/build.log:Tests failed : 1
+/var/lib/mock/scl83fc40a/build.log:Tests failed : 1
+/var/lib/mock/scl83fc40x/build.log:Tests failed : 1
+all:
+ 2 FPM: version string [sapi/fpm/tests/main-version.phpt]
(1) proc_open give erratic test results :(
diff --git a/php-8.4.0-ldap_r.patch b/php-8.4.0-ldap_r.patch
index ea27490..a574751 100644
--- a/php-8.4.0-ldap_r.patch
+++ b/php-8.4.0-ldap_r.patch
@@ -1,12 +1,12 @@
Use -lldap_r by default.
-diff -up php-7.4.0RC2/ext/ldap/config.m4.ldap_r php-7.4.0RC2/ext/ldap/config.m4
---- php-7.4.0RC2/ext/ldap/config.m4.ldap_r 2019-09-17 10:21:24.769200812 +0200
-+++ php-7.4.0RC2/ext/ldap/config.m4 2019-09-17 10:21:30.658181771 +0200
-@@ -71,7 +71,11 @@
- dnl -pc removal is a hack for clang
- MACHINE_INCLUDES=$($CC -dumpmachine | $SED 's/-pc//')
+diff -up php-8.4.0beta1/ext/ldap/config.m4.ldap_r php-8.4.0beta1/ext/ldap/config.m4
+--- php-8.4.0beta1/ext/ldap/config.m4.ldap_r 2024-08-13 15:48:12.000000000 +0200
++++ php-8.4.0beta1/ext/ldap/config.m4 2024-08-13 16:23:24.744311776 +0200
+@@ -72,7 +72,11 @@ if test "$PHP_LDAP" != "no"; then
+ AH_TEMPLATE([HAVE_ORALDAP],
+ [Define to 1 if the ldap extension uses the Oracle Instant Client.])
- if test -f $LDAP_LIBDIR/liblber.a || test -f $LDAP_LIBDIR/liblber.$SHLIB_SUFFIX_NAME || test -f $LDAP_LIBDIR/$MACHINE_INCLUDES/liblber.a || test -f $LDAP_LIBDIR/$MACHINE_INCLUDES/liblber.$SHLIB_SUFFIX_NAME; then
+ if test -f $LDAP_LIBDIR/libldap_r.$SHLIB_SUFFIX_NAME; then
diff --git a/php-8.1.0-phpinfo.patch b/php-8.4.0-phpinfo.patch
index d19b2f4..2536f9e 100644
--- a/php-8.1.0-phpinfo.patch
+++ b/php-8.4.0-phpinfo.patch
@@ -30,15 +30,15 @@ diff -up ./ext/standard/tests/general_functions/phpinfo.phpt.phpinfo ./ext/stand
Server API => Command Line Interface
Virtual Directory Support => %s
Configuration File (php.ini) Path => %s
-diff -up ./sapi/cli/php_cli.c.phpinfo ./sapi/cli/php_cli.c
---- ./sapi/cli/php_cli.c.phpinfo 2020-07-21 11:43:38.812475300 +0200
-+++ ./sapi/cli/php_cli.c 2020-07-21 11:43:45.783464540 +0200
-@@ -645,7 +645,7 @@ static int do_cli(int argc, char **argv)
- "NTS"
+diff -up ./main/main.c.phpinfo ./main/main.c
+--- ./main/main.c.phpinfo 2024-08-13 16:14:03.242363191 +0200
++++ ./main/main.c 2024-08-13 16:14:06.588499946 +0200
+@@ -119,7 +119,7 @@ PHPAPI char *php_get_version(sapi_module
+ "NTS"
#endif
#ifdef PHP_BUILD_COMPILER
-- " " PHP_BUILD_COMPILER
-+ " gcc"
+- " " PHP_BUILD_COMPILER
++ " gcc"
#endif
#ifdef PHP_BUILD_ARCH
- " " PHP_BUILD_ARCH
+ " " PHP_BUILD_ARCH
diff --git a/php.ini b/php.ini
index 0b5f76d..cdd2c0b 100644
--- a/php.ini
+++ b/php.ini
@@ -139,16 +139,6 @@
; Development Value: 1000
; Production Value: 1000
-; session.sid_bits_per_character
-; Default Value: 4
-; Development Value: 5
-; Production Value: 5
-
-; session.sid_length
-; Default Value: 32
-; Development Value: 26
-; Production Value: 26
-
; short_open_tag
; Default Value: On
; Development Value: Off
@@ -1195,9 +1185,6 @@ mysqlnd.collect_memory_statistics = Off
; key.
;mysqlnd.sha256_server_public_key =
-[OCI8]
-; see /etc/php.d/20-oci8.ini
-
[PostgreSQL]
; Allow or prevent persistent links.
; https://php.net/pgsql.allow-persistent
@@ -1390,15 +1377,6 @@ session.cache_expire = 180
; https://php.net/session.use-trans-sid
session.use_trans_sid = 0
-; Set session ID character length. This value could be between 22 to 256.
-; Shorter length than default is supported only for compatibility reason.
-; Users should use 32 or more chars.
-; https://php.net/session.sid-length
-; Default Value: 32
-; Development Value: 26
-; Production Value: 26
-session.sid_length = 26
-
; The URL rewriter will look for URLs in a defined set of HTML tags.
; <form> is special; if you include them here, the rewriter will
; add a hidden <input> field with the info which is otherwise appended
@@ -1424,18 +1402,6 @@ session.trans_sid_tags = "a=href,area=href,frame=src,form="
; Production Value: ""
;session.trans_sid_hosts=""
-; Define how many bits are stored in each character when converting
-; the binary hash data to something readable.
-; Possible values:
-; 4 (4 bits: 0-9, a-f)
-; 5 (5 bits: 0-9, a-v)
-; 6 (6 bits: 0-9, a-z, A-Z, "-", ",")
-; Default Value: 4
-; Development Value: 5
-; Production Value: 5
-; https://php.net/session.hash-bits-per-character
-session.sid_bits_per_character = 5
-
; Enable upload progress tracking in $_SESSION
; Default Value: On
; Development Value: On
diff --git a/php.spec b/php.spec
index ac54500..a348542 100644
--- a/php.spec
+++ b/php.spec
@@ -82,7 +82,7 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.4.0
-%global rcver alpha4
+%global rcver beta1
# TODO set PHP_EXTRA_VERSION for EOL version
Summary: PHP scripting language for creating dynamic web sites
@@ -141,7 +141,7 @@ Patch45: php-8.4.0-ldap_r.patch
Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
-Patch47: php-8.1.0-phpinfo.patch
+Patch47: php-8.4.0-phpinfo.patch
# Always warn about missing curve_name
# Both Fedora and RHEL do not support arbitrary EC parameters
Patch48: php-8.3.0-openssl-ec-param.patch
@@ -1076,7 +1076,7 @@ build --libdir=%{_libdir}/php \
--enable-opcache \
--enable-opcache-file \
--with-capstone \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
--enable-mbstring=shared \
--enable-mbregex \
--enable-gd=shared \
@@ -1636,6 +1636,9 @@ fi
%changelog
+* Tue Aug 13 2024 Remi Collet <remi@remirepo.net> - 8.4.0~beta1-1
+- Update to 8.4.0beta1
+
* Thu Aug 1 2024 Remi Collet <remi@remirepo.net> - 8.4.0~alpha4-1
- Update to 8.4.0alpha4