summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec11
1 files changed, 9 insertions, 2 deletions
diff --git a/php.spec b/php.spec
index 93602e1..d8c7a67 100644
--- a/php.spec
+++ b/php.spec
@@ -123,14 +123,14 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.3.0
-%global rcver beta1
+%global rcver beta2
%global lower %(echo %{rcver} | tr '[:upper:]' '[:lower:]')
# TODO set PHP_EXTRA_VERSION for EOL version
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -204,6 +204,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.4.0-datetests.patch
# WIP
+Patch400: php-dtrace.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -985,6 +986,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch -P300 -p1 -b .datetests
# WIP patch
+%patch -P400 -p1 -R -b .dtrace
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE ZEND_LICENSE
@@ -1862,6 +1864,11 @@ fi
%changelog
+* Tue Aug 1 2023 Remi Collet <remi@remirepo.net> - 8.3.0~beta2-1
+- update to 8.3.0beta2
+- revert upstream changes breaking DTrace build
+ see https://github.com/php/php-src/issues/11847
+
* Mon Jul 24 2023 Remi Collet <remi@remirepo.net> - 8.3.0~beta1-2
- openssl: always warn about missing curve_name