summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-06-05 17:46:15 +0200
committerRemi Collet <remi@php.net>2023-06-05 17:46:15 +0200
commit209c04be421b89be605cf422947bafe16225ca78 (patch)
tree63f275de77c6a5e7883bef1abf7a42c015502069
parentce6bb895e772b36d61237c635770e4c2ee51f766 (diff)
update to 8.2.0-dev
-rw-r--r--failed.txt7
-rw-r--r--php.ini10
-rw-r--r--php.spec30
3 files changed, 32 insertions, 15 deletions
diff --git a/failed.txt b/failed.txt
index ad13828..dc69562 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,15 +1,16 @@
-===== 8.2.7RC1 (2023-05-25)
+===== 8.3.0-dev (2023-06-05)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
-/var/lib/mock/scl82el7x/build.log:Tests failed : 0
+/var/lib/mock/scl82el7x/build.log:Tests failed : 1
/var/lib/mock/scl82el8x/build.log:Tests failed : 0
/var/lib/mock/scl82el9x/build.log:Tests failed : 0
-/var/lib/mock/scl82fc36x/build.log:Tests failed : 0
/var/lib/mock/scl82fc37x/build.log:Tests failed : 0
/var/lib/mock/scl82fc38x/build.log:Tests failed : 2
+el7x:
+ 5 ext/standard/tests/directory/bug74589_utf8.phpt
fc38x:
3 openssl_error_string() tests (OpenSSL >= 3.0) [ext/openssl/tests/openssl_error_string_basic_openssl3.phpt]
3 openssl_private_decrypt() tests [ext/openssl/tests/openssl_private_decrypt_basic.phpt]
diff --git a/php.ini b/php.ini
index fa92cd3..38b10a4 100644
--- a/php.ini
+++ b/php.ini
@@ -144,6 +144,11 @@
; Development Value: 5
; Production Value: 5
+; session.sid_length
+; Default Value: 32
+; Development Value: 26
+; Production Value: 26
+
; short_open_tag
; Default Value: On
; Development Value: Off
@@ -154,6 +159,11 @@
; Development Value: "GPCS"
; Production Value: "GPCS"
+; zend.assertions
+; Default Value: 1
+; Development Value: 1
+; Production Value: -1
+
; zend.exception_ignore_args
; Default Value: Off
; Development Value: Off
diff --git a/php.spec b/php.spec
index caf1b7b..af1824e 100644
--- a/php.spec
+++ b/php.spec
@@ -23,8 +23,8 @@
%endif
# API/ABI check
-%global apiver 20220829
-%global zendver 20220829
+%global apiver 20220830
+%global zendver 20220830
%global pdover 20170320
# Extension version
%global oci8ver 3.3.0
@@ -33,7 +33,7 @@
%global _hardened_build 1
# version used for php embedded library soname
-%global embed_version 8.2
+%global embed_version 8.3
# Ugly hack. Harcoded values to avoid relocation.
%global _httpd_mmn %(cat %{_root_includedir}/httpd/.mmn 2>/dev/null || echo 0)
@@ -117,17 +117,18 @@
%global with_httpd2410 0
%endif
-%global gh_commit e2e2d2997328951de813fd157b6b4bf8701d8607
+%global gh_commit 9ce6980b4d93d539341807087abef9217cb81351
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-#global gh_date 20220530
+%global gh_date 20230605
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.7
-%global rcver RC1
+%global upver 8.3.0
+%global rcver -dev
+%global lower DEV
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
+Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -239,7 +240,7 @@ BuildRequires: %{?dtsprefix}systemtap-sdt-devel
%endif
%if 0%{?gh_date}
BuildRequires: bison
-BuildRequires: re2c
+BuildRequires: re2c >= 1.0.3
%endif
# used for tests
BuildRequires: /bin/ps
@@ -392,7 +393,7 @@ Provides: %{?scl_prefix}php-date, %{?scl_prefix}php-date%{?_isa}
Provides: bundled(timelib)
Provides: %{?scl_prefix}php-exif, %{?scl_prefix}php-exif%{?_isa}
Provides: %{?scl_prefix}php-fileinfo, %{?scl_prefix}php-fileinfo%{?_isa}
-Provides: bundled(libmagic) = 5.29
+Provides: bundled(libmagic) = 5.43
Provides: %{?scl_prefix}php-filter, %{?scl_prefix}php-filter%{?_isa}
Provides: %{?scl_prefix}php-ftp, %{?scl_prefix}php-ftp%{?_isa}
Provides: %{?scl_prefix}php-gettext, %{?scl_prefix}php-gettext%{?_isa}
@@ -449,6 +450,7 @@ need to install this package.
%package opcache
Summary: The Zend OPcache
License: PHP-3.01
+BuildRequires: pkgconfig(capstone) >= 3.0
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-zendopcache = %{version}
Provides: %{?scl_prefix}php-pecl-zendopcache%{?_isa} = %{version}
@@ -985,7 +987,7 @@ cp Zend/asm/LICENSE BOOST_LICENSE
cp TSRM/LICENSE TSRM_LICENSE
cp sapi/fpm/LICENSE fpm_LICENSE
cp ext/mbstring/libmbfl/LICENSE libmbfl_LICENSE
-cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
+# cp ext/fileinfo/libmagic/LICENSE libmagic_LICENSE
cp ext/bcmath/libbcmath/LICENSE libbcmath_LICENSE
cp ext/date/lib/LICENSE.rst timelib_LICENSE
@@ -1210,6 +1212,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
+ --with-capstone \
--enable-phpdbg \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
@@ -1712,7 +1715,7 @@ fi
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
%license LICENSE TSRM_LICENSE ZEND_LICENSE BOOST_LICENSE
-%license libmagic_LICENSE
+#license libmagic_LICENSE
%license timelib_LICENSE
%doc php.ini-*
%config(noreplace) %{_sysconfdir}/php.ini
@@ -1851,6 +1854,9 @@ fi
%changelog
+* Mon Jun 5 2023 Remi Collet <remi@remirepo.net> - 8.3.0~DEV.20230605-1
+- update to 8.2.0-dev
+
* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 8.2.7~RC1-1
- update to 8.2.7RC1