summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec336
1 files changed, 260 insertions, 76 deletions
diff --git a/php.spec b/php.spec
index 7d0625d..c88a7e9 100644
--- a/php.spec
+++ b/php.spec
@@ -27,7 +27,7 @@
%global zendver 20220829
%global pdover 20170320
# Extension version
-%global oci8ver 3.2.1
+%global oci8ver 3.3.0
# Adds -z now to the linker flags
%global _hardened_build 1
@@ -49,8 +49,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.7
+%ifarch aarch64
+%global oraclever 19.22
+%global oraclelib 19.1
+%global oracledir 19.22
+%else
+%global oraclever 21.13
%global oraclelib 21.1
+%global oracledir 21
+%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -122,14 +129,13 @@
#global gh_date 20220530
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.0
-%global rcver RC2
-%global lower %(echo %{rcver} | tr '[:upper:]' '[:lower:]')
+%global upver 8.2.19
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
-Version: %{upver}%{?rcver:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 15%{?dist}
+Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -137,7 +143,7 @@ Release: 15%{?dist}
# ext/date/lib is MIT
# Zend/zend_sort is NCSA
# Zend/asm is Boost
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost
+License: PHP-3.01 AND Zend-2.0 AND BSD-2-Clause AND MIT AND Apache-1.0 AND NCSA AND BSL-1.0
URL: http://www.php.net/
%if 0%{?gh_date}
@@ -177,7 +183,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch43: php-8.1.0-systzdata-v22.patch
+Patch43: php-8.1.0-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch44: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -192,7 +198,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-pr9537.patch
# Security fixes (200+)
@@ -222,7 +227,7 @@ BuildRequires: pkgconfig(libedit)
%if %{with libpcre}
BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
-Provides: bundled(pcre2) = 10.32
+Provides: bundled(pcre2) = 10.40
%endif
%if %{with libxcrypt}
BuildRequires: pkgconfig(libxcrypt)
@@ -299,7 +304,7 @@ which adds support for the PHP language to system Apache HTTP Server.
%package cli
Summary: Command-line interface for PHP
# sapi/cli/ps_title.c is PostgreSQL
-License: PHP and Zend and BSD and MIT and ASL 1.0 and NCSA and Boost and PostgreSQL
+License: PHP-3.01 AND Zend-2.0 AND BSD-2-Clause AND MIT AND Apache-1.0 AND NCSA AND PostgreSQL
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-cgi = %{version}-%{release}, %{?scl_prefix}php-cgi%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-pcntl, %{?scl_prefix}php-pcntl%{?_isa}
@@ -372,7 +377,16 @@ Summary: Common files for PHP
# All files licensed under PHP version 3.01, except
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
-License: PHP and BSD
+License: PHP-3.01 AND BSD-2-Clause
+
+%if %{with tzdata}
+Requires: tzdata
+%endif
+%if %{with libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php(api) = %{apiver}-%{__isa_bits}
Provides: %{?scl_prefix}php(zend-abi) = %{zendver}-%{__isa_bits}
@@ -444,7 +458,7 @@ need to install this package.
%package opcache
Summary: The Zend OPcache
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-zendopcache = %{version}
Provides: %{?scl_prefix}php-pecl-zendopcache%{?_isa} = %{version}
@@ -462,7 +476,7 @@ bytecode optimization patterns that make code execution faster.
%package imap
Summary: A module for PHP applications that use IMAP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(krb5)
BuildRequires: pkgconfig(krb5-gssapi)
@@ -478,7 +492,7 @@ messages on mail servers. PHP is an HTML-embedded scripting language.
%package ldap
Summary: A module for PHP applications that use LDAP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libsasl2)
BuildRequires: openldap-devel
@@ -493,7 +507,7 @@ language.
%package pdo
Summary: A database access abstraction module for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php-pdo-abi = %{pdover}-%{__isa_bits}
@@ -512,7 +526,7 @@ databases.
%package mysqlnd
Summary: A module for PHP applications that use MySQL databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-mysqli = %{version}-%{release}
@@ -531,7 +545,7 @@ This package use the MySQL Native Driver
%package pgsql
Summary: A PostgreSQL database module for PHP
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_pgsql, %{?scl_prefix}php-pdo_pgsql%{?_isa}
@@ -550,7 +564,7 @@ php package.
%package process
Summary: Modules for PHP script using system process interfaces
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-posix, %{?scl_prefix}php-posix%{?_isa}
Provides: %{?scl_prefix}php-shmop, %{?scl_prefix}php-shmop%{?_isa}
@@ -567,7 +581,7 @@ communication.
Summary: A module for PHP applications that use ODBC databases
# All files licensed under PHP version 3.01, except
# pdo_odbc is licensed under PHP version 3.0
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_odbc, %{?scl_prefix}php-pdo_odbc%{?_isa}
@@ -586,7 +600,7 @@ package.
%package soap
Summary: A module for PHP applications that use the SOAP protocol
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libxml-2.0)
@@ -598,7 +612,7 @@ support to PHP for using the SOAP web services protocol.
%package pdo-firebird
Summary: PDO driver for Interbase/Firebird databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: firebird-devel
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
@@ -623,8 +637,15 @@ License.
%package oci8
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
+%ifarch aarch64
+BuildRequires: oracle-instantclient%{oraclever}-devel
+# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
+Requires: libclntsh.so.%{oraclelib}
+AutoReq: 0
+%else
BuildRequires: oracle-instantclient-devel >= %{oraclever}
+%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci
@@ -633,8 +654,6 @@ Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
-AutoReq: 0
%description oci8
The %{?scl_prefix}php-oci8 packages provides the OCI8 extension version %{oci8ver}
@@ -644,13 +663,9 @@ The extension is linked with Oracle client libraries %{oraclever}
(Oracle Instant Client). For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
-You must install libclntsh.so.%{oraclelib} to use this package, provided
-in the database installation, or in the free Oracle Instant Client
-available from Oracle.
-
-Notice:
-- %{?scl_prefix}php-oci8 provides oci8 and pdo_oci extensions from php sources.
-- %{?scl_prefix}php-pecl-oci8 only provides oci8 extension.
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%endif
@@ -658,7 +673,7 @@ Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%package snmp
Summary: A module for PHP applications that query SNMP-managed devices
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}, net-snmp
BuildRequires: net-snmp-devel
@@ -671,7 +686,7 @@ will need to install this package and the php package.
%package xml
Summary: A module for PHP applications which use XML
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-dom, %{?scl_prefix}php-dom%{?_isa}
Provides: %{?scl_prefix}php-domxml, %{?scl_prefix}php-domxml%{?_isa}
@@ -694,7 +709,7 @@ Summary: A module for PHP applications which need multi-byte string handling
# libmbfl is licensed under LGPLv2
# onigurama is licensed under BSD
# ucgendat is licensed under OpenLDAP
-License: PHP and LGPLv2 and BSD and OpenLDAP
+License: PHP-3.01 AND LGPL-2.1-only AND OLDAP-2.8
%if 0%{?rhel}
BuildRequires: oniguruma5php-devel
%else
@@ -711,10 +726,10 @@ support for multi-byte string handling to PHP.
Summary: A module for PHP applications for using the gd graphics library
# All files licensed under PHP version 3.01
%if %{with libgd}
-License: PHP
+License: PHP-3.01
%else
-# bundled libgd is licensed under BSD
-License: PHP and BSD
+# bundled libgd is licensed under MIT
+License: PHP-3.01 and MIT
%endif
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%if %{with libgd}
@@ -739,7 +754,7 @@ support for using the gd graphics library to PHP.
Summary: A module for PHP applications for using the bcmath library
# All files licensed under PHP version 3.01, except
# libbcmath is licensed under LGPLv2+
-License: PHP and LGPLv2+
+License: PHP-3.01 AND LGPL-2.1-or-later
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
Provides: bundled(libbcmath)
@@ -750,7 +765,7 @@ support for using the bcmath library to PHP.
%package gmp
Summary: A module for PHP applications for using the GNU MP library
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: gmp-devel
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
@@ -761,7 +776,7 @@ using the GNU MP library.
%package dba
Summary: A database abstraction layer module for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
BuildRequires: libdb-devel
BuildRequires: tokyocabinet-devel
BuildRequires: lmdb-devel
@@ -779,7 +794,7 @@ support for using the DBA database abstraction layer to PHP.
%package tidy
Summary: Standard PHP module provides tidy library support
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: libtidy-devel
@@ -792,7 +807,7 @@ support for using the tidy library to PHP.
%package pdo-dblib
Summary: PDO driver for Microsoft SQL Server and Sybase databases
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
BuildRequires: freetds-devel
Provides: %{?scl_prefix}php-pdo_dblib, %{?scl_prefix}php-pdo_dblib%{?_isa}
@@ -806,7 +821,7 @@ PHP to Microsoft SQL Server and Sybase databases through the FreeTDS library.
%package pspell
Summary: A module for PHP applications for using pspell interfaces
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: aspell-devel >= 0.50.0
@@ -817,11 +832,11 @@ support for using the pspell library to PHP.
%package intl
Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 71
-BuildRequires: pkgconfig(icu-io) >= 71
-BuildRequires: pkgconfig(icu-uc) >= 71
+BuildRequires: pkgconfig(icu-i18n) >= 73
+BuildRequires: pkgconfig(icu-io) >= 73
+BuildRequires: pkgconfig(icu-uc) >= 73
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -831,7 +846,7 @@ support for using the ICU library to PHP.
%package enchant
Summary: Enchant spelling extension for PHP applications
# All files licensed under PHP version 3.0
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(enchant-2)
@@ -844,7 +859,7 @@ support for using the enchant library to PHP.
%package zip
Summary: ZIP archive management extension for PHP
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
BuildRequires: pkgconfig(libzip) >= 0.11
@@ -857,7 +872,7 @@ support for ZIP archive management to PHP.
%package sodium
Summary: Wrapper for the Sodium cryptographic library
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
# Minimal is 1.0.8, 1.0.14 is needed for argon2 password
BuildRequires: pkgconfig(libsodium) >= 1.0.14
@@ -874,7 +889,7 @@ low-level PHP extension for the libsodium cryptographic library.
%package ffi
Summary: Foreign Function Interface
# All files licensed under PHP version 3.0.1
-License: PHP
+License: PHP-3.01
BuildRequires: pkgconfig(libffi)
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
@@ -946,35 +961,32 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
%endif
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
%if 0%{?rhel} == 7
-%patch10 -p1 -b .curltls
+%patch -P10 -p1 -b .curltls
%endif
-%patch41 -p1 -b .syslib
+%patch -P41 -p1 -b .syslib
%if %{with tzdata}
-%patch43 -p1 -b .systzdata
+%patch -P43 -p1 -b .systzdata
%endif
-%patch44 -p1 -b .headers
+%patch -P44 -p1 -b .headers
sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
-%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
-%patch45 -p1 -b .ldap_r
-%endif
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .pr9537
# security patches
# Fixes for tests
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
# WIP patch
@@ -1246,8 +1258,8 @@ build --libdir=%{_libdir}/php \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
%if %{with oci8}
- --with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
+ --with-oci8=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
%endif
%if %{with firebird}
--with-pdo-firebird=shared \
@@ -1460,9 +1472,9 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install systemd unit files and scripts for handling server startup
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
-install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
-sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_unitdir}/*.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
+sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/*.service.d/%{?scl_prefix}php-fpm.conf
%endif
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
@@ -1772,8 +1784,8 @@ fi
%{_unitdir}/%{?scl_prefix}php-fpm.service
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
-%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%config(noreplace) %{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
+%config(noreplace) %{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
%{_sbindir}/php-fpm
%dir %{_sysconfdir}/php-fpm.d
@@ -1850,6 +1862,178 @@ fi
%changelog
+* Wed Apr 24 2024 Remi Collet <remi@remirepo.net> - 8.2.19~RC1-1
+- update to 8.2.19RC1
+- use oracle client library version 19.22 on aarch64
+
+* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 8.2.18-1
+- Update to 8.2.18 - http://www.php.net/releases/8_2_18.php
+
+* Tue Mar 26 2024 Remi Collet <remi@remirepo.net> - 8.2.18~RC1-1
+- update to 8.2.18RC1
+
+* Tue Mar 12 2024 Remi Collet <remi@remirepo.net> - 8.2.17-1
+- Update to 8.2.17 - http://www.php.net/releases/8_2_17.php
+
+* Wed Feb 28 2024 Remi Collet <remi@remirepo.net> - 8.2.17~RC2-1
+- update to 8.2.17RC2
+
+* Tue Feb 27 2024 Remi Collet <remi@remirepo.net> - 8.2.17~RC1-1
+- update to 8.2.17RC1
+
+* Wed Feb 14 2024 Remi Collet <remi@remirepo.net> - 8.2.16-1
+- Update to 8.2.16 - http://www.php.net/releases/8_2_16.php
+- use oracle client library version 21.13 on x86_64
+
+* Wed Jan 31 2024 Remi Collet <remi@remirepo.net> - 8.2.16~RC1-1
+- update to 8.2.16RC1
+
+* Tue Jan 16 2024 Remi Collet <remi@remirepo.net> - 8.2.15-1
+- Update to 8.2.15 - http://www.php.net/releases/8_2_15.php
+
+* Tue Jan 2 2024 Remi Collet <remi@remirepo.net> - 8.2.15~RC1-1
+- update to 8.2.15RC1
+
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 8.2.14-1
+- Update to 8.2.14 - http://www.php.net/releases/8_2_14.php
+
+* Wed Dec 6 2023 Remi Collet <remi@remirepo.net> - 8.2.14~RC1-1
+- update to 8.2.14RC1
+
+* Tue Nov 21 2023 Remi Collet <remi@remirepo.net> - 8.2.13-1
+- Update to 8.2.13 - http://www.php.net/releases/8_2_13.php
+
+* Tue Nov 7 2023 Remi Collet <remi@remirepo.net> - 8.2.13~RC1-1
+- update to 8.2.13RC1
+- use oracle client library version 21.12 on x86_64
+- use ICU 73.2
+
+* Wed Oct 25 2023 Remi Collet <remi@remirepo.net> - 8.2.12-1
+- Update to 8.2.12 - http://www.php.net/releases/8_2_12.php
+
+* Wed Oct 11 2023 Remi Collet <remi@remirepo.net> - 8.2.12~RC1-1
+- update to 8.2.12RC1
+- add internal UTC if tzdata is missing
+
+* Tue Sep 26 2023 Remi Collet <remi@remirepo.net> - 8.2.11-1
+- Update to 8.2.11 - http://www.php.net/releases/8_2_11.php
+
+* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 8.2.11~RC1-2
+- use oracle client library version 19.19 on aarch64
+- use official Oracle Instant Client RPM
+
+* Tue Sep 12 2023 Remi Collet <remi@remirepo.net> - 8.2.11~RC1-1
+- update to 8.2.11RC1
+- use oracle client library version 21.11
+
+* Tue Aug 29 2023 Remi Collet <remi@remirepo.net> - 8.2.10-1
+- Update to 8.2.10 - http://www.php.net/releases/8_2_10.php
+
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 8.2.10~RC1-1
+- update to 8.2.10RC1
+
+* Thu Aug 3 2023 Remi Collet <remi@remirepo.net> - 8.2.9-2
+- Update to 8.2.9 - http://www.php.net/releases/8_2_9.php
+- rebuild for new sources
+
+* Tue Aug 1 2023 Remi Collet <remi@remirepo.net> - 8.2.9-1
+- Update to 8.2.9 - http://www.php.net/releases/8_2_9.php
+
+* Tue Jul 18 2023 Remi Collet <remi@remirepo.net> - 8.2.9~RC1-1
+- update to 8.2.9RC1
+- move httpd/nginx wants directive to config files in /etc
+
+* Wed Jul 5 2023 Remi Collet <remi@remirepo.net> - 8.2.8-1
+- Update to 8.2.8 - http://www.php.net/releases/8_2_8.php
+
+* Tue Jun 20 2023 Remi Collet <remi@remirepo.net> - 8.2.8~RC1-1
+- update to 8.2.8RC1
+
+* Wed Jun 7 2023 Remi Collet <remi@remirepo.net> - 8.2.7-2
+- Update to 8.2.7 - http://www.php.net/releases/8_2_7.php
+- rebuild for new sources
+
+* Tue Jun 6 2023 Remi Collet <remi@remirepo.net> - 8.2.7-1
+- Update to 8.2.7 - http://www.php.net/releases/8_2_7.php
+
+* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 8.2.7~RC1-1
+- update to 8.2.7RC1
+
+* Wed May 10 2023 Remi Collet <remi@remirepo.net> - 8.2.6-1
+- Update to 8.2.6 - http://www.php.net/releases/8_2_6.php
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.2.6~RC1-2
+- define %%php82___phpize and %%php82___phpconfig
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.2.6~RC1-1
+- update to 8.2.6RC1
+- use oracle client library version 21.10
+- use ICU 72.1
+- oci8 version is now 3.3.0
+
+* Wed Apr 12 2023 Remi Collet <remi@remirepo.net> - 8.2.5-1
+- Update to 8.2.5 - http://www.php.net/releases/8_2_5.php
+
+* Wed Mar 29 2023 Remi Collet <remi@remirepo.net> - 8.2.5~RC1-1
+- update to 8.2.5RC1
+
+* Wed Mar 15 2023 Remi Collet <remi@remirepo.net> - 8.2.4-1
+- Update to 8.2.4 - http://www.php.net/releases/8_2_4.php
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 8.2.4~RC1-1
+- update to 8.2.4RC1
+
+* Tue Feb 21 2023 Remi Collet <remi@remirepo.net> - 8.2.3-2
+- F38: enable imap extension
+
+* Tue Feb 14 2023 Remi Collet <remi@remirepo.net> - 8.2.3-1
+- Update to 8.2.3 - http://www.php.net/releases/8_2_3.php
+
+* Wed Feb 1 2023 Remi Collet <remi@remirepo.net> - 8.2.2-1
+- Update to 8.2.2 - http://www.php.net/releases/8_2_2.php
+- add dependency on pcre2 minimal version
+
+* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 8.2.2~RC1-1
+- update to 8.2.2RC1
+
+* Wed Jan 4 2023 Remi Collet <remi@remirepo.net> - 8.2.1-1
+- Update to 8.2.1 - http://www.php.net/releases/8_2_1.php
+
+* Tue Dec 20 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-3
+- add upstream patch for failing test
+
+* Mon Dec 19 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-2
+- php-fpm.conf: move include directive after [global] section
+ https://github.com/remicollet/remirepo/issues/225
+
+* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-1
+- update to 8.2.1RC1
+- use oracle client library version 21.8
+
+* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 8.2.0-1
+- update to 8.2.0 GA
+
+* Fri Nov 25 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc7-22
+- test build for GH-9997 with new upstream patch
+
+* Thu Nov 24 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc7-21
+- test build for GH-9997 with upstream patch reverted
+
+* Wed Nov 23 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc7-19
+- update to 8.2.0RC7
+
+* Tue Nov 8 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc6-19
+- update to 8.2.0RC6
+
+* Wed Oct 26 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc5-18
+- update to 8.2.0RC5
+
+* Tue Oct 11 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc4-17
+- update to 8.2.0RC4
+
+* Wed Sep 28 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc3-16
+- update to 8.2.0RC3
+
* Wed Sep 14 2022 Remi Collet <remi@remirepo.net> - 8.2.0~rc2-15
- update to 8.2.0RC2 (new tag)
- add patch from https://github.com/php/php-src/pull/9537