summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec174
1 files changed, 152 insertions, 22 deletions
diff --git a/php.spec b/php.spec
index 0f1d37a..693c992 100644
--- a/php.spec
+++ b/php.spec
@@ -49,8 +49,10 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.11
-%global oraclelib 21.1
+%global oraclever 23.7
+%global oraclemax 24
+%global oraclelib 23.1
+%global oracledir 23
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -68,7 +70,11 @@
%bcond_with zip
# Optional extensions; to disable: pass "--without xxx" etc to rpmbuild/mock.
%bcond_without imap
+%if 0%{?rhel} == 10
+%bcond_with firebird
+%else
%bcond_without firebird
+%endif
%bcond_without freetds
%bcond_without tidy
%bcond_without sqlite3
@@ -122,8 +128,8 @@
#global gh_date 20220530
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.11
-%global rcver RC1
+%global upver 8.2.28
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -176,7 +182,7 @@ Patch10: php-8.2.0-curl.patch
# Use system nikic/php-parser
Patch41: php-8.2.0-parser.patch
# use system tzdata
-Patch43: php-8.1.0-systzdata-v23.patch
+Patch43: php-8.2.23-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch44: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -185,7 +191,7 @@ Patch45: php-7.4.0-ldap_r.patch
Patch46: php-8.0.7-argon2.patch
# drop "Configure command" from phpinfo output
# and only use gcc (instead of full version)
-Patch47: php-8.1.0-phpinfo.patch
+Patch47: php-8.2.25-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -197,6 +203,10 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.4.0-datetests.patch
+# for pcre2 10.45 (F42)
+Patch301: php-8.2.28-pcretests.patch
+# for zlib-ng
+Patch302: php-8.2.28-zlibtests.patch
# WIP
@@ -236,6 +246,9 @@ BuildRequires: libtool
BuildRequires: libtool-ltdl-devel
%if %{with dtrace}
BuildRequires: %{?dtsprefix}systemtap-sdt-devel
+%if 0%{?fedora} >= 41
+BuildRequires: %{?dtsprefix}systemtap-sdt-dtrace
+%endif
%endif
%if 0%{?gh_date}
BuildRequires: bison
@@ -372,6 +385,9 @@ Summary: Common files for PHP
# regex, libmagic are licensed under BSD
License: PHP-3.01 AND BSD-2-Clause
+%if %{with tzdata}
+Requires: tzdata
+%endif
%if %{with libpcre}
%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
Requires: pcre2%{?_isa} >= %{pcre2_buildver}
@@ -628,7 +644,7 @@ License.
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
License: PHP-3.01
-BuildRequires: oracle-instantclient-devel >= %{oraclever}
+BuildRequires: (oracle-instantclient-devel >= %{oraclever} with oracle-instantclient-devel < %{oraclemax})
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci
@@ -637,8 +653,6 @@ Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
-AutoReq: 0
%description oci8
The %{?scl_prefix}php-oci8 packages provides the OCI8 extension version %{oci8ver}
@@ -648,13 +662,9 @@ The extension is linked with Oracle client libraries %{oraclever}
(Oracle Instant Client). For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
-You must install libclntsh.so.%{oraclelib} to use this package, provided
-in the database installation, or in the free Oracle Instant Client
-available from Oracle.
-
-Notice:
-- %{?scl_prefix}php-oci8 provides oci8 and pdo_oci extensions from php sources.
-- %{?scl_prefix}php-pecl-oci8 only provides oci8 extension.
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%endif
@@ -823,9 +833,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP-3.01
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 72
-BuildRequires: pkgconfig(icu-io) >= 72
-BuildRequires: pkgconfig(icu-uc) >= 72
+BuildRequires: pkgconfig(icu-i18n) >= 74
+BuildRequires: pkgconfig(icu-io) >= 74
+BuildRequires: pkgconfig(icu-uc) >= 74
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -976,6 +986,8 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
# Fixes for tests
%patch -P300 -p1 -b .datetests
+%patch -P301 -p1 -b .pcretests
+%patch -P302 -p1 -b .zlibtests
# WIP patch
@@ -1210,7 +1222,7 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
- --enable-phpdbg \
+ --enable-phpdbg --enable-phpdbg-readline \
%if %{with imap}
--with-imap=shared --with-imap-ssl \
%endif
@@ -1247,8 +1259,8 @@ build --libdir=%{_libdir}/php \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
%if %{with oci8}
- --with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
+ --with-oci8=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
%endif
%if %{with firebird}
--with-pdo-firebird=shared \
@@ -1851,6 +1863,124 @@ fi
%changelog
+* Wed Mar 12 2025 Remi Collet <remi@remirepo.net> - 8.2.28-1
+- Update to 8.2.28 - http://www.php.net/releases/8_2_28.php
+- use oracle client library version 23.7 on x86_64 and arm64
+
+* Tue Dec 17 2024 Remi Collet <remi@remirepo.net> - 8.2.27-1
+- Update to 8.2.27 - http://www.php.net/releases/8_2_27.php
+
+* Tue Dec 3 2024 Remi Collet <remi@remirepo.net> - 8.2.27~RC1-1
+- update to 8.2.27RC1
+
+* Wed Nov 20 2024 Remi Collet <remi@remirepo.net> - 8.2.26-1
+- Update to 8.2.26 - http://www.php.net/releases/8_2_26.php
+
+* Wed Nov 6 2024 Remi Collet <remi@remirepo.net> - 8.2.26~RC1-1
+- update to 8.2.26RC1
+
+* Wed Oct 23 2024 Remi Collet <remi@remirepo.net> - 8.2.25-1
+- Update to 8.2.25 - http://www.php.net/releases/8_2_25.php
+
+* Wed Oct 9 2024 Remi Collet <remi@remirepo.net> - 8.2.25~RC1-1
+- update to 8.2.25RC1
+
+* Wed Sep 25 2024 Remi Collet <remi@remirepo.net> - 8.2.24-1
+- Update to 8.2.24 - http://www.php.net/releases/8_2_24.php
+
+* Wed Sep 11 2024 Remi Collet <remi@remirepo.net> - 8.2.24~RC1-1
+- update to 8.2.24RC1
+- use ICU 74.2
+
+* Wed Aug 28 2024 Remi Collet <remi@remirepo.net> - 8.2.23-1
+- Update to 8.2.23 - http://www.php.net/releases/8_2_23.php
+
+* Wed Aug 14 2024 Remi Collet <remi@remirepo.net> - 8.2.23~RC1-1
+- update to 8.2.23RC1
+
+* Tue Jul 30 2024 Remi Collet <remi@remirepo.net> - 8.2.22-1
+- Update to 8.2.22 - http://www.php.net/releases/8_2_22.php
+- use oracle client library version 23.5 on x86_64
+
+* Wed Jul 17 2024 Remi Collet <remi@remirepo.net> - 8.2.22~RC1-1
+- update to 8.2.22RC1
+- use oracle client library version 23.4 on x86_64, 19.23 on aarch64
+
+* Tue Jul 2 2024 Remi Collet <remi@remirepo.net> - 8.2.21-1
+- Update to 8.2.21 - http://www.php.net/releases/8_2_21.php
+
+* Fri Jun 7 2024 Remi Collet <remi@remirepo.net> - 8.2.20-2
+- Fix GH-14480 Method visibility issue introduced in version 8.2.20
+
+* Tue Jun 4 2024 Remi Collet <remi@remirepo.net> - 8.2.20-1
+- Update to 8.2.20 - http://www.php.net/releases/8_2_20.php
+
+* Wed May 22 2024 Remi Collet <remi@remirepo.net> - 8.2.20~RC1-1
+- update to 8.2.20RC1
+
+* Mon May 13 2024 Remi Collet <remi@remirepo.net> - 8.2.19-1
+- Update to 8.2.19 - http://www.php.net/releases/8_2_19.php
+
+* Wed Apr 24 2024 Remi Collet <remi@remirepo.net> - 8.2.19~RC1-1
+- update to 8.2.19RC1
+- use oracle client library version 19.22 on aarch64
+
+* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 8.2.18-1
+- Update to 8.2.18 - http://www.php.net/releases/8_2_18.php
+
+* Tue Mar 26 2024 Remi Collet <remi@remirepo.net> - 8.2.18~RC1-1
+- update to 8.2.18RC1
+
+* Tue Mar 12 2024 Remi Collet <remi@remirepo.net> - 8.2.17-1
+- Update to 8.2.17 - http://www.php.net/releases/8_2_17.php
+
+* Wed Feb 28 2024 Remi Collet <remi@remirepo.net> - 8.2.17~RC2-1
+- update to 8.2.17RC2
+
+* Tue Feb 27 2024 Remi Collet <remi@remirepo.net> - 8.2.17~RC1-1
+- update to 8.2.17RC1
+
+* Wed Feb 14 2024 Remi Collet <remi@remirepo.net> - 8.2.16-1
+- Update to 8.2.16 - http://www.php.net/releases/8_2_16.php
+- use oracle client library version 21.13 on x86_64
+
+* Wed Jan 31 2024 Remi Collet <remi@remirepo.net> - 8.2.16~RC1-1
+- update to 8.2.16RC1
+
+* Tue Jan 16 2024 Remi Collet <remi@remirepo.net> - 8.2.15-1
+- Update to 8.2.15 - http://www.php.net/releases/8_2_15.php
+
+* Tue Jan 2 2024 Remi Collet <remi@remirepo.net> - 8.2.15~RC1-1
+- update to 8.2.15RC1
+
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 8.2.14-1
+- Update to 8.2.14 - http://www.php.net/releases/8_2_14.php
+
+* Wed Dec 6 2023 Remi Collet <remi@remirepo.net> - 8.2.14~RC1-1
+- update to 8.2.14RC1
+
+* Tue Nov 21 2023 Remi Collet <remi@remirepo.net> - 8.2.13-1
+- Update to 8.2.13 - http://www.php.net/releases/8_2_13.php
+
+* Tue Nov 7 2023 Remi Collet <remi@remirepo.net> - 8.2.13~RC1-1
+- update to 8.2.13RC1
+- use oracle client library version 21.12 on x86_64
+- use ICU 73.2
+
+* Wed Oct 25 2023 Remi Collet <remi@remirepo.net> - 8.2.12-1
+- Update to 8.2.12 - http://www.php.net/releases/8_2_12.php
+
+* Wed Oct 11 2023 Remi Collet <remi@remirepo.net> - 8.2.12~RC1-1
+- update to 8.2.12RC1
+- add internal UTC if tzdata is missing
+
+* Tue Sep 26 2023 Remi Collet <remi@remirepo.net> - 8.2.11-1
+- Update to 8.2.11 - http://www.php.net/releases/8_2_11.php
+
+* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 8.2.11~RC1-2
+- use oracle client library version 19.19 on aarch64
+- use official Oracle Instant Client RPM
+
* Tue Sep 12 2023 Remi Collet <remi@remirepo.net> - 8.2.11~RC1-1
- update to 8.2.11RC1
- use oracle client library version 21.11