summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-14 10:20:42 +0100
committerRemi Collet <remi@php.net>2022-12-14 10:20:42 +0100
commit4da3a41a91b5e2b0f3ecf421991fec406b92785d (patch)
tree0918b24b91f0e1f5e6cc930c0a595d1e98d83d3e
parent7732ae7c77f01f1aa030b602f220f110c0f91e2f (diff)
update to 8.2.1RC1
use oracle client library version 21.8
-rw-r--r--failed.txt2
-rw-r--r--php.spec12
-rw-r--r--upstream.patch31
3 files changed, 8 insertions, 37 deletions
diff --git a/failed.txt b/failed.txt
index 5b7dba6..d9bddd0 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.2.0 (2022-12-08)
+===== 8.2.1RC1 (2022-12-15)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/php.spec b/php.spec
index 5eb9f6f..5aef839 100644
--- a/php.spec
+++ b/php.spec
@@ -49,7 +49,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.7
+%global oraclever 21.8
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -122,8 +122,8 @@
#global gh_date 20220530
%global gh_owner php
%global gh_project php-src
-%global upver 8.2.0
-#global rcver RC7
+%global upver 8.2.1
+%global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -191,7 +191,6 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: upstream.patch
# Security fixes (200+)
@@ -968,7 +967,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1
# security patches
@@ -1849,6 +1847,10 @@ fi
%changelog
+* Wed Dec 14 2022 Remi Collet <remi@remirepo.net> - 8.2.1~RC1-1
+- update to 8.2.1RC1
+- use oracle client library version 21.8
+
* Tue Dec 6 2022 Remi Collet <remi@remirepo.net> - 8.2.0-1
- update to 8.2.0 GA
diff --git a/upstream.patch b/upstream.patch
deleted file mode 100644
index be72054..0000000
--- a/upstream.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 3d90a24e9349ea17e5467de7b1d7bfa17ec2c650 Mon Sep 17 00:00:00 2001
-From: Jakub Zelenka <bukka@php.net>
-Date: Thu, 24 Nov 2022 18:29:44 +0000
-Subject: [PATCH] Fix GH-9997: OpenSSL engine clean up segfault
-
----
- NEWS | 3 +++
- ext/openssl/openssl.c | 5 +++--
- 2 files changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/ext/openssl/openssl.c b/ext/openssl/openssl.c
-index cb5e6260b4ab..da555c843c15 100644
---- a/ext/openssl/openssl.c
-+++ b/ext/openssl/openssl.c
-@@ -1324,13 +1324,14 @@ PHP_MSHUTDOWN_FUNCTION(openssl)
- #if OPENSSL_VERSION_NUMBER < 0x10100000L || defined (LIBRESSL_VERSION_NUMBER)
- EVP_cleanup();
-
-+ /* prevent accessing locking callback from unloaded extension */
-+ CRYPTO_set_locking_callback(NULL);
-+
- #ifndef OPENSSL_NO_ENGINE
- /* Free engine list initialized by OPENSSL_config */
- ENGINE_cleanup();
- #endif
-
-- /* prevent accessing locking callback from unloaded extension */
-- CRYPTO_set_locking_callback(NULL);
- /* free allocated error strings */
- ERR_free_strings();
- CONF_modules_free();