summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec14
1 files changed, 12 insertions, 2 deletions
diff --git a/php.spec b/php.spec
index 4e40462..9449212 100644
--- a/php.spec
+++ b/php.spec
@@ -123,7 +123,7 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.1.15
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -220,7 +220,7 @@ BuildRequires: pkgconfig(libedit)
%if %{with libpcre}
BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
-Provides: bundled(pcre2) = 10.32
+Provides: bundled(pcre2) = 10.39
%endif
%if %{with libxcrypt}
BuildRequires: pkgconfig(libxcrypt)
@@ -370,6 +370,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php(api) = %{apiver}-%{__isa_bits}
Provides: %{?scl_prefix}php(zend-abi) = %{zendver}-%{__isa_bits}
@@ -1847,6 +1853,10 @@ fi
%changelog
+* Wed Feb 1 2023 Remi Collet <remi@remirepo.net> - 8.1.15-1
+- Update to 8.1.15 - http://www.php.net/releases/8_1_15.php
+- add dependency on pcre2 minimal version
+
* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 8.1.15~RC1-1
- update to 8.1.15RC1