summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec226
1 files changed, 186 insertions, 40 deletions
diff --git a/php.spec b/php.spec
index 5ffaf33..a474615 100644
--- a/php.spec
+++ b/php.spec
@@ -49,8 +49,15 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.7
+%ifarch aarch64
+%global oraclever 19.19
+%global oraclelib 19.1
+%global oracledir 19.19
+%else
+%global oraclever 21.13
%global oraclelib 21.1
+%global oracledir 21
+%endif
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
%bcond_without lsws
@@ -122,8 +129,8 @@
#global gh_date 20210809
%global gh_owner php
%global gh_project php-src
-%global upver 8.1.11
-%global rcver RC1
+%global upver 8.1.28
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
@@ -169,6 +176,8 @@ Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-8.0.0-embed.patch
Patch8: php-8.1.0-libdb.patch
+# For libxml 2.12 from 8.1
+Patch9: php-8.1.27-libxml212.patch
# RHEL backports
Patch10: php-7.0.7-curl.patch
@@ -176,7 +185,7 @@ Patch10: php-7.0.7-curl.patch
# Use system nikic/php-parser
Patch41: php-8.1.0-parser.patch
# use system tzdata
-Patch43: php-8.1.0-systzdata-v22.patch
+Patch43: php-8.1.0-systzdata-v24.patch
# See http://bugs.php.net/53436
Patch44: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
@@ -197,6 +206,7 @@ Patch91: php-7.2.0-oci8conf.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.4.0-datetests.patch
+Patch301: php-8.1.27-zlib-tests.patch
# WIP
@@ -220,7 +230,7 @@ BuildRequires: pkgconfig(libedit)
%if %{with libpcre}
BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
-Provides: bundled(pcre2) = 10.32
+Provides: bundled(pcre2) = 10.39
%endif
%if %{with libxcrypt}
BuildRequires: pkgconfig(libxcrypt)
@@ -370,6 +380,15 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with tzdata}
+Requires: tzdata
+%endif
+%if %{with libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php(api) = %{apiver}-%{__isa_bits}
Provides: %{?scl_prefix}php(zend-abi) = %{zendver}-%{__isa_bits}
@@ -620,7 +639,14 @@ License.
Summary: A module for PHP applications that use OCI8 databases
# All files licensed under PHP version 3.01
License: PHP
+%ifarch aarch64
+BuildRequires: oracle-instantclient%{oraclever}-devel
+# Should requires libclntsh.so.19.1()(aarch-64), but it's not provided by Oracle RPM.
+Requires: libclntsh.so.%{oraclelib}
+AutoReq: 0
+%else
BuildRequires: oracle-instantclient-devel >= %{oraclever}
+%endif
Requires: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php_database
Provides: %{?scl_prefix}php-pdo_oci
@@ -629,8 +655,6 @@ Obsoletes: %{?scl_prefix}php-pecl-oci8 <= %{oci8ver}
Conflicts: %{?scl_prefix}php-pecl-oci8 > %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8) = %{oci8ver}
Provides: %{?scl_prefix}php-pecl(oci8)%{?_isa} = %{oci8ver}
-# Should requires libclntsh.so.18.3, but it's not provided by Oracle RPM.
-AutoReq: 0
%description oci8
The %{?scl_prefix}php-oci8 packages provides the OCI8 extension version %{oci8ver}
@@ -640,13 +664,9 @@ The extension is linked with Oracle client libraries %{oraclever}
(Oracle Instant Client). For details, see Oracle's note
"Oracle Client / Server Interoperability Support" (ID 207303.1).
-You must install libclntsh.so.%{oraclelib} to use this package, provided
-in the database installation, or in the free Oracle Instant Client
-available from Oracle.
-
-Notice:
-- %{?scl_prefix}php-oci8 provides oci8 and pdo_oci extensions from php sources.
-- %{?scl_prefix}php-pecl-oci8 only provides oci8 extension.
+You must install libclntsh.so.%{oraclelib} to use this package,
+provided by Oracle Instant Client RPM available from Oracle on:
+https://www.oracle.com/database/technologies/instant-client/downloads.html
Documentation is at http://php.net/oci8 and http://php.net/pdo_oci
%endif
@@ -815,9 +835,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 71
-BuildRequires: pkgconfig(icu-io) >= 71
-BuildRequires: pkgconfig(icu-uc) >= 71
+BuildRequires: pkgconfig(icu-i18n) >= 73
+BuildRequires: pkgconfig(icu-io) >= 73
+BuildRequires: pkgconfig(icu-uc) >= 73
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -942,34 +962,34 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
%endif
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch10 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%patch -P9 -p1 -b .libxml212
+%if 0%{?rhel} == 7
+%patch -P10 -p1 -b .curltls
%endif
-%patch41 -p1 -b .syslib
+%patch -P41 -p1 -b .syslib
%if %{with tzdata}
-%patch43 -p1 -b .systzdata
+%patch -P43 -p1 -b .systzdata
%endif
-%patch44 -p1 -b .headers
+%patch -P44 -p1 -b .headers
sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
-%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
-%patch45 -p1 -b .ldap_r
-%endif
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
# security patches
# Fixes for tests
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
+%patch -P301 -p1 -b .zlibng
# WIP patch
@@ -1244,8 +1264,8 @@ build --libdir=%{_libdir}/php \
--with-mysqli=shared,mysqlnd \
--with-mysql-sock=%{mysql_sock} \
%if %{with oci8}
- --with-oci8=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
- --with-pdo-oci=shared,instantclient,%{_root_libdir}/oracle/%{oraclever}/client64/lib,%{oraclever} \
+ --with-oci8=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
+ --with-pdo-oci=shared,instantclient,%{_root_prefix}/lib/oracle/%{oracledir}/client64/lib,%{oraclever} \
%endif
%if %{with firebird}
--with-pdo-firebird=shared \
@@ -1457,9 +1477,9 @@ mv $RPM_BUILD_ROOT%{_sysconfdir}/php-fpm.d/www.conf.default .
# install systemd unit files and scripts for handling server startup
install -Dm 644 %{SOURCE6} $RPM_BUILD_ROOT%{_unitdir}/%{?scl_prefix}php-fpm.service
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
-install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
-sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_unitdir}/*.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
+install -Dm 644 %{SOURCE12} $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
+sed -e 's/php-fpm/%{?scl_prefix}php-fpm/' -i $RPM_BUILD_ROOT%{_root_sysconfdir}/systemd/system/*.service.d/%{?scl_prefix}php-fpm.conf
%endif
sed -e 's:/run:%{_localstatedir}/run:' \
-e 's:/etc/sysconfig:%{_sysconfdir}/sysconfig:' \
@@ -1769,8 +1789,8 @@ fi
%{_unitdir}/%{?scl_prefix}php-fpm.service
%dir %{_root_sysconfdir}/systemd/system/%{?scl_prefix}php-fpm.service.d
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-%{_unitdir}/httpd.service.d/%{?scl_prefix}php-fpm.conf
-%{_unitdir}/nginx.service.d/%{?scl_prefix}php-fpm.conf
+%config(noreplace) %{_root_sysconfdir}/systemd/system/httpd.service.d/%{?scl_prefix}php-fpm.conf
+%config(noreplace) %{_root_sysconfdir}/systemd/system/nginx.service.d/%{?scl_prefix}php-fpm.conf
%endif
%{_sbindir}/php-fpm
%dir %{_sysconfdir}/php-fpm.d
@@ -1847,6 +1867,132 @@ fi
%changelog
+* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 8.1.28-1
+- Update to 8.1.28 - http://www.php.net/releases/8_1_28.php
+
+* Wed Mar 6 2024 Remi Collet <remi@remirepo.net> - 8.1.27-2
+- use oracle client library version 21.13 on x86_64
+- patch test suite for zlib-ng
+
+* Wed Dec 20 2023 Remi Collet <remi@remirepo.net> - 8.1.27-1
+- Update to 8.1.27 - http://www.php.net/releases/8_1_27.php
+
+* Tue Dec 5 2023 Remi Collet <remi@remirepo.net> - 8.1.27~RC1-1
+- update to 8.1.27RC1
+- add fixes for libxml 2.12 from 8.2
+
+* Wed Nov 22 2023 Remi Collet <remi@remirepo.net> - 8.1.26-1
+- Update to 8.1.26 - http://www.php.net/releases/8_1_26.php
+
+* Wed Nov 8 2023 Remi Collet <remi@remirepo.net> - 8.1.26~RC1-1
+- update to 8.1.26RC1
+- use oracle client library version 21.12 on x86_64
+- use ICU 73.2
+
+* Wed Oct 25 2023 Remi Collet <remi@remirepo.net> - 8.1.25-1
+- Update to 8.1.25 - http://www.php.net/releases/8_1_25.php
+
+* Wed Oct 11 2023 Remi Collet <remi@remirepo.net> - 8.1.25~RC1-1
+- update to 8.1.25RC1
+- add internal UTC if tzdata is missing
+
+* Wed Sep 27 2023 Remi Collet <remi@remirepo.net> - 8.1.24-1
+- Update to 8.1.24 - http://www.php.net/releases/8_1_24.php
+
+* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 8.1.24~RC1-2
+- use oracle client library version 19.19 on aarch64
+- use official Oracle Instant Client RPM
+
+* Wed Sep 13 2023 Remi Collet <remi@remirepo.net> - 8.1.24~RC1-1
+- update to 8.1.24RC1
+- use oracle client library version 21.11
+
+* Wed Aug 30 2023 Remi Collet <remi@remirepo.net> - 8.1.23-1
+- Update to 8.1.23 - http://www.php.net/releases/8_1_23.php
+
+* Thu Aug 17 2023 Remi Collet <remi@remirepo.net> - 8.1.23~RC1-1
+- update to 8.1.23RC1
+
+* Wed Aug 2 2023 Remi Collet <remi@remirepo.net> - 8.1.22-1
+- Update to 8.1.22 - http://www.php.net/releases/8_1_22.php
+
+* Wed Jul 19 2023 Remi Collet <remi@remirepo.net> - 8.1.22~RC1-1
+- update to 8.1.22RC1
+- move httpd/nginx wants directive to config files in /etc
+
+* Wed Jul 5 2023 Remi Collet <remi@remirepo.net> - 8.1.21-1
+- Update to 8.1.21 - http://www.php.net/releases/8_1_21.php
+
+* Tue Jun 20 2023 Remi Collet <remi@remirepo.net> - 8.1.21~RC1-1
+- update to 8.1.21RC1
+
+* Wed Jun 7 2023 Remi Collet <remi@remirepo.net> - 8.1.20-1
+- Update to 8.1.20 - http://www.php.net/releases/8_1_20.php
+
+* Wed May 24 2023 Remi Collet <remi@remirepo.net> - 8.1.20~RC1-1
+- update to 8.1.20RC1
+
+* Wed May 10 2023 Remi Collet <remi@remirepo.net> - 8.1.19-1
+- Update to 8.1.19 - http://www.php.net/releases/8_1_19.php
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.1.19~RC1-2
+- define %%php81___phpize and %%php81___phpconfig
+
+* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.1.19~RC1-1
+- update to 8.1.19RC1
+- use oracle client library version 21.10
+- use ICU 72.1
+
+* Wed Apr 12 2023 Remi Collet <remi@remirepo.net> - 8.1.18-1
+- Update to 8.1.18 - http://www.php.net/releases/8_1_18.php
+
+* Thu Mar 30 2023 Remi Collet <remi@remirepo.net> - 8.1.18~RC1-1
+- update to 8.1.18RC1
+
+* Wed Mar 15 2023 Remi Collet <remi@remirepo.net> - 8.1.17-1
+- Update to 8.1.17 - http://www.php.net/releases/8_1_17.php
+
+* Wed Mar 1 2023 Remi Collet <remi@remirepo.net> - 8.1.17~RC1-1
+- update to 8.1.17RC1
+
+* Tue Feb 21 2023 Remi Collet <remi@remirepo.net> - 8.1.16-2
+- F38: enable imap extension
+
+* Tue Feb 14 2023 Remi Collet <remi@remirepo.net> - 8.1.16-1
+- Update to 8.1.16 - http://www.php.net/releases/8_1_16.php
+
+* Wed Feb 1 2023 Remi Collet <remi@remirepo.net> - 8.1.15-1
+- Update to 8.1.15 - http://www.php.net/releases/8_1_15.php
+- add dependency on pcre2 minimal version
+
+* Wed Jan 18 2023 Remi Collet <remi@remirepo.net> - 8.1.15~RC1-1
+- update to 8.1.15RC1
+
+* Thu Jan 5 2023 Remi Collet <remi@remirepo.net> - 8.1.14-2
+- rebuild with new sources archive
+
+* Wed Jan 4 2023 Remi Collet <remi@remirepo.net> - 8.1.14-1
+- Update to 8.1.14 - http://www.php.net/releases/8_1_14.php
+
+* Mon Dec 12 2022 Remi Collet <remi@remirepo.net> - 8.1.14~RC1-1
+- update to 8.1.14RC1
+- use oracle client library version 21.8
+
+* Tue Nov 22 2022 Remi Collet <remi@remirepo.net> - 8.1.13-1
+- Update to 8.1.13 - http://www.php.net/releases/8_1_13.php
+
+* Wed Nov 9 2022 Remi Collet <remi@remirepo.net> - 8.1.13~RC1-1
+- update to 8.1.13RC1
+
+* Wed Oct 26 2022 Remi Collet <remi@remirepo.net> - 8.1.12-1
+- Update to 8.1.12 - http://www.php.net/releases/8_1_12.php
+
+* Wed Oct 12 2022 Remi Collet <remi@remirepo.net> - 8.1.12~RC1-1
+- update to 8.1.12RC1
+
+* Wed Sep 28 2022 Remi Collet <remi@remirepo.net> - 8.1.11-1
+- Update to 8.1.11 - http://www.php.net/releases/8_1_11.php
+
* Wed Sep 14 2022 Remi Collet <remi@remirepo.net> - 8.1.11~RC1-1
- update to 8.1.11RC1