summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-06-22 18:59:40 +0200
committerRemi Collet <remi@remirepo.net>2021-06-22 18:59:40 +0200
commit8d29ddbebd292159ca568e27500408ce97e85e2b (patch)
tree22acda565edf74ce7d680cdae0a3ff8826b01e92
parentf3dd3a29f7bc72be7e928bdeb83eeee3199f0dde (diff)
test build for upcoming 8.1.0alpha2
fix build for missing public API using patch from https://github.com/php/php-src/pull/7185
-rw-r--r--php-upstream.patch49
-rw-r--r--php.spec15
2 files changed, 60 insertions, 4 deletions
diff --git a/php-upstream.patch b/php-upstream.patch
new file mode 100644
index 0000000..b5a46d3
--- /dev/null
+++ b/php-upstream.patch
@@ -0,0 +1,49 @@
+From b83bfb2c5444865515673ff5da939b5f75604128 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Tue, 22 Jun 2021 18:42:43 +0200
+Subject: [PATCH] make new API public (#7185)
+
+---
+ ext/standard/crc32.c | 4 ++--
+ ext/standard/crc32.h | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/ext/standard/crc32.c b/ext/standard/crc32.c
+index c492a9602c3b5..8b4fa085058a3 100644
+--- a/ext/standard/crc32.c
++++ b/ext/standard/crc32.c
+@@ -89,7 +89,7 @@ static uint32_t crc32_aarch64(uint32_t crc, char *p, size_t nr) {
+ # endif
+ #endif
+
+-uint32_t crc32_bulk_update(uint32_t crc, const char *p, size_t nr)
++PHPAPI uint32_t crc32_bulk_update(uint32_t crc, const char *p, size_t nr)
+ {
+ #if HAVE_AARCH64_CRC32
+ if (has_crc32_insn()) {
+@@ -112,7 +112,7 @@ uint32_t crc32_bulk_update(uint32_t crc, const char *p, size_t nr)
+ return crc;
+ }
+
+-int crc32_stream_bulk_update(uint32_t *crc, php_stream *fp, size_t nr)
++PHPAPI int crc32_stream_bulk_update(uint32_t *crc, php_stream *fp, size_t nr)
+ {
+ size_t handled = 0, n;
+ char buf[1024];
+diff --git a/ext/standard/crc32.h b/ext/standard/crc32.h
+index 262713fd5ec8c..1de234208aa9e 100644
+--- a/ext/standard/crc32.h
++++ b/ext/standard/crc32.h
+@@ -23,10 +23,10 @@
+
+ #define CRC32(crc, ch) (crc = (crc >> 8) ^ crc32tab[(crc ^ (ch)) & 0xff])
+
+-uint32_t crc32_bulk_update(uint32_t crc, const char *p, size_t nr);
++PHPAPI uint32_t crc32_bulk_update(uint32_t crc, const char *p, size_t nr);
+
+ /* Return FAILURE if stream reading fail */
+-int crc32_stream_bulk_update(uint32_t *crc, php_stream *fp, size_t nr);
++PHPAPI int crc32_stream_bulk_update(uint32_t *crc, php_stream *fp, size_t nr);
+
+ /* generated using the AUTODIN II polynomial
+ * x^32 + x^26 + x^23 + x^22 + x^16 +
diff --git a/php.spec b/php.spec
index 1c6cd4a..76c319e 100644
--- a/php.spec
+++ b/php.spec
@@ -107,13 +107,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.1.0
-%global rcver alpha1
-%global lower alpha1
+%global rcver alpha2
+%global lower alpha2
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 0%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -177,6 +177,7 @@ Patch47: php-8.1.0-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
+Patch100: php-upstream.patch
# Security fixes (200+)
@@ -949,6 +950,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
+%patch100 -p1
# security patches
@@ -1317,7 +1319,7 @@ popd
%check
%if %{with tests}
-cd build-apache
+cd build-fpm
# Run tests, using the CLI SAPI
export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
@@ -1819,6 +1821,11 @@ fi
%changelog
+* Tue Jun 22 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha2-0
+- test build for upcoming 8.1.0alpha2
+- fix build for missing public API using patch from
+ https://github.com/php/php-src/pull/7185
+
* Wed Jun 9 2021 Remi Collet <remi@remirepo.net> - 8.1.0~alpha1-1
- update to 8.1.0alpha1