summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-05-10 17:15:04 +0200
committerRemi Collet <remi@php.net>2023-05-10 17:15:04 +0200
commit70029d5158f0fe4627a21c75236a2de51a99e28f (patch)
tree00781db16e012ee1cc77c689b0a8622918851382
parentdf1c2a1a8aa234a1eb00d1a18ff1e1f820f712b8 (diff)
Update to 8.1.19 - http://www.php.net/releases/8_1_19.phpv8.1.19
-rw-r--r--failed.txt2
-rw-r--r--macros.php1
-rw-r--r--php.spec37
3 files changed, 21 insertions, 19 deletions
diff --git a/failed.txt b/failed.txt
index e038d78..d0fec17 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,4 +1,4 @@
-===== 8.1.19RC1 (2023-04-27)
+===== 8.1.19 (2023-05-10)
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
diff --git a/macros.php b/macros.php
index c49070a..d3e937f 100644
--- a/macros.php
+++ b/macros.php
@@ -17,3 +17,4 @@
%@SCL@__phpize @BINDIR@/phpize
%@SCL@__phpconfig @BINDIR@/php-config
+
diff --git a/php.spec b/php.spec
index 4d58189..94aaf27 100644
--- a/php.spec
+++ b/php.spec
@@ -123,12 +123,12 @@
%global gh_owner php
%global gh_project php-src
%global upver 8.1.19
-%global rcver RC1
+#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 1%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -948,34 +948,32 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
%endif
-%patch1 -p1 -b .mpmcheck
-%patch5 -p1 -b .includedir
-%patch6 -p1 -b .embed
-%patch8 -p1 -b .libdb
-%if 0%{?rhel}
-%patch10 -p1 -b .curltls
+%patch -P1 -p1 -b .mpmcheck
+%patch -P5 -p1 -b .includedir
+%patch -P6 -p1 -b .embed
+%patch -P8 -p1 -b .libdb
+%if 0%{?rhel} == 7
+%patch -P10 -p1 -b .curltls
%endif
-%patch41 -p1 -b .syslib
+%patch -P41 -p1 -b .syslib
%if %{with tzdata}
-%patch43 -p1 -b .systzdata
+%patch -P43 -p1 -b .systzdata
%endif
-%patch44 -p1 -b .headers
+%patch -P44 -p1 -b .headers
sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
-%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
-%patch45 -p1 -b .ldap_r
-%endif
-%patch46 -p1 -b .argon2
-%patch47 -p1 -b .phpinfo
+%patch -P45 -p1 -b .ldap_r
+%patch -P46 -p1 -b .argon2
+%patch -P47 -p1 -b .phpinfo
-%patch91 -p1 -b .remi-oci8
+%patch -P91 -p1 -b .remi-oci8
# upstream patches
# security patches
# Fixes for tests
-%patch300 -p1 -b .datetests
+%patch -P300 -p1 -b .datetests
# WIP patch
@@ -1853,6 +1851,9 @@ fi
%changelog
+* Wed May 10 2023 Remi Collet <remi@remirepo.net> - 8.1.19-1
+- Update to 8.1.19 - http://www.php.net/releases/8_1_19.php
+
* Tue Apr 25 2023 Remi Collet <remi@remirepo.net> - 8.1.19~RC1-2
- define %%php81___phpize and %%php81___phpconfig