summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php.spec b/php.spec
index 1825843..b4dd485 100644
--- a/php.spec
+++ b/php.spec
@@ -55,7 +55,7 @@
%global oraclelib 19.1
%global oracledir 19.25
%else
-%global oraclever 23.6
+%global oraclever 23.7
%global oraclemax 24
%global oraclelib 23.1
%global oracledir 23
@@ -132,7 +132,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 11%{?dist}
+Release: 12%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -176,8 +176,10 @@ Patch7: php-7.4.0-libdb.patch
Patch8: php-8.0.30-libxml212.patch
# get rid of deprecated functions from 8.1
Patch9: php-8.0.6-deprecated.patch
-# RHEL backports
-Patch10: php-7.0.7-curl.patch
+# For recent ICU from 8.2
+Patch11: php-8.0.30-icu.patch
+# Fix strict prototypes from 8.1
+Patch12: php-8.0.30-proto.patch
# Functional changes
# Use system nikic/php-parser
@@ -986,9 +988,8 @@ in pure PHP.
%patch -P7 -p1 -b .libdb
%patch -P8 -p1 -b .libxml212
%patch -P9 -p1 -b .deprecated
-%if 0%{?rhel} == 7
-%patch -P10 -p1 -b .curltls
-%endif
+%patch -P11 -p1 -b .icu74
+%patch -P12 -p1 -b .proto
%patch -P41 -p1 -b .syslib
%patch -P42 -p1 -b .systzdata
@@ -1187,7 +1188,7 @@ scripts/dev/genfiles
touch configure.ac
./buildconf --force
-CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign"
+CFLAGS="$RPM_OPT_FLAGS -fno-strict-aliasing -Wno-pointer-sign -Wno-incompatible-pointer-types"
export CFLAGS
# Install extension modules in %{_libdir}/php/modules.
@@ -1916,6 +1917,9 @@ EOF
%changelog
+* Thu Feb 13 2025 Remi Collet <remi@remirepo.net> - 8.0.30-12
+- backport fix for ICU 74+
+
* Wed Nov 27 2024 Remi Collet <remi@remirepo.net> - 8.0.30-11
- Fix Leak partial content of the heap through heap buffer over-read
CVE-2024-8929