summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec12
1 files changed, 9 insertions, 3 deletions
diff --git a/php.spec b/php.spec
index 86b91f0..8335b96 100644
--- a/php.spec
+++ b/php.spec
@@ -50,9 +50,9 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
%ifarch aarch64
-%global oraclever 19.19
+%global oraclever 19.22
%global oraclelib 19.1
-%global oracledir 19.19
+%global oracledir 19.22
%else
%global oraclever 21.13
%global oraclelib 21.1
@@ -126,7 +126,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 5%{?dist}
+Release: 6%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -207,6 +207,7 @@ Patch91: php-7.2.0-oci8conf.patch
# Security fixes (200+)
Patch200: php-cve-2024-2756.patch
Patch201: php-cve-2024-3096.patch
+Patch202: php-cve-2024-5458.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
@@ -993,6 +994,7 @@ rm ext/openssl/tests/p12_with_extra_certs.p12
# security patches
%patch -P200 -p1 -b .cve2756
%patch -P201 -p1 -b .cve3096
+%patch -P202 -p1 -b .cve5458
# Fixes for tests
%patch -P300 -p1 -b .datetests
@@ -1885,6 +1887,10 @@ EOF
%changelog
+* Tue Jun 4 2024 Remi Collet <remi@remirepo.net> - 8.0.30-6
+- Fix filter bypass in filter_var FILTER_VALIDATE_URL
+ CVE-2024-5458
+
* Wed Apr 10 2024 Remi Collet <remi@remirepo.net> - 8.0.30-5
- Fix __Host-/__Secure- cookie bypass due to partial CVE-2022-31629 fix
CVE-2024-2756