summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-01 10:54:33 +0100
committerRemi Collet <remi@php.net>2023-02-01 10:54:33 +0100
commit6d9c638c5e0e6a9f8f38ee4850951bd6bfbe5760 (patch)
tree3da948cb1285ae5444bb08f80a40e4dfc0edf889
parent2811c454d7470f9666d0cc7c1ec9e05eba30e226 (diff)
add dependency on pcre2 minimal version
-rw-r--r--failed.txt2
-rw-r--r--php.spec8
2 files changed, 8 insertions, 2 deletions
diff --git a/failed.txt b/failed.txt
index 694d31a..96b9832 100644
--- a/failed.txt
+++ b/failed.txt
@@ -3,7 +3,7 @@
$ grep -ar 'Tests failed' /var/lib/mock/*/build.log
/var/lib/mock/scl80el7x/build.log:Tests failed : 0
-/var/lib/mock/scl80el8x/build.log:Tests failed : 1
+/var/lib/mock/scl80el8x/build.log:Tests failed : 0
/var/lib/mock/scl80el9x/build.log:Tests failed : 0
/var/lib/mock/scl80fc35x/build.log:Tests failed : 0
/var/lib/mock/scl80fc36x/build.log:Tests failed : 0
diff --git a/php.spec b/php.spec
index b11a7ed..f73a2a1 100644
--- a/php.spec
+++ b/php.spec
@@ -221,7 +221,7 @@ BuildRequires: pkgconfig(libedit)
%if %{with libpcre}
BuildRequires: pkgconfig(libpcre2-8) >= 10.30
%else
-Provides: bundled(pcre2) = 10.32
+Provides: bundled(pcre2) = 10.35
%endif
%if %{with libxcrypt}
BuildRequires: pkgconfig(libxcrypt)
@@ -368,6 +368,12 @@ Summary: Common files for PHP
# fileinfo is licensed under PHP version 3.0
# regex, libmagic are licensed under BSD
License: PHP and BSD
+
+%if %{with libpcre}
+%global pcre2_buildver %(pkg-config --silence-errors --modversion libpcre2-8 2>/dev/null || echo 10.30)
+Requires: pcre2%{?_isa} >= %{pcre2_buildver}
+%endif
+
# ABI/API check - Arch specific
Provides: %{?scl_prefix}php(api) = %{apiver}-%{__isa_bits}
Provides: %{?scl_prefix}php(zend-abi) = %{zendver}-%{__isa_bits}