summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-04-15 09:29:12 +0200
committerRemi Collet <remi@remirepo.net>2020-04-15 09:29:12 +0200
commit6224dc50a7aec5729ec6036f77f8a9ffb07df6b4 (patch)
tree59bd53396791f1572fd331c06196c021111b1458
parentffef10cdf19fb648662ee089a5ccffd0eb31f30d (diff)
new snapshot
-rw-r--r--Makefile2
-rw-r--r--failed.txt11
-rw-r--r--php.conf2
-rw-r--r--php.conf214
-rw-r--r--php.ini46
-rw-r--r--php.spec18
6 files changed, 38 insertions, 55 deletions
diff --git a/Makefile b/Makefile
index 9538721..a5696eb 100644
--- a/Makefile
+++ b/Makefile
@@ -3,4 +3,4 @@ NAME := $(shell basename $(SRCDIR))
include ../../common/Makefile
srpm:
- rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php74' -bs $(NAME).spec
+ rpmbuild $(RPMDEFINES) $(SRCDEFINES) --define 'scl php80' -bs $(NAME).spec
diff --git a/failed.txt b/failed.txt
index 5e73da6..3527fbe 100644
--- a/failed.txt
+++ b/failed.txt
@@ -1,13 +1,16 @@
-===== 7.8.0-dev (2020-04-09)
+===== 7.8.0-dev (2020-04-15)
$ grep -ar 'Tests failed' /var/lib/mock/scl80*/build.log
-/var/lib/mock/scl80el7x/build.log:Tests failed : 0
+/var/lib/mock/scl80el7x/build.log:Tests failed : 1
/var/lib/mock/scl80el8x/build.log:Tests failed : 16
-/var/lib/mock/scl80fc31x/build.log:Tests failed : 0
-/var/lib/mock/scl80fc32x/build.log:Tests failed : 0
+/var/lib/mock/scl80fc31x/build.log:Tests failed : 1
+/var/lib/mock/scl80fc32x/build.log:Tests failed : 1
+all
+ 2 Detailed reporting on specific types of syntax errors [tests/lang/syntax_errors.phpt]
+
(1) proc_open give erratic test results :(
(2) test issue (fixed upstream)
diff --git a/php.conf b/php.conf
index d192ccf..0639c0a 100644
--- a/php.conf
+++ b/php.conf
@@ -24,7 +24,7 @@ AddType text/html .php
DirectoryIndex index.php
# mod_php options
-<IfModule mod_php7.c>
+<IfModule mod_php.c>
#
# Cause the PHP interpreter to handle files with a .php extension.
#
diff --git a/php.conf2 b/php.conf2
index aeed80f..cdd7640 100644
--- a/php.conf2
+++ b/php.conf2
@@ -1,12 +1,14 @@
-# Redirect to local php-fpm if mod_php (5 or 7) is not available
+# Redirect to local php-fpm if mod_php (5, 7 or 8) is not available
<IfModule !mod_php5.c>
<IfModule !mod_php7.c>
- # Enable http authorization headers
- SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
+ <IfModule !mod_php.c>
+ # Enable http authorization headers
+ SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1
- <FilesMatch \.(php|phar)$>
- SetHandler "proxy:fcgi://127.0.0.1:9000"
- </FilesMatch>
+ <FilesMatch \.(php|phar)$>
+ SetHandler "proxy:fcgi://127.0.0.1:9000"
+ </FilesMatch>
+ </IfModule>
</IfModule>
</IfModule>
diff --git a/php.ini b/php.ini
index 96df66f..50e96c3 100644
--- a/php.ini
+++ b/php.ini
@@ -99,12 +99,12 @@
; Production Value: Off
; display_startup_errors
-; Default Value: Off
+; Default Value: On
; Development Value: On
; Production Value: Off
; error_reporting
-; Default Value: E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
+; Default Value: E_ALL
; Development Value: E_ALL
; Production Value: E_ALL & ~E_DEPRECATED & ~E_STRICT
@@ -458,7 +458,7 @@ memory_limit = 128M
; E_ALL & ~E_NOTICE (Show all errors, except for notices)
; E_ALL & ~E_NOTICE & ~E_STRICT (Show all errors, except for notices and coding standards warnings.)
; E_COMPILE_ERROR|E_RECOVERABLE_ERROR|E_ERROR|E_CORE_ERROR (Show only errors)
-; Default Value: E_ALL & ~E_NOTICE & ~E_STRICT & ~E_DEPRECATED
+; Default Value: E_ALL
; Development Value: E_ALL
; Production Value: E_ALL & ~E_DEPRECATED & ~E_STRICT
; http://php.net/error-reporting
@@ -482,11 +482,9 @@ error_reporting = E_ALL & ~E_DEPRECATED & ~E_STRICT
display_errors = Off
; The display of errors which occur during PHP's startup sequence are handled
-; separately from display_errors. PHP's default behavior is to suppress those
-; errors from clients. Turning the display of startup errors on can be useful in
-; debugging configuration problems. We strongly recommend you
-; set this to 'off' for production servers.
-; Default Value: Off
+; separately from display_errors. We strongly recommend you set this to 'off'
+; for production servers to avoid leaking configuration details.
+; Default Value: On
; Development Value: On
; Production Value: Off
; http://php.net/display-startup-errors
@@ -527,16 +525,6 @@ report_memleaks = On
; This setting is on by default.
;report_zend_debug = 0
-; Store the last error/warning message in $php_errormsg (boolean). Setting this value
-; to On can assist in debugging and is appropriate for development servers. It should
-; however be disabled on production servers.
-; This directive is DEPRECATED.
-; Default Value: Off
-; Development Value: Off
-; Production Value: Off
-; http://php.net/track-errors
-;track_errors = Off
-
; Turn off normal error reporting and emit XML-RPC error XML
; http://php.net/xmlrpc-errors
;xmlrpc_errors = 0
@@ -929,10 +917,10 @@ cli_server.color = On
;date.default_longitude = 35.2333
; http://php.net/date.sunrise-zenith
-;date.sunrise_zenith = 90.583333
+;date.sunrise_zenith = 90.833333
; http://php.net/date.sunset-zenith
-;date.sunset_zenith = 90.583333
+;date.sunset_zenith = 90.833333
[filter]
; http://php.net/filter.default
@@ -1009,8 +997,6 @@ pcre.jit=0
; http://php.net/pdo-odbc.connection-pooling
;pdo_odbc.connection_pooling=strict
-;pdo_odbc.db2_instance_name
-
[Pdo_mysql]
; Default socket name for local MySQL connects. If empty, uses the built-in
; MySQL defaults.
@@ -1490,11 +1476,6 @@ zend.assertions = -1
; http://php.net/assert.callback
;assert.callback = 0
-; Eval the expression with current error_reporting(). Set to true if you want
-; error_reporting(0) around the eval().
-; http://php.net/assert.quiet-eval
-;assert.quiet_eval = 0
-
[mbstring]
; language for internal character representation.
; This affects mb_send_mail() and mbstring.detect_order.
@@ -1544,17 +1525,6 @@ zend.assertions = -1
; http://php.net/mbstring.substitute-character
;mbstring.substitute_character = none
-; overload(replace) single byte functions by mbstring functions.
-; mail(), ereg(), etc are overloaded by mb_send_mail(), mb_ereg(),
-; etc. Possible values are 0,1,2,4 or combination of them.
-; For example, 7 for overload everything.
-; 0: No overload
-; 1: Overload mail() function
-; 2: Overload str*() functions
-; 4: Overload ereg*() functions
-; http://php.net/mbstring.func-overload
-;mbstring.func_overload = 0
-
; enable strict encoding detection.
; Default: Off
;mbstring.strict_detection = On
diff --git a/php.spec b/php.spec
index b5f90ff..f1efce2 100644
--- a/php.spec
+++ b/php.spec
@@ -97,9 +97,9 @@
%global with_zip 0
-%global gh_commit 636c827aa2f72deb6d4f431a95b39a182b32dbeb
+%global gh_commit ed179c2ef4ed4d371267da9d1b745df519ffa0d5
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20200409
+%global gh_date 20200415
%global gh_owner php
%global gh_project php-src
%global upver 8.0.0
@@ -109,7 +109,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -1371,7 +1371,7 @@ cp %{SOURCE9} modconf
%endif
# Dual config file with httpd >= 2.4 (RHEL >= 7)
-install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_modconfdir}/15-%{name}.conf
+install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_modconfdir}/20-%{name}.conf
install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
%if %{with_httpd2410}
cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
@@ -1664,7 +1664,7 @@ fi
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/opcache
%config(noreplace) %{_httpd_confdir}/%{name}.conf
-%config(noreplace) %{_httpd_modconfdir}/15-%{name}.conf
+%config(noreplace) %{_httpd_modconfdir}/20-%{name}.conf
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
@@ -1814,6 +1814,14 @@ fi
%changelog
+* Wed Apr 15 2020 Remi Collet <remi@remirepo.net> - 8.0.0~DEV.20200415-3
+- new snapshot
+
+* Fri Apr 10 2020 Remi Collet <remi@remirepo.net> - 8.0.0~DEV.20200409-2
+- new snapshot
+- refresh php.ini from upstream
+- rename 15-php80-php.conf to 20-php70-php.conf to ensure load order
+
* Thu Apr 9 2020 Remi Collet <remi@remirepo.net> - 8.0.0~DEV.20200409-1
- update to 8.0.0-dev