summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-21 15:23:08 +0200
committerRemi Collet <remi@php.net>2023-04-21 15:23:08 +0200
commit2a7e6586b1089fc85e026967df15733c31a4c22c (patch)
tree5315bd53c5243b1c2a6648950f24081b41d553af
parentb2e552a8de8011d9c148988e981b2a5ebeeed10b (diff)
use ICU 72.1
use oracle client library version 21.10 fix missing TZData version in intl phpinfo fix possible buffer overflow in date
-rw-r--r--php-8.0.10-systzdata-v21.patch3
-rw-r--r--php-8.0.28-intlinfo.patch33
-rw-r--r--php.spec19
3 files changed, 49 insertions, 6 deletions
diff --git a/php-8.0.10-systzdata-v21.patch b/php-8.0.10-systzdata-v21.patch
index 779f538..699dc11 100644
--- a/php-8.0.10-systzdata-v21.patch
+++ b/php-8.0.10-systzdata-v21.patch
@@ -5,6 +5,7 @@ Add support for use of the system timezone database, rather
than embedding a copy. Discussed upstream but was not desired.
History:
+r22: fix possible buffer overflow
r21: retrieve tzdata version from /usr/share/zoneinfo/tzdata.zi
r20: adapt for timelib 2020.03 (in 8.0.10RC1)
r19: adapt for timelib 2020.02 (in 8.0.0beta2)
@@ -454,7 +455,7 @@ index e9bd0f136d..c04ff01adc 100644
+ size_t n;
+ char *data, *p;
+
-+ data = malloc(3 * sysdb->index_size + 7);
++ data = malloc(3 * sysdb->index_size + sizeof(FAKE_HEADER) - 1);
+
+ p = mempcpy(data, FAKE_HEADER, sizeof(FAKE_HEADER) - 1);
+
diff --git a/php-8.0.28-intlinfo.patch b/php-8.0.28-intlinfo.patch
new file mode 100644
index 0000000..c4bf036
--- /dev/null
+++ b/php-8.0.28-intlinfo.patch
@@ -0,0 +1,33 @@
+From 0eeaba52f1900f5b3bc389ee0a44e2b70a7ab8f6 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 14 Apr 2023 10:23:21 +0200
+Subject: [PATCH] Fix GH-11071: Revert "Fix [-Wundef] warning in INTL
+ extension"
+
+This reverts commit ea8686540ac43e59dd3f8784e29a0c06e3446df2.
+---
+ ext/intl/php_intl.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/ext/intl/php_intl.c b/ext/intl/php_intl.c
+index 5826c2e3372f..a15e16604133 100644
+--- a/ext/intl/php_intl.c
++++ b/ext/intl/php_intl.c
+@@ -281,7 +281,7 @@ PHP_RSHUTDOWN_FUNCTION( intl )
+ /* {{{ PHP_MINFO_FUNCTION */
+ PHP_MINFO_FUNCTION( intl )
+ {
+-#ifndef UCONFIG_NO_FORMATTING
++#if !UCONFIG_NO_FORMATTING
+ UErrorCode status = U_ZERO_ERROR;
+ const char *tzdata_ver = NULL;
+ #endif
+@@ -292,7 +295,7 @@ PHP_MINFO_FUNCTION( intl )
+ #ifdef U_ICU_DATA_VERSION
+ php_info_print_table_row( 2, "ICU Data version", U_ICU_DATA_VERSION );
+ #endif
+-#ifndef UCONFIG_NO_FORMATTING
++#if !UCONFIG_NO_FORMATTING
+ tzdata_ver = ucal_getTZDataVersion(&status);
+ if (U_ZERO_ERROR == status) {
+ php_info_print_table_row( 2, "ICU TZData version", tzdata_ver);
diff --git a/php.spec b/php.spec
index 06e039d..0f77345 100644
--- a/php.spec
+++ b/php.spec
@@ -49,7 +49,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.8
+%global oraclever 21.10
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI), you can disable using --without tests
@@ -119,7 +119,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -187,6 +187,8 @@ Patch49: php-8.0.10-phar-sha.patch
Patch50: php-8.0.21-openssl3.patch
# use system libxcrypt, from 8.1
Patch51: php-8.0.13-crypt.patch
+# display TZData version for intl
+Patch52: php-8.0.28-intlinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -817,9 +819,9 @@ Summary: Internationalization extension for PHP applications
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 71
-BuildRequires: pkgconfig(icu-io) >= 71
-BuildRequires: pkgconfig(icu-uc) >= 71
+BuildRequires: pkgconfig(icu-i18n) >= 72
+BuildRequires: pkgconfig(icu-io) >= 72
+BuildRequires: pkgconfig(icu-uc) >= 72
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -971,6 +973,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
rm ext/openssl/tests/p12_with_extra_certs.p12
%endif
%patch51 -p1 -b .libxcrypt
+%patch52 -p1 -b .intlinfo
%patch91 -p1 -b .remi-oci8
@@ -1855,6 +1858,12 @@ fi
%changelog
+* Fri Apr 21 2023 Remi Collet <remi@remirepo.net> - 8.0.28-3
+- use ICU 72.1
+- use oracle client library version 21.10
+- fix missing TZData version in intl phpinfo
+- fix possible buffer overflow in date
+
* Tue Feb 21 2023 Remi Collet <remi@remirepo.net> - 8.0.28-2
- F38: enable imap extension