summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec21
1 files changed, 16 insertions, 5 deletions
diff --git a/php.spec b/php.spec
index 5d549bf..3bd7ddb 100644
--- a/php.spec
+++ b/php.spec
@@ -54,7 +54,7 @@
%global oraclelib 19.1
%global oracledir 19.19
%else
-%global oraclever 21.11
+%global oraclever 21.12
%global oraclelib 21.1
%global oracledir 21
%endif
@@ -117,7 +117,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 9%{?dist}
+Release: 10%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -157,6 +157,8 @@ Source53: 20-ffi.ini
Patch1: php-7.4.0-httpd.patch
Patch5: php-7.2.0-includedir.patch
Patch6: php-7.4.0-embed.patch
+# For libxml 2.12 from 8.1
+Patch7: php-7.4.33-libxml212.patch
Patch8: php-7.2.0-libdb.patch
Patch9: php-7.0.7-curl.patch
@@ -193,6 +195,8 @@ Patch206: php-cve-2023-3824.patch
# Fixes for tests (300+)
# Factory is droped from system tzdata
Patch300: php-7.0.10-datetests.patch
+# Make test slower
+Patch301: php-7.4.33-tests.patch
# WIP
@@ -851,9 +855,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 72
-BuildRequires: pkgconfig(icu-io) >= 72
-BuildRequires: pkgconfig(icu-uc) >= 72
+BuildRequires: pkgconfig(icu-i18n) >= 73
+BuildRequires: pkgconfig(icu-io) >= 73
+BuildRequires: pkgconfig(icu-uc) >= 73
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -949,6 +953,7 @@ in pure PHP.
%patch -P1 -p1 -b .mpmcheck
%patch -P5 -p1 -b .includedir
%patch -P6 -p1 -b .embed
+%patch -P7 -p1 -b .libxml212
%patch -P8 -p1 -b .libdb
%if 0%{?rhel} == 7
%patch -P9 -p1 -b .curltls
@@ -981,6 +986,7 @@ rm ext/openssl/tests/p12_with_extra_certs.p12
# Fixes for tests
%patch -P300 -p1 -b .datetests
+%patch -P301 -p1 -b .tests
# WIP patch
@@ -1867,6 +1873,11 @@ EOF
%changelog
+* Tue Dec 12 2023 Remi Collet <remi@remirepo.net> - 7.4.33-10
+- use ICU 73.2
+- use oracle client library version 21.12 on x86_64, 19.19 on aarch64
+- add fixes for libxml 2.11 and 2.12 from 8.1
+
* Thu Sep 21 2023 Remi Collet <remi@remirepo.net> - 7.4.33-9
- use oracle client library version 21.11 on x86_64, 19.19 on aarch64
- use official Oracle Instant Client RPM