summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec21
1 files changed, 15 insertions, 6 deletions
diff --git a/php.spec b/php.spec
index abd024e..16744c5 100644
--- a/php.spec
+++ b/php.spec
@@ -102,13 +102,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 7.4.0
-%global rcver RC1
-%global lower rc1
+%global rcver RC2
+%global lower rc2
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 18%{?dist}
+Release: 19%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -156,7 +156,7 @@ Patch42: php-7.3.3-systzdata-v18.patch
# See http://bugs.php.net/53436
Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
-Patch45: php-7.2.3-ldap_r.patch
+Patch45: php-7.4.0-ldap_r.patch
# Make php_config.h constant across builds
Patch46: php-7.2.4-fixheader.patch
# drop "Configure command" from phpinfo output
@@ -174,6 +174,7 @@ Patch91: php-7.2.0-oci8conf.patch
Patch300: php-7.0.10-datetests.patch
# WIP
+Patch100: https://github.com/php/php-src/commit/56e880af9f90c9d313292c75eb6df58cc9e7e208.patch
BuildRequires: gnupg2
BuildRequires: bzip2-devel
@@ -945,6 +946,7 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch300 -p1 -b .datetests
# WIP patch
+%patch100 -p1 -R
# Prevent %%doc confusion over LICENSE files
cp Zend/LICENSE Zend/ZEND_LICENSE
@@ -977,6 +979,8 @@ rm ext/date/tests/bug33414-1.phpt
rm ext/date/tests/bug33415-2.phpt
rm ext/date/tests/date_modify-1.phpt
%endif
+# too fast builder
+rm ext/date/tests/bug73837.phpt
# fails sometime
rm ext/sockets/tests/mcast_ipv?_recv.phpt
# Should be skipped but fails sometime
@@ -1307,7 +1311,7 @@ export NO_INTERACTION=1 REPORT_EXIT_STATUS=1 MALLOC_CHECK_=2
export SKIP_ONLINE_TESTS=1
export SKIP_IO_CAPTURE_TESTS=1
unset TZ LANG LC_ALL
-if ! make test TESTS=%{?_smp_mflags}; then
+if ! make test TESTS=-j4; then
set +x
for f in $(find .. -name \*.diff -type f -print); do
if ! grep -q XFAIL "${f/.diff/.phpt}"
@@ -1785,7 +1789,12 @@ fi
%changelog
-* Tue Sep 3 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc1-17
+* Tue Sep 17 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc2-19
+- update to 7.4.0RC2
+- add tarball signature check
+- reduce to 4 concurrent test workers
+
+* Tue Sep 3 2019 Remi Collet <remi@remirepo.net> - 7.4.0~rc1-18
- update to 7.4.0RC1
- bump API number to 20190902