summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec53
1 files changed, 34 insertions, 19 deletions
diff --git a/php.spec b/php.spec
index 4de1b9c..827528f 100644
--- a/php.spec
+++ b/php.spec
@@ -102,13 +102,13 @@
%global gh_owner php
%global gh_project php-src
%global upver 7.4.0
-%global rcver alpha3
-%global lower alpha3
+%global rcver beta1
+%global lower beta1
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 13%{?dist}
+Release: 14%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -163,7 +163,6 @@ Patch47: php-5.6.3-phpinfo.patch
Patch91: php-7.2.0-oci8conf.patch
# Upstream fixes (100+)
-Patch100: php-upstream.patch
# Security fixes (200+)
@@ -215,17 +214,28 @@ BuildRequires: /bin/ps
Requires: httpd-mmn = %{_httpd_mmn}
Provides: %{?scl_prefix}mod_php = %{version}-%{release}
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-# For backwards-compatibility, require php-cli for the time being:
-Requires: %{?scl_prefix}php-cli%{?_isa} = %{version}-%{release}
# To ensure correct /var/lib/php/session ownership:
%if %{with_httpd2410}
Requires(pre): httpd-filesystem
%else
Requires(pre): httpd
%endif
+
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
+# For backwards-compatibility, pull the "php" command
+Recommends: %{?scl_prefix}php-cli%{?_isa} = %{version}-%{release}
# httpd have threaded MPM by default
-Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-fpm%{?_isa} = %{version}-%{release}
+# as "php" is now mostly a meta-package, commonly used extensions
+Recommends: %{?scl_prefix}php-json%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-mbstring%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-opcache%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-pdo%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-sodium%{?_isa} = %{version}-%{release}
+Recommends: %{?scl_prefix}php-xml%{?_isa} = %{version}-%{release}
+%else
+# For backwards-compatibility, require php-cli for the time being:
+Requires: %{?scl_prefix}php-cli%{?_isa} = %{version}-%{release}
%endif
@@ -698,11 +708,6 @@ License: PHP
License: PHP and BSD
%endif
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-# Required to build the bundled GD library
-BuildRequires: pkgconfig(libjpeg)
-BuildRequires: pkgconfig(libpng)
-BuildRequires: pkgconfig(freetype2)
-BuildRequires: pkgconfig(xpm)
%if %{with_libgd}
BuildRequires: pkgconfig(gdlib) >= 2.1.1
%if 0%{?fedora} <= 19 && 0%{?rhel} <= 7
@@ -711,6 +716,12 @@ Requires: gd-last%{?_isa} >= 2.1.1
Requires: gd%{?_isa} >= 2.1.1
%endif
%else
+# Required to build the bundled GD library
+BuildRequires: pkgconfig(zlib)
+BuildRequires: pkgconfig(libjpeg)
+BuildRequires: pkgconfig(libpng)
+BuildRequires: pkgconfig(freetype2)
+BuildRequires: pkgconfig(xpm)
BuildRequires: pkgconfig(libwebp)
Provides: bundled(gd) = 2.0.35
%endif
@@ -899,8 +910,6 @@ in pure PHP.
%setup -q -n php-%{upver}%{?rcver}
%endif
-rm -r ext/recode
-
%patch1 -p1 -b .mpmcheck
%patch5 -p1 -b .includedir
%patch6 -p1 -b .embed
@@ -923,7 +932,6 @@ sed -e 's/php-devel/%{?scl_prefix}php-devel/' -i scripts/phpize.in
%patch91 -p1 -b .remi-oci8
# upstream patches
-%patch100 -p1 -b .up
# security patches
@@ -1112,11 +1120,7 @@ ln -sf ../configure
--disable-rpath \
--without-pear \
--with-exec-dir=%{_bindir} \
- --with-freetype \
- --with-png \
- --with-xpm \
--without-gdbm \
- --with-jpeg \
--with-openssl \
--with-system-ciphers \
%if %{with_libpcre}
@@ -1162,6 +1166,10 @@ build --libdir=%{_libdir}/php \
--with-external-gd \
%else
--enable-gd=shared \
+ --with-webp \
+ --with-jpeg \
+ --with-xpm \
+ --with-freetype \
%endif
--with-gmp=shared \
--enable-calendar=shared \
@@ -1771,6 +1779,13 @@ fi
%changelog
+* Tue Jul 23 2019 Remi Collet <remi@remirepo.net> - 7.4.0~beta1-14
+- update to 7.4.0beta1
+- main package now recommends commonly used extensions and SAPI
+ (json, mbstring, opcache, pdo, xml)
+- fix gd build options and dependencies
+- refresh provided configuration from upstream production values
+
* Fri Jul 12 2019 Remi Collet <remi@remirepo.net> - 7.4.0~alpha3-13
- drop recode extension, moved to php-pecl-recode
- add upstream patch for argon2 password