summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec17
1 files changed, 11 insertions, 6 deletions
diff --git a/php.spec b/php.spec
index 7a6dfaa..02c4131 100644
--- a/php.spec
+++ b/php.spec
@@ -49,7 +49,7 @@
%global mysql_sock %(mysql_config --socket 2>/dev/null || echo /var/lib/mysql/mysql.sock)
-%global oraclever 21.6
+%global oraclever 21.7
%global oraclelib 21.1
# Build for LiteSpeed Web Server (LSAPI)
@@ -104,7 +104,7 @@
#global gh_date 20190612
%global gh_owner php
%global gh_project php-src
-%global upver 7.4.30
+%global upver 7.4.32
#global rcver RC1
Summary: PHP scripting language for creating dynamic web sites
@@ -300,7 +300,6 @@ Group: Development/Languages
Summary: PHP FastCGI Process Manager
BuildRequires: libacl-devel
BuildRequires: pkgconfig(libsystemd) >= 209
-Requires(pre): %{_root_sbindir}/useradd
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
%{?systemd_requires}
# This is actually needed for the %%triggerun script but Requires(triggerun)
@@ -313,6 +312,8 @@ Requires(pre): httpd-filesystem
# For php.conf in /etc/httpd/conf.d
# and version 2.4.10 for proxy support in SetHandler
Requires: httpd-filesystem >= 2.4.10
+%else
+Requires(pre): %{_root_sbindir}/useradd
%endif
%description fpm
@@ -828,9 +829,9 @@ Group: System Environment/Libraries
# All files licensed under PHP version 3.01
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
-BuildRequires: pkgconfig(icu-i18n) >= 69
-BuildRequires: pkgconfig(icu-io) >= 69
-BuildRequires: pkgconfig(icu-uc) >= 69
+BuildRequires: pkgconfig(icu-i18n) >= 71
+BuildRequires: pkgconfig(icu-io) >= 71
+BuildRequires: pkgconfig(icu-uc) >= 71
%description intl
The %{?scl_prefix}php-intl package contains a dynamic shared object that will add
@@ -1828,6 +1829,10 @@ fi
%changelog
+* Wed Sep 28 2022 Remi Collet <remi@remirepo.net> - 7.4.32-1
+- Update to 7.4.32 - http://www.php.net/releases/7_4_32.php
+- use ICU 71.1
+
* Tue Jun 7 2022 Remi Collet <remi@remirepo.net> - 7.4.30-1
- Update to 7.4.30 - http://www.php.net/releases/7_4_30.php
- use oracle client library version 21.6