summaryrefslogtreecommitdiffstats
path: root/php.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-05-22 16:30:43 +0200
committerRemi Collet <remi@remirepo.net>2019-05-22 16:30:43 +0200
commit7b8aac46006ce57fb0056ea4bd8b6e79ee55fe3e (patch)
tree56808826771589925d5ec18cd92dea7ee3e50f17 /php.spec
parent1980e23d65c295d7a9ff5026a7f01612b52e4458 (diff)
new snapshot with configuration updated from upstream
Diffstat (limited to 'php.spec')
-rw-r--r--php.spec53
1 files changed, 17 insertions, 36 deletions
diff --git a/php.spec b/php.spec
index d14c14d..24688e5 100644
--- a/php.spec
+++ b/php.spec
@@ -96,9 +96,9 @@
%global with_zip 0
-%global gh_commit 9ef03a94ba68be0f8bae36f46c4763ba3c88a02a
+%global gh_commit 7f68d5b7d8fd23f719078e0c37055558411aad07
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 20190521
+%global gh_date 20190522
%global gh_owner php
%global gh_project php-src
%global upver 7.4.0
@@ -108,7 +108,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?lower:~%{lower}}%{?gh_date:.%{gh_date}}
-Release: 2%{?dist}
+Release: 3%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -139,6 +139,7 @@ Source12: php-fpm.wants
Source50: 10-opcache.ini
Source51: opcache-default.blacklist
Source52: 20-oci8.ini
+Source53: 20-ffi.ini
# Build fixes
Patch1: php-7.1.7-httpd.patch
@@ -329,8 +330,8 @@ Summary: Common files for PHP
# regex, libmagic are licensed under BSD
License: PHP and BSD
# ABI/API check - Arch specific
-Provides: %{?scl_prefix}php(api) = %{apiver}%{isasuffix}
-Provides: %{?scl_prefix}php(zend-abi) = %{zendver}%{isasuffix}
+Provides: %{?scl_prefix}php(api) = %{apiver}-%{__isa_bits}
+Provides: %{?scl_prefix}php(zend-abi) = %{zendver}-%{__isa_bits}
Provides: %{?scl_prefix}php(language) = %{version}
Provides: %{?scl_prefix}php(language)%{?_isa} = %{version}
# Provides for all builtin/shared modules:
@@ -454,8 +455,8 @@ Group: Development/Languages
License: PHP
Requires: %{?scl_prefix}php-common%{?_isa} = %{version}-%{release}
# ABI/API check - Arch specific
-Provides: %{?scl_prefix}php-pdo-abi = %{pdover}%{isasuffix}
-Provides: %{?scl_prefix}php(pdo-abi) = %{pdover}%{isasuffix}
+Provides: %{?scl_prefix}php-pdo-abi = %{pdover}-%{__isa_bits}
+Provides: %{?scl_prefix}php(pdo-abi) = %{pdover}-%{__isa_bits}
%if %{with_sqlite3}
Provides: %{?scl_prefix}php-sqlite3, %{?scl_prefix}php-sqlite3%{?_isa}
%endif
@@ -1040,9 +1041,9 @@ find . -name \*.[ch] -exec chmod 644 {} \;
chmod 644 README.*
# Create the macros.php files
-sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
- -e "s/@PHP_ZENDVER@/%{zendver}%{isasuffix}/" \
- -e "s/@PHP_PDOVER@/%{pdover}%{isasuffix}/" \
+sed -e "s/@PHP_APIVER@/%{apiver}-%{__isa_bits}/" \
+ -e "s/@PHP_ZENDVER@/%{zendver}-%{__isa_bits}/" \
+ -e "s/@PHP_PDOVER@/%{pdover}-%{__isa_bits}/" \
-e "s/@PHP_VERSION@/%{upver}/" \
-e "s:@LIBDIR@:%{_libdir}:" \
-e "s:@ETCDIR@:%{_sysconfdir}:" \
@@ -1054,28 +1055,14 @@ sed -e "s/@PHP_APIVER@/%{apiver}%{isasuffix}/" \
echo '%%%{?scl:%{scl}_}pecl_xmldir %{_localstatedir}/lib/php/peclxml' | tee -a macros.php
%endif
-# php-fpm configuration files for tmpfiles.d
-# TODO echo "d /run/php-fpm 755 root root" >php-fpm.tmpfiles
-
# Some extensions have their own configuration file
-cp %{SOURCE50} 10-opcache.ini
-%if 0%{?rhel} != 6
-cat << EOF >>10-opcache.ini
-
-; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
-; This should improve performance, but requires appropriate OS configuration.
-opcache.huge_code_pages=0
-EOF
+cp %{SOURCE50} %{SOURCE51} %{SOURCE52} %{SOURCE53} .
%ifarch x86_64
sed -e '/opcache.huge_code_pages/s/0/1/' -i 10-opcache.ini
%endif
-%endif
-tail -n 5 10-opcache.ini
-cp %{SOURCE51} .
sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
-i 10-opcache.ini
-cp %{SOURCE52} 20-oci8.ini
%if 0%{!?scl:1}
: SCL macro not defined
@@ -1179,9 +1166,6 @@ build --libdir=%{_libdir}/php \
--enable-pcntl \
--enable-opcache \
--enable-opcache-file \
-%if 0%{?rhel} == 6
- --disable-huge-code-pages \
-%endif
--enable-phpdbg \
%if %{with_imap}
--with-imap=shared --with-imap-ssl \
@@ -1361,6 +1345,8 @@ make -C build-cgi install \
# Install the default configuration file
install -m 755 -d $RPM_BUILD_ROOT%{_sysconfdir}/
install -m 644 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
+sed -e 's:%{_root_sysconfdir}:%{_sysconfdir}:' \
+ -i $RPM_BUILD_ROOT%{_sysconfdir}/php.ini
# For third-party packaging:
install -m 755 -d $RPM_BUILD_ROOT%{_datadir}/php
@@ -1378,18 +1364,12 @@ ln -s %{_httpd_moddir}/libphp7.so $RPM_BUILD_ROOT%{_root_httpd_moddir}/lib%
cp %{SOURCE9} modconf
%endif
-%if "%{_httpd_modconfdir}" == "%{_httpd_confdir}"
-# Single config file with httpd < 2.4 (RHEL <= 6)
-install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-cat %{SOURCE1} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
-%else
# Dual config file with httpd >= 2.4 (RHEL >= 7)
install -D -m 644 modconf $RPM_BUILD_ROOT%{_httpd_modconfdir}/15-%{name}.conf
install -D -m 644 %{SOURCE1} $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
%if %{with_httpd2410}
cat %{SOURCE10} >>$RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
%endif
-%endif
sed -e 's:/var/lib:%{_localstatedir}/lib:' \
-i $RPM_BUILD_ROOT%{_httpd_confdir}/%{name}.conf
@@ -1663,9 +1643,7 @@ fi
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/wsdlcache
%attr(0770,root,apache) %dir %{_localstatedir}/lib/php/opcache
%config(noreplace) %{_httpd_confdir}/%{name}.conf
-%if "%{_httpd_modconfdir}" != "%{_httpd_confdir}"
%config(noreplace) %{_httpd_modconfdir}/15-%{name}.conf
-%endif
%files common -f files.common
%doc EXTENSIONS NEWS UPGRADING* README.REDIST.BINS *md docs
@@ -1817,6 +1795,9 @@ fi
%changelog
+* Wed May 22 2019 Remi Collet <remi@remirepo.net> - 7.4.0~DEV.20190522-3
+- new snapshot with configuration updated from upstream
+
* Tue May 21 2019 Remi Collet <remi@remirepo.net> - 7.4.0~DEV.20190521-2
- new snapshot for enchant and sodium fix