summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-06 14:20:47 +0200
committerRemi Collet <remi@remirepo.net>2020-07-06 14:20:47 +0200
commita7017e9f2e9a7705242674f106e889ac48e63fbd (patch)
treeb3db49742abcb8c6c26c1a57cf46fb3a08c81951
parent3e9831e33b7a438a56b5bbb4261237897dc0f129 (diff)
display build system and provider in phpinfo (from 8.0)
-rw-r--r--php-5.6.3-phpinfo.patch29
-rw-r--r--php-7.4.8-phpinfo.patch76
-rw-r--r--php.spec12
3 files changed, 86 insertions, 31 deletions
diff --git a/php-5.6.3-phpinfo.patch b/php-5.6.3-phpinfo.patch
deleted file mode 100644
index 086be15..0000000
--- a/php-5.6.3-phpinfo.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-
-Drop "Configure Command" from phpinfo as it doesn't
-provide any useful information.
-The available extensions are not related to this command.
-
-diff -up php-7.0.0RC1/ext/standard/info.c.phpinfo php-7.0.0RC1/ext/standard/info.c
---- php-7.0.0RC1/ext/standard/info.c.phpinfo 2015-08-18 23:39:24.000000000 +0200
-+++ php-7.0.0RC1/ext/standard/info.c 2015-08-22 07:56:18.344761928 +0200
-@@ -870,9 +870,6 @@ PHPAPI void php_print_info(int flag)
- #ifdef ARCHITECTURE
- php_info_print_table_row(2, "Architecture", ARCHITECTURE);
- #endif
--#ifdef CONFIGURE_COMMAND
-- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
--#endif
-
- if (sapi_module.pretty_name) {
- php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
-diff -up php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt
---- php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo 2015-08-18 23:39:22.000000000 +0200
-+++ php-7.0.0RC1/ext/standard/tests/general_functions/phpinfo.phpt 2015-08-22 07:56:18.344761928 +0200
-@@ -20,7 +20,6 @@ PHP Version => %s
-
- System => %s
- Build Date => %s%a
--Configure Command => %s
- Server API => Command Line Interface
- Virtual Directory Support => %s
- Configuration File (php.ini) Path => %s
diff --git a/php-7.4.8-phpinfo.patch b/php-7.4.8-phpinfo.patch
new file mode 100644
index 0000000..9b7175e
--- /dev/null
+++ b/php-7.4.8-phpinfo.patch
@@ -0,0 +1,76 @@
+
+Drop "Configure Command" from phpinfo as it doesn't
+provide any useful information.
+The available extensions are not related to this command.
+
+diff -up a/ext/standard/info.c.phpinfo v/ext/standard/info.c
+--- a/ext/standard/info.c.phpinfo 2015-08-18 23:39:24.000000000 +0200
++++ b/ext/standard/info.c 2015-08-22 07:56:18.344761928 +0200
+@@ -809,9 +809,6 @@ PHPAPI void php_print_info(int flag)
+ #ifdef ARCHITECTURE
+ php_info_print_table_row(2, "Architecture", ARCHITECTURE);
+ #endif
+-#ifdef CONFIGURE_COMMAND
+- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
+-#endif
+
+ if (sapi_module.pretty_name) {
+ php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
+diff -up a/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo b/ext/standard/tests/general_functions/phpinfo.phpt
+--- a/ext/standard/tests/general_functions/phpinfo.phpt.phpinfo 2015-08-18 23:39:22.000000000 +0200
++++ b/ext/standard/tests/general_functions/phpinfo.phpt 2015-08-22 07:56:18.344761928 +0200
+@@ -20,7 +20,6 @@ PHP Version => %s
+
+ System => %s
+ Build Date => %s%a
+-Configure Command => %s
+ Server API => Command Line Interface
+ Virtual Directory Support => %s
+ Configuration File (php.ini) Path => %s
+
+
+Backported from 8.0:
+
+From ad0d2e438fddc089917e71e5d8909d145db9da8a Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Fri, 3 Jul 2020 10:08:09 +0200
+Subject: [PATCH] display info about system used to build and its provider
+
+---
+ configure.ac | 5 +++++
+ ext/standard/info.c | 6 ++++++
+ 2 files changed, 11 insertions(+)
+
+diff --git a/configure.ac b/configure.ac
+index d9e6329314a3..77f12a55569a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -1328,6 +1328,11 @@ PHP_UNAME=${PHP_UNAME:-$UNAME}
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
++PHP_BUILD_SYSTEM=${PHP_BUILD_SYSTEM:-$PHP_UNAME}
++AC_DEFINE_UNQUOTED(PHP_BUILD_SYSTEM,"$PHP_BUILD_SYSTEM",[builder uname output])
++if test -n "${PHP_BUILD_PROVIDER}"; then
++ AC_DEFINE_UNQUOTED(PHP_BUILD_PROVIDER,"$PHP_BUILD_PROVIDER",[build provider])
++fi
+
+ PHP_SUBST_OLD(PHP_INSTALLED_SAPIS)
+
+diff --git a/ext/standard/info.c b/ext/standard/info.c
+index 262e95ae2731..f652efd23657 100644
+--- a/ext/standard/info.c
++++ b/ext/standard/info.c
+@@ -803,6 +803,12 @@ PHPAPI ZEND_COLD void php_print_info(int flag)
+ php_info_print_table_start();
+ php_info_print_table_row(2, "System", ZSTR_VAL(php_uname));
+ php_info_print_table_row(2, "Build Date", __DATE__ " " __TIME__);
++#ifdef PHP_BUILD_SYSTEM
++ php_info_print_table_row(2, "Build System", PHP_BUILD_SYSTEM);
++#endif
++#ifdef PHP_BUILD_PROVIDER
++ php_info_print_table_row(2, "Build Provider", PHP_BUILD_PROVIDER);
++#endif
+ #ifdef COMPILER
+ php_info_print_table_row(2, "Compiler", COMPILER);
+ #endif
diff --git a/php.spec b/php.spec
index 9ff483f..8fed7ce 100644
--- a/php.spec
+++ b/php.spec
@@ -107,7 +107,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: %{?scl_prefix}php
Version: %{upver}%{?rcver:~%{rcver}}%{?gh_date:.%{gh_date}}
-Release: 1%{?dist}
+Release: 2%{?dist}
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
# TSRM is licensed under BSD
@@ -157,7 +157,8 @@ Patch43: php-7.4.0-phpize.patch
# Use -lldap_r for OpenLDAP
Patch45: php-7.4.0-ldap_r.patch
# drop "Configure command" from phpinfo output
-Patch47: php-5.6.3-phpinfo.patch
+# and add build system and provider (from 8.0)
+Patch47: php-7.4.8-phpinfo.patch
# RC Patch
Patch91: php-7.2.0-oci8conf.patch
@@ -1071,6 +1072,10 @@ exit 1
# Set build date from https://reproducible-builds.org/specs/source-date-epoch/
export SOURCE_DATE_EPOCH=$(date +%s -r NEWS)
export PHP_UNAME=$(uname)
+export PHP_BUILD_SYSTEM=$(cat /etc/redhat-release | sed -e 's/ Beta//')
+%if 0%{?vendor:1}
+export PHP_BUILD_PROVIDER="%{vendor}"
+%endif
# Force use of system libtool:
libtoolize --force --copy
@@ -1800,6 +1805,9 @@ fi
%changelog
+* Mon Jul 6 2020 Remi Collet <remi@remirepo.net> - 7.4.8~RC1-2
+- display build system and provider in phpinfo (from 8.0)
+
* Tue Jun 23 2020 Remi Collet <remi@remirepo.net> - 7.4.8~RC1-1
- update to 7.4.8RC1
- drop patch to fix PHP_UNAME